<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xml:lang="en" lang="en" version="XHTML+RDFa 1.0" dir="ltr"
  xmlns:fb="http://ogp.me/ns/fb#"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="fb:pages" content="53844953429"/><meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo"/><script type="text/javascript" async="1" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="d0494fd0-8921-497a-8323-e3d29775ce1b" />
</script><link rel="amphtml" href="https://www.nba.com/amp/hornets/press-releases/charlotte-hornets-announce-medical-staff-additions" />
<link rel="shortcut icon" href="https://www.nba.com/hornets/sites/all/themes/etowah_radix/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="timestamp" content="1634450531" />
<meta name="is_https" content="true" />
<meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Charlotte Hornets Announce Medical Staff Additions","url":"https:\/\/www.nba.com\/hornets\/press-releases\/charlotte-hornets-announce-medical-staff-additions","dateCreated":"2021-10-16T18:45:00Z","articleSection":"Press Releases","creator":["qwash"],"keywords":["Hornets"],"author":["qwash"],"datePublished":"2021-10-16T18:45:00Z","image":"https:\/\/www.nba.com\/hornets\/sites\/hornets\/files\/777x442_pr_text.jpg","publisher":{"@type":"Organization","name":"NBA.com\/hornets","logo":{"@type":"ImageObject","url":"https:\/\/www.nba.com\/.element\/img\/1.0\/teamsites\/logos\/teamlogos_500x500\/CHA.png","width":180,"height":60}},"dateModified":"2021-10-16T18:46:10Z","mainEntityOfPage":"https:\/\/www.nba.com\/hornets\/press-releases\/charlotte-hornets-announce-medical-staff-additions","thumbnailUrl":"https:\/\/www.nba.com\/hornets\/sites\/hornets\/files\/777x442_pr_text.jpg"}</script>
<script type="text/javascript">var turner_metadata = {
        teamPageType        : "custom",
        turnerId            : "aa41822-1193725393-1389694715530-1",
        entity              : "nba:team:hornets",
        analyticsVersion    : "2.0",
        appName             : "app:nba - desktop",
        registrationState   : "not signed in",
        page                : "nba:team:hornets:features:Charlotte Hornets Announce Medical Staff Additions",
        section             : "nba:team:hornets:features",
        subsection          :  "hornets:features",
        articleCategory     : "Press Releases",
        articleTitle        : "Charlotte Hornets Announce Medical Staff Additions",
        articleAuthor       : "qwash",
        articlePublishDate  : "10/16/2021",
        articleTags         : "Hornets, Press Release, Press Releases",
        eventPageView       : "1",
        offsiteSource       : "Team Site"
      };</script>
<meta name="description" content="October 16, 2021 – Charlotte Hornets President of Basketball Operations &amp; General Manager Mitch Kupchak announced today that the team has named Daniel Taylor Director of Applied Sports Science, Jameel Battle Director of Rehabilitation and Nina Hsieh Assistant Athletic Trainer. All three individuals join the Hornets Medical Staff under the team’s Medical Director Joe Sharpe." />
<script type="text/javascript" src="https://assets.adobedtm.com/82bf3c13a525/5c242dc5adef/launch-f8e9806a0236.min.js" async></script>
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.nba.com/hornets/press-releases/charlotte-hornets-announce-medical-staff-additions" />
<link rel="shortlink" href="https://www.nba.com/hornets/node/47824" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="Charlotte Hornets" />
<meta property="og:title" content="Charlotte Hornets Announce Medical Staff Additions | Charlotte Hornets" />
<meta property="og:url" content="https://www.nba.com/hornets/press-releases/charlotte-hornets-announce-medical-staff-additions" />
<meta property="og:description" content="October 16, 2021 – Charlotte Hornets President of Basketball Operations &amp; General Manager Mitch Kupchak announced today that the team has named Daniel Taylor Director of Applied Sports Science, Jameel Battle Director of Rehabilitation and Nina Hsieh Assistant Athletic Trainer. All three individuals join the Hornets Medical Staff under the team’s Medical Director Joe Sharpe." />
<meta property="og:image" content="https://www.nba.com/hornets/sites/hornets/files/777x442_pr_text.jpg?cw=700&amp;ch=500&amp;w=879&amp;h=500&amp;x=90&amp;y=0" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.nba.com/hornets/press-releases/charlotte-hornets-announce-medical-staff-additions" />
<meta name="twitter:title" content="Charlotte Hornets Announce Medical Staff Additions | Charlotte Hornets" />
<meta name="twitter:description" content="October 16, 2021 – Charlotte Hornets President of Basketball Operations &amp; General Manager Mitch Kupchak announced today that the team has named Daniel Taylor Director of Applied Sports Science," />
<meta name="twitter:image" content="https://www.nba.com/hornets/sites/hornets/files/777x442_pr_text.jpg?cw=700&amp;ch=500&amp;w=879&amp;h=500&amp;x=90&amp;y=0" />
  <title>Charlotte Hornets Announce Medical Staff Additions | Charlotte Hornets</title>
  <link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_0J0j30EHY_O6fG4oQYo28pnf_7_Gja3PE01Da8Xgcec.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_AlWLDw5zK9c_n8B2pWtHr5RJTDmwgoArH9iWu9TJG7g.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_6klLCvmTSl9w4XMlHaw6MYpLQ8D5ls8B1E22Jqr3JVs.css" media="screen" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_EQSNwepYouWKOvu8Eko5wFL3JnXbvbqve3GoRghCcsE.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_wcRQzRoU7NZ_T6Cz359M6LmJlA2_v54CK9A4l5i9rtU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://turnip.cdn.turner.com/top/player-ui/2.3.0-1/player-ui.min.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_FLGsFUpM4GrY2aDhzAyqMcR8LMjMr9B4rTbxvTant0A.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/all/themes/etowah_radix/assets/stylesheets/ie8_fallback.css?r132sy" media="all" />
<![endif]-->

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/all/themes/etowah_radix/assets/stylesheets/ie7_fallback.css?r132sy" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/all/themes/etowah_radix/assets/stylesheets/bootstrap.css?r132sy" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/all/themes/etowah_radix/assets/stylesheets/screen.css?r132sy" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_T-TZfTydUwB664EEKJHDcuk7jy4tISCzGTq3m7vhy9Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_OtwcE6kawdd53FXsEIMJnPfgyVgYWQHGWZBiSees_yo.css" media="print" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/colorizer/etowah_radix-6e8ec42d.css" media="all" />
<style type="text/css" media="(min-width: 640px)">
<!--/*--><![CDATA[/*><!--*/
.page{background-image:url(https://www.nba.com/hornets/sites/hornets/files/hornets_generic_web_skin.jpg)}

/*]]>*/-->
</style>
<style type="text/css" media="(-webkit-min-device-pixel-ratio: 2) and (min-width: 640px), (min-resolution: 192dpi) and (min-width: 640px)">
<!--/*--><![CDATA[/*><!--*/
.page{background-image:url(https://www.nba.com/hornets/sites/hornets/files/hornets_generic_web_skin.jpg);background-size :4500px auto}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/css/css_nXOVDoQeELbgAUa9CTrDwn-1L8XJar8bsVQYPtgNC3c.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/hornets/sites/hornets/files/sitewide_overrides/active/etowah_swo_80646/style_sitewide_overrides.css?r132sy" media="all" />
    <script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_sOTmJnDhZ0YaYTQBr9FPewnH0WbS6pH--oA8_JDPY0w.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var jQuery1111 = jQuery.noConflict(); var jQuery111 = jQuery1111;
//--><!]]>
</script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_zS-CmNFGyegtLYJmqFRpxQvvQrfPIFrOMq_3T3C8sZE.js"></script>
<script type="text/javascript" src="//www.nba.com/javascriptGlobalSettings.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_eAtNCuh9Vfx9qN14qMJAChJnBHm5P4auvYGH7pl0im8.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_QmJ3ajIz-wSPb_FJengDTA5QzpFegWrdnhLICfxXYtM.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_lIrYjw88ZYMAOjUr6Bw4pOWhZwMOgtLzjxtc8yN7yLc.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_zykj1GuJRnNxoDrLXuFv6n-3vBWcf_mN56NiBXbkjgk.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_RUl525ZJlhTXbT69JUWad71UhhrjIMfJDJcEGJL1ZuA.js"></script>
<script type="text/javascript" src="https://turnip.cdn.turner.com/top/player/2.3.0-1/player.min.js"></script>
<script type="text/javascript" src="https://turnip.cdn.turner.com/top/auth/2.3.0-1/auth.min.js"></script>
<script type="text/javascript" src="https://i.cdn.turner.com/ads/adfuel/ais/2.1/nba-teams-ais.min.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_16s4a3bPvUxjRQYFHA58_6ovzWEKfa9ukGeXCF2j-fQ.js"></script>
<script type="text/javascript" src="//agility.nba.com/turner/nba-prod/Bootstrap.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/sitewide_overrides/active/etowah_swo_80646/header_sitewide_overrides.js?r132sy"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_O-8YMkEHkTJ_L_8yhpg2uFQGunL4rJ_A62ML0Znf6o8.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]>
   <script>
      document.createElement('header');
      document.createElement('nav');
      document.createElement('section');
      document.createElement('article');
      document.createElement('aside');
      document.createElement('footer');
   </script>
   <link id="respond-proxy" rel="respond-proxy" href="http://i.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="http://z.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="https://s.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-redirect" rel="respond-redirect" href="https://www.nba.com/hornets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.gif" />
   <script type="text/javascript" src="https://www.nba.com/hornets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.min.js" />
<script type="text/javascript" src="https://www.nba.com/hornets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/src/respond.min.js" />
<script type="text/javascript" src="https://www.nba.com/hornets/sites/all/themes/etowah_radix/assets/javascripts/vendor/selectivizr-min.js" />
  <![endif]-->

</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-47824 node-type-story region-content">
  <div id="skip-link">
    <a tabindex="1" href="#content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    
<header class="header" role="header">
  <nav class="global-nav-wrapper">
    <div class="container">
    <!--Top of the page navigation and NBA logo -->
      <div class="row">
        <div class="col-xs-12">
          <div class="utility-logo">
            <a tabindex="1" href = "http://www.nba.com"><span class="element-invisible">NBA</span></a>
          </div>
          <ul class="global-nav">
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/" class="teamNavGlobal global-nav__hidden-xs" title="Link to NBA Global">Global</a></li>
            <li class="global-nav__menu-item expanded has-dropdown">
              <a tabindex="1" href="javascript:void(0)" id="global-nav__menu-item__teams-link">Teams</a>
              <ul class="global-nav__menu-item__sub-menu" id="global-nav__menu-item__teams-link-dropdown">
                <li><a class="global-nav__menu-item__sub-menu__sub-item" href="http://www.nba.com/teams/" title="Link to NBA Teams">Teams</a></li>
                <li class="teamHDR">Team Sites</li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hawks/" title="Link to Atlanta Hawks Team Site">Atlanta</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/heat/" title="Link to Miami Heat Team Site">Miami</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/celtics/" title="Link to Boston Celtics Team Site">Boston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bucks/" title="Link to Milwaukee Bucks Team Site">Milwaukee</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nets/" title="Link to Brooklyn Nets Team Site">Brooklyn</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/timberwolves/" title="Link to Minnesota Timberwolves Team Site">Minnesota</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hornets/" title="Link to Charlotte Hornets Team Site">Charlotte</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pelicans/" title="Link to New Orleans Pelicans Team Site">New Orleans</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bulls/" title="Link to Chicago Bulls Team Site">Chicago</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/knicks/" title="Link to New York Knicks Team Site">New York</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/cavaliers/" title="Link to Cleveland Cavaliers Team Site">Cleveland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/thunder/" title="Link to Oklahoma City Thunder Team Site">Oklahoma City</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/mavericks/" title="Link to Dallas Mavericks Team Site">Dallas</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/magic/" title="Link to Orlando Magic Team Site">Orlando</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nuggets/" title="Link to Denver Nuggets Team Site">Denver</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/sixers/" title="Link to Philadelphia 76ers Team Site">Philadelphia</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pistons/" title="Link to Detroit Pistons Team Site">Detroit</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/suns/" title="Link to Phoenix Suns Team Site">Phoenix</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/warriors/" title="Link to Golden State Warriors Team Site">Golden State</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/blazers/" title="Link to Portland Blazers Team Site">Portland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/rockets/" title="Link to Houston Rockets Team Site">Houston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/kings/" title="Link to Sacramento Kings Team Site">Sacramento</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pacers/" title="Link to Indiana Pacers Team Site">Indiana</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/spurs/" title="Link to San Antonio Spurs Team Site">San Antonio</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/clippers/" title="Link to LA Clippers Team Site">LA Clippers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/raptors/" title="Link to Toronto Raptors Team Site">Toronto</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/lakers/" title="Link to LA Lakers Team Site">LA Lakers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/jazz/" title="Link to Utah Jazz Team Site">Utah</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/grizzlies/" title="Link to Memphis Grizzlies Team Site">Memphis</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/wizards/" title="Link to Washington Wizards Team Site">Washington</a></li>
              </ul>
            </li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://gleague.nba.com" title="Link to G League">G League</a></li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://www.wnba.com" title="Link to WNBA" class="teamNavWNBA">WNBA</a></li>
            <li class="global-nav__menu-item"><a tabindex="1" href="https://www.nba.com/store?category=nba_jerseys" class="teamNavStore" title="Link to NBA Store">NBA Store</a></li>
            <li class="global-nav__menu-item"><a href="https://www.nba.com/watch/streaming-subscriptions" class="teamLeaguePass" title="Link to NBA League Pass" tabindex="1">NBA League Pass</a></li>
          </ul>
        </div>
      </div>
    </div>
  </nav>
</header>

<main id="main" class="main">
  <div id="page" class="page">
          <header>
        <nav class="main-nav-wrapper">
          <div class="main-nav-wrapper-inner">
          <div class="container">
            <div class="row">
              <div class="col-md-12">
                <!-- Site Logo -->
                <div class="navbar-brand-wrapper">
                  <a tabindex="1" href="/hornets/" id="logo" class="navbar-brand" title="Home" rel="home">
                                          <img src="https://www.nba.com/hornets/sites/hornets/files/hornets_primary_logo.png?" alt="Site Logo" title="Site Logo" />                                        <span class="element-invisible">Charlotte Hornets</span>
                  </a>
                </div>
                <!-- Presented by Advertisement -->
                <div class="presented-by presented-by--header">
                    <div class="region region-promo-region">
    <div id="block-bean-presented-by-promo" class="block block-bean">

    <h2>Promo Title</h2>
  
  <div class="content">
      <span class="presented-by__text">Presented by</span>
  <img src="" width="0" height="0" />
  <a tabindex="1" href="" target="_blank">
  <img class="block__img" src="/hornets/sites/hornets/files/presented_by/100x22.gif?w=100&amp;h=22" alt="Promo Title" title="Promo Title" /></a>
  </div>
</div>
  </div>
                </div>
                <!-- Main Navigation for Users -->
                <div class="mobile-menu-hamburger"><a href="javascript:;"></a></div>

                <ul id="main-menu" class="main-nav left"><li class="visible-xs mobile-menu-top">Menu</li><li class="first expanded main-nav__menu-item has-dropdown" title=""><a href="/hornets/tickets" title="">Tickets</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/hornets/tickets" title="">Ticket Central</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/2021-season-memberships" title="">Hive Society</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/memberships" title="">Season Memberships</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://am.ticketmaster.com/charhornets/buy?filterType=69&amp;camefrom=WEB" title="">Pick 23 Plan</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/schedule" title="">Single Game</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/nba-season-faq" title="">Ticket FAQ</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="http://www.hornetspremium.com/" title="">Premium</a></li><li class="leaf"><a href="/hornets/group-experience">Groups</a></li><li class="leaf" title=""><a href="https://www.ticketmaster.com/Charlotte-Hornets-tickets/artist/931493?brand=hornets&amp;extcmp=gw500187&amp;wt.mc_id=NBA_TEAM_CHA_NAV&amp;utm_source=NBA.com&amp;utm_medium=client&amp;utm_campaign=NBA_TEAM_CHA&amp;utm_content=NAV" title="">Sell Tickets</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://am.ticketmaster.com/charhornets" title="">Login</a></li><li class="last leaf" title="" target="_blank"><a href="https://www.seats3d.com/nba/charlotte_hornets/" title="" target="_blank">3D Seat Map</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/hornets/schedule" title="">Schedule</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="/hornets/schedule" title="">Interactive Schedule</a></li><li class="leaf" title=""><a href="https://www.stanza.co/@nba-hornets/subscription?source=a2c" title="">Download Outlook/iCal/Facebook</a></li><li class="leaf" title=""><a href="https://www.nba.com/resources/static/team/v2/hornets/PDFs/2122_pdf_Schedule_Letter.pdf" title="">Calendar (8.5x11)</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/resources/static/team/v2/hornets/PDFs/2122_pdf_Schedule_Tabloid.pdf" title="">Calendar (11x17)</a></li><li class="leaf" title=""><a href="https://www.nba.com/resources/static/team/v2/hornets/PDFs/2122_pdf_Schedule-List.pdf" title="">List (PDF)</a></li><li class="leaf" title=""><a href="https://www.nba.com/resources/static/team/v2/hornets/PDFs/2122_pdf_Schedule-Analysis.pdf" title="">Analysis (PDF)</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="https://www.spectrumcentercharlotte.com" title="">Arena Events Schedule</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/hornets/roster/2013" title="">Team</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-5 blocks-0"><li class="dropdown-row"><ul><li class="first leaf"><a href="/hornets/roster">Roster</a></li><li class="leaf"><a href="/hornets/stats/leaders">Leaders</a></li><li class="leaf"><a href="/hornets/stats/team">Team Stats</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/hornets/stats">Player Stats</a></li><li class="leaf" title=""><a href="https://www.nba.com/standings" title="">Standings</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/press-releases/hornets-announce-coaching-staff" title="">Coaches</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="" target="_blank"><a href="http://publogix.com/e/20-CHAHORYB" title="" target="_blank">2020-21 Digital Yearbook</a></li><li class="leaf" title=""><a href="https://www.nba.com/resources/static/team/v2/hornets/PDFs/2021_pdf_Media-Guide2.pdf" title="">Media Guide</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/executive-staff" title="">Front Office</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/hornets/hse-staff-directory">Staff Directory</a></li><li class="leaf"><a href="/hornets/contact-hornets-sports-and-entertainment">Contact Us</a></li><li class="leaf" title=""><a href="https://www.hornetspartnerships.com/" title="">Partnerships</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="https://www.nba.com/hornets/hsecareers" target="_blank" title="">HSE Jobs</a></li><li class="last leaf" title="" target="_blank"><a href="https://www.hornets.com/hse" title="" target="_blank">Spectrum Center Jobs</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="http://www.hornetsfanshop.com/source/bm-referral-comad-topnav" title="">Shop</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.hornetsfanshop.com/Charlotte_Hornets_Mens?source=bm-Hornets-Top-Nav-Mens" title="">Men</a></li><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/Charlotte_Hornets_Ladies?source=bm-Hornets-Top-Nav-womens" title="">Women</a></li><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/Charlotte_Hornets_Kids?source=bm-Hornets-Top-Nav-kids" title="">Kids</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/Charlotte_Hornets_T-Shirts?source=bm-Hornets-Top-Nav-tshirts" title="">T-shirts</a></li><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/charlotte-hornets-jerseys/t-25030677+d-8905176372+z-94-3510697914&amp;_s=bm-Jerseys-HornetsHomePage-2020" title="">Jerseys</a></li><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/charlotte-hornets-hats/t-25697344+d-4550514706+z-96-2858499738&amp;_s=bm-Headwear-HornetsHomePage-2020" title="">Hats</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/Charlotte_Hornets_Sweatshirts_And_Fleece?source=bm-Hornets-Top-Nav-sweatshirt" title="">Sweatshirts</a></li><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/charlotte-hornets-hardwood-classics/c-26478252+z-9296564-4002129096&amp;_s=bm-HardwoodClassics-Linktr.ee-2020" title="">Hardwood Classics</a></li><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/Charlotte_Hornets_Jordan_Brand" title="">Jordan Brand</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="Fan Shop Info"><a href="https://www.nba.com/hornets/hornets-fan-shop" title="Fan Shop Info">Store Information</a></li><li class="leaf" title=""><a href="https://www.hornetsfanshop.com/charlotte-hornets-new-styles-from-top-brands/t-36584077+c-76454331+z-966-1297469951?_s=bm-Hornets-NewArrivals-.comad-5.15.19" title="">New Arrivals</a></li><li class="last leaf" title=""><a href="https://www.instagram.com/hornetsfanshop/" title="">Instagram</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/hornets/news" title="">News</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf"><a href="/hornets/2020-21-end-season">2020-21 End of Season Central</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/2020-draft-central" title="">2020 Draft Central presented by LendingTree</a></li><li class="leaf" title=""><a href="https://buzzcityminted.com" title="">Buzz City Minted</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://hornetsuniforms.com/" title="">New Association and Icon Edition Uniforms</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/covid19" title="">Hornets COVID-19 Response</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/radio" title="">Hornets Radio Network</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/hornets/archive/Press%20Release" title="">Press Releases</a></li><li class="leaf"><a href="/hornets/app">Official Mobile App</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/photos/" title="">Photo Galleries</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/hornets/dleague" title="">G League</a></li><li class="leaf" title="" target="_blank"><a href="https://hornetsvenomgt.nba.com/" title="" target="_blank">Hornets Venom GT</a></li><li class="last leaf" title=""><a href="https://www.nba.com/hornets/email-signup" title="">Email Signup</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/hornets/video" title="">Video</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/hornets/video/channel/inside_the_hive" title="">Inside The Hive</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/video/channel/hornets_practice" title="">Hornets Practice</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/video/channel/hornets_shootaround" title="">Hornets Shootaround</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/hornets/video/channel/hornets_pregame" title="">Hornets Pregame</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/video/channel/hornets_postgame" title="">Hornets Postgame</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/video/channel/rookie_journal" title="">Rookie Journal</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/hornets/video/channel/nba_draft" title="">NBA Draft Coverage</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/video/channel/community" title="">Community</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/video/channel/team_originals" title="">Team Originals</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="https://www.youtube.com/channel/UCPhFI5lIFnSggz7HgY9UuuQ" title="">Youtube</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" target="_blank"><a href="/hornets/community/home" target="_blank">Community</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" target="_blank"><a href="/hornets/community/education" target="_blank">Education</a></li><li class="leaf" target="_blank"><a href="/hornets/community/wellness" target="_blank">Wellness</a></li><li class="leaf" target="_blank"><a href="/hornets/community/military" target="_blank">Military</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank"><a href="/hornets/community/hunger" target="_blank">Hunger</a></li><li class="leaf"><a href="/hornets/community/communitycorner">Ally Community Corner</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/innovation-summit" title="">Innovation Summit</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/hornets/social-justice-platform" title="">Hornets Social Justice Platform</a></li><li class="last leaf" title=""><a href="https://www.nba.com/hornets/player-nation" title="">Player Nation</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/hornets/mobile-app" title="">Fans</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/hornets/welcomeback" title="">Know Before You Go</a></li><li class="leaf" title=""><a href="http://spectrumcenter.parkmobile.io/" title="">Parking &amp; Transportation</a></li><li class="leaf" title=""><a href="https://i.cdn.turner.com/nba/nba/.element/media/2.0/teamsites/hornets/PDFs/NBA-Fan-COD.pdf" title="">Fan Code of Conduct</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://spectrumcentercharlotte.com/" title="">Spectrum Center</a></li><li class="leaf" title=""><a href="/hornets/guest-experience" title="">Guest Experience</a></li><li class="leaf" title=""><a href="http://www.spectrumcentercharlotte.com/plan-your-visit/directions-parking" title="">Parking and Traffic</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/hornets/hornetshoops" title="">Camps and Clinics</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/jrhornets" title="">Jr. Hornets</a></li><li class="leaf" title=""><a href="https://www.nba.com/hornets/sensory" title="">Sensory Inclusion Program</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="https://www.nba.com/hornets/unsolicited-ideas-policy" title="">Unsolicited Idea Policy</a></li></ul></li></ul></li><li class="last expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/hornets/hive-entertainment" title="">Hive Entertainment</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-1 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/hornets/hugo" title="">Book Hugo</a></li><li class="last leaf" title=""><a href="https://www.nba.com/hornets/photos/honey%20bees%20" title="">Honey Bees</a></li></ul></li></ul></li></ul>                                <div class="search-box">
                  <p><span class="search-box__pre-text">Search</span> <a tabindex="-1" class="search-box__icon" href="#"><span tabindex="-1" class="element-invisible">Toggle Search Input</span></a>
                  </p>
                  <div class="search-box__form-wrapper">
                    <form>
                      <label for="search-box__input-box" class="element-invisible">Search Box</label>
                      <input tabindex="1" id="search-box__input-box" class="search-box__input-box" alt="search box" type="text" placeholder="Search" />
                      <input tabindex="1" type="submit" class="submit search-box__submit-btn" value="Search" />
                      <div class="search-box__submit-btn-icon"></div>
                    </form>
                  </div>
                </div>
                <!-- Social Bar -->
                <div class="social-bar-wrapper">
                  <!-- <a class="social-bar__mobile-icon visible-xs" href="#"><span class="element-invisible">Social Menu</span></a> -->
                    <div class="region region-header-social">
    <div id="block-etowah-marketing-social-links-header" class="block block-etowah-marketing">

    
  <div class="content">
    <ul class="social-bar first social-bar--header"><li class="social-bar__item "><a href="https://www.facebook.com/hornets" target="_blank" class="" alt="Facebook social link" title="Facebook social link" style="background-color:#3b5998"><i class="fab fa-facebook"></i></a></li><li class="social-bar__item "><a href="https://twitter.com/hornets" target="_blank" class="" alt="Twitter social link" title="Twitter social link" style="background-color:#1da1f2"><i class="fab fa-twitter"></i></a></li><li class="social-bar__item "><a href="https://www.instagram.com/hornets/" target="_blank" class="" alt="Instagram social link" title="Instagram social link" style="background-color:#000000"><i class="fab fa-instagram"></i></a></li><li class="social-bar__item last"><a href="https://www.nba.com/hornets/email-signup" target="_blank" class="last" alt="Email signup social link" title="Email signup social link" style="background-color:#00788c"><i class="fas fa-envelope"></i></a></li></ul>  </div>
</div>
  </div>
                </div>
              </div><!-- End .col-lg-12 -->
            </div><!-- End .row -->
          </div><!-- End .container -->
        </div><!-- End .main-nav-wrapper-inner -->
        </nav><!-- End .main-nav-wrapper -->
      </header>
    
    <div class="container">
      
    </div>
          <div class="page-header-ad">
        <div class="container">
            <div class="region region-header">
    <div id="block-panels-mini-mini-panel-top-banner-ad" class="block block-panels-mini">

    
  <div class="content">
    <div class="panel-display panel-1col clearfix" id="mini-panel-mini_panel_top_banner_ad">
  <div class="panel-panel panel-col">
    <div><div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1293-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1293-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1292-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1292-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
</div>
  </div>
</div>
  </div>
</div>
  </div>
        </div>
      </div>
    
     <div tabindex="0" id="content" class="">

    <div id="page-header">
                      </div>
           <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    
<div class="panel-display moscone-flipped clearfix " >

  <div class="moscone-container moscone-header clearfix panel-panel">
    <div id='moscone-header-inner' class="moscone-container-inner moscone-header-inner panel-panel-inner">
          </div>
  </div>

  <div class="moscone-flipped-container moscone-flipped-column-content clearfix">
    <div class="moscone-flipped-column-content-region moscone-flipped-content panel-panel">
      <div id='moscone-flipped-content-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-content-inner panel-panel-inner">
        <div class="panel-pane pane-etowah-story-pane-photo" >
  
      
  
  <div class="pane-content">
      <div>
    <h1>Charlotte Hornets Announce Medical Staff Additions</h1>
          <div class="field field-name-field-subheadline field-type-text field-label-hidden">
              </div>
      </div>
  
  <img src="/hornets/sites/hornets/files/777x442_pr_text.jpg?w=756&amp;h=430" />    

  </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-author" >
  
      
  
  <div class="pane-content">
     
<div class="author-block">
   
   
  <div class="author-block__author">by Quinton Wash</div>
      <div class="author-block__post-date">Posted: Oct 16, 2021</div>
    <div class="social-bar--author-block__wrapper"><div class='social-bar-wrapper social-bar--author-block' id='social-bar-wrapper-47824616bbc62adb86'><div class="item-list"><ul class="social-bar "><li class="social-bar__item first"><a href="https://facebook.com/sharer.php?u=https://www.nba.com/hornets/press-releases/charlotte-hornets-announce-medical-staff-additions&amp;t=Charlotte+Hornets+Announce+Medical+Staff+Additions" class="social-facebook-icon facebook-color social-facebook-popup" title="Share on Facebook" target="_blank"><span class='element-invisible'>Facebook</span></a></li>
<li class="social-bar__item last"><a href="https://twitter.com/intent/tweet?url=https://www.nba.com/hornets/press-releases/charlotte-hornets-announce-medical-staff-additions&amp;text=Charlotte+Hornets+Announce+Medical+Staff+Additions&amp;via=hornets" class="social-twitter-icon twitter-color social-twitter-popup" title="Share on Twitter" target="_blank"><span class='element-invisible'>Twitter</span></a></li>
</ul></div></div></div>
  </div><!-- End author-block -->  </div>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="pane-content">
    <div class="field field-name-body field-type-text-with-summary field-label-hidden">
  		  <p><strong>October 16, 2021</strong> – Charlotte Hornets President of Basketball Operations &amp; General Manager Mitch Kupchak announced today that the team has named Daniel Taylor Director of Applied Sports Science, Jameel Battle Director of Rehabilitation and Nina Hsieh Assistant Athletic Trainer.  All three individuals join the Hornets Medical Staff under the team’s Medical Director Joe Sharpe.</p>
<p>Taylor joins the organization after spending the last five seasons working as the Director of Performance for Men’s Basketball at Georgia Institute of Technology, where the Yellow Jackets won the ACC Championship in 2021. Prior to his time in Georgia, Taylor was the Head Strength and Conditioning Coach at Siena College for nine seasons, which included back-to-back-to-back MAAC Championships (2008, 2009 &amp; 2010). Taylor, a native of England, holds degrees from Franklin Pierce College (Bachelor of Arts), California University of Pennsylvania (Master of Science in Exercise Science and Performance Enhancement) and Edith Cowan University based in Perth, Western Australia (Master of Science in Exercise Science).</p>
<p>Battle joins Charlotte after spending last year as the Athletic Training Fellow for the Seattle Mariners. Prior to his time in Seattle, Battle spent two years in private practice focused on transforming physical rehabilitation and athletic performance by synthesizing Eastern and Western medical modalities. Before that, he was Assistant Athletic Director of Sports Medicine and Head Athletic Trainer for Clark Atlanta University. Battle also did a Sports Medicine Residency with the Arizona Diamondbacks, working with their Major League and Minor League rosters. Battle is originally from Cincinnati, Ohio, and holds degrees from Western Kentucky University (Bachelor of Science in Environmental Health and Safety), Yo San University (Master’s Degree of Traditional Chinese Medicine), Life University (Master of Athletic Training) and University of Vermont (Doctorate of Physical Therapy).</p>
<p>Hsieh joins the Hornets as the Assistant Athletic Trainer after serving as the Head Athletic Trainer with the Los Angeles Lakers for two seasons (2019-21) and the team’s Assistant Athletic Trainer for three seasons (2016-19). Hsieh was the team’s Head Athletic Trainer for the Lakers 2020 NBA Championship. Before working for the Los Angeles Lakers, she spent seven seasons with the franchise’s G League Affiliate, the South Bay Lakers, overseeing all health, wellness, strength and conditioning, equipment operations and travel needs for the team. Prior to joining the Lakers organization, Hsieh served as the Athletic Trainer for the UC-Santa Barbara women’s basketball team (2004-08), as well as the men’s soccer team (2010-11). She is a native of Taiwan and holds degrees from Cal State-Fullerton (Bachelor of Science in Kinesiology and Exercise Science) and AT Still University (Master of Science in Sports Healthcare).</p>
<p>Memberships to the newly rebranded Hive Society and Pick 23 Plans for the 2021-22 season are on sale now. Hive Society Memberships, which include all 43 regular-season and preseason games, start at $48 per game on average in the lower level and as low as $12 per game on average in the upper level, and include some of the best benefits in all of professional sports. Pick 23 Plans include Opening Night and 22 additional games of the purchaser’s choice, along with playoff priority and interest-free payment plans. Hornets fans can get lower-level tickets with this plan starting at $64 per game on average and upper-level tickets starting at $14 per game on average. For more information, call 704.HORNETS or visit hornets.com/tickets.</p>
	</div>
  </div>

  
  </div>
<div class="panel-pane pane-node-links link-wrapper" >
  
      
  
  <div class="pane-content">
      </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-tags" >
  
      
  
  <div class="pane-content">
    <div class="tag__title">Tags</div><div class="tag__link-wrapper"><a href="/hornets/archive/Hornets" class="tag__link" aria-label="Link to content tagged with Hornets">Hornets</a>, <a href="/hornets/archive/Press%20Release" class="tag__link" aria-label="Link to content tagged with Press Release">Press Release</a>, <a href="/hornets/archive/Press%20Releases" class="tag__link" aria-label="Link to content tagged with Press Releases">Press Releases</a></div>  </div>

  
  </div>
      </div>
    </div>
    <div class="moscone-flipped-column-content-region moscone-flipped-sidebar panel-panel">
      <div id='moscone-flipped-sidebar-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-sidebar-inner panel-panel-inner">
        <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60ce-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60ce-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-etowah-story-pane-rel-stories" >
  
        <h4 class="pane-title" tabindex="0">Related Content</h4>
    
  
  <div class="pane-content">
      <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Hornets</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--videos" href="https://www.nba.com/hornets/video/teams/hornets/2021/10/16/486689/1634416055377-pt-melo-zoom-486689"><img class="content-image" width="210" height="140" alt="Hornets Practice | LaMelo Ball - 10/16/21" src="https://clips-media-aka.warnermediacdn.com/nba/clips/2021-10/486689-754a2503bcf34a1fabb86bb1a1e1beb1/images/1634416055377-PT-MELO-ZOOM-486689-3.png"/></a>                    <div class="post__title"><a href="/hornets/video/teams/hornets/2021/10/16/486689/1634416055377-pt-melo-zoom-486689" class="node_title related-content__link related-content__link--title">Hornets Practice | LaMelo Ball - 10/16/21</a></div>
                    <div class="post__date">October 16, 2021</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--videos" href="https://www.nba.com/hornets/video/teams/hornets/2021/10/16/486688/1634415889191-pt-jb-zoom-486688"><img class="content-image" width="210" height="140" alt="Hornets Practice | James Borrego - 10/16/21" src="https://clips-media-aka.warnermediacdn.com/nba/clips/2021-10/486688-c8fd3bfa93c54252b258f498edc83a9a/images/1634415889191-PT-JB-ZOOM-486688-10.png"/></a>                    <div class="post__title"><a href="/hornets/video/teams/hornets/2021/10/16/486688/1634415889191-pt-jb-zoom-486688" class="node_title related-content__link related-content__link--title">Hornets Practice | James Borrego - 10/16/21</a></div>
                    <div class="post__date">October 16, 2021</div>
        </li>
          </ul>
  </div>
  <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Press Release</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/hornets/hornets-waive-crutcher-and-mcgriff"><img class="content-image" src="/hornets/sites/hornets/files/211014_release_main.jpg?cw=210&amp;ch=140&amp;w=246&amp;h=140&amp;x=18&amp;y=0" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/hornets/hornets-waive-crutcher-and-mcgriff" class="node_title related-content__link related-content__link--title">Hornets Waive Crutcher and McGriff</a></div>
                    <div class="post__date">October 14, 2021</div>
        </li>
              <li class="related-content__row">
                    <div class="post__title"><a href="/hornets/press-releases/charlotte-hornets-foundation-honors-community-leaders-13th-annual-hornets-heroes-gala" class="node_title related-content__link related-content__link--title">Charlotte Hornets Foundation Honors Community Leaders At 13th Annual Hornets Heroes Gala</a></div>
                    <div class="post__date">October 10, 2021</div>
        </li>
          </ul>
  </div>
  <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Press Releases</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/hornets/press-releases/charlotte-hornets-sign-jalen-crutcher-and-cameron-mcgriff"><img class="content-image" src="/hornets/sites/hornets/files/2122_header_generic.jpg?cw=210&amp;ch=140&amp;w=246&amp;h=140&amp;x=18&amp;y=0" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/hornets/press-releases/charlotte-hornets-sign-jalen-crutcher-and-cameron-mcgriff" class="node_title related-content__link related-content__link--title">Charlotte Hornets Sign Jalen Crutcher and Cameron McGriff</a></div>
                    <div class="post__date">October 08, 2021</div>
        </li>
              <li class="related-content__row">
                    <div class="post__title"><a href="/hornets/press-releases/charlotte-hornets-waive-dj-carton-and-xavier-sneed" class="node_title related-content__link related-content__link--title">Charlotte Hornets Waive DJ Carton and Xavier Sneed</a></div>
                    <div class="post__date">October 08, 2021</div>
        </li>
          </ul>
  </div>
  </div>

  
  </div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60d1-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60d1-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
      </div>
    </div>
  </div>

  <div class="moscone-container moscone-footer clearfix panel-panel">
    <div id='moscone-footer-inner' class="moscone-container-inner moscone-footer-inner panel-panel-inner">
      <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60cf-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60cf-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
    </div>
  </div>

</div><!-- /.moscone-flipped -->
  </div>
</div>
<div class="etowah_ticket_share mfp-hide">
  <app-ticket-share></app-ticket-share>
</div>
  <div class="nextup_wrapper nextup_original">
    <div class="nextup_contain" tabindex="0" aria-label="Next Up">
      <div class="nextup_header">
        <div class="nextup_image">
          <img src="" class="thumb" />
        </div>
        <div class="nextup_details">
          <div class="nextup_timer">NEXT UP: <span></span></div>
          <div class="nextup_title"></div>
          <div class="nextup_desc"></div>
        </div>
      </div>
      <div class="nextup_playback">
        <button class="nextup_replay" title="Replay Video">Replay</button>
        <button class="nextup_playnext" title="Play Next Video">Play Next</button>
      </div>
      <div class="nextup_social">
        <hr />
        <ul>
          <li id="nextup_fb">
            <a href="#" target="_blank" title="Share to Facebook">
              <img src="https://cdn.nba.net/assets/video/icons/social_fb.png" alt="Facebook" />
            </a>
          </li>
          <li id="nextup_tw">
            <a href="#" target="_blank" title="Share to Twitter">
              <img src="https://cdn.nba.net/assets/video/icons/social_tw.png" alt="Twitter" />
            </a>
          </li>
          <li id="nextup_link">
            <a href="#" title="Copy share link">
              <img src="https://cdn.nba.net/assets/video/icons/social_lk.png" alt="Share Link" />
            </a>
            <div id="nextup_link_message">Link copied to clipboard</div>
          </li>
        </ul>
      </div>
    </div>
  </div>  </div>
    </div>
  </div><!-- End .page -->

</main>

  <div class="region region-footer">
    <div id="block-panels-mini-mini-panel-footer" class="block block-panels-mini">

    
  <div class="content">
    
<footer id="footer" role="footer" class="footer panel-display etowah-footer clearfix etowah-footer" id="mini-panel-mini_panel_footer">
  <div class="footer-top">
    <div class="container">
      <div class="row">
        <div class="custom-page-ad_bottom">
          <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1290-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1290-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1291-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1291-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
        </div>
      </div>
      <div class="row">
        <ul class="col-xs-12 footer-top-sponsors">
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c39a6-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c39a6-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-menu-tree pane-menu-footer-column-1" >
  
      
  
  <div class="pane-content">
    <div class="menu-block-wrapper menu-block-ctools-menu-footer-column-1-1 menu-name-menu-footer-column-1 parent-mlid-menu-footer-column-1:0 menu-level-1">
  <ul class="menu nav nav-tabs nav-stacked"><li class="first collapsed menu-mlid-4981"><a href="https://www.nba.com/hornets/schedule" title="">Schedule</a></li>
<li class="leaf menu-mlid-4909"><a href="https://www.nba.com/hornets/tickets" title="">Ticket Central</a></li>
<li class="leaf menu-mlid-6923"><a href="https://www.ticketmaster.com/Charlotte-Hornets-tickets/artist/931493?extcmp=gw500188&amp;utm_source=NBA.com&amp;utm_medium=client&amp;utm_campaign=NBA_TEAM_CHA&amp;utm_content=FOOTER" title="">Single Game Tickets</a></li>
<li class="leaf menu-mlid-6925"><a href="https://www.nba.com/hornets/ticketback" title="">Ticket Terms and Conditions</a></li>
<li class="last leaf menu-mlid-4919"><a href="https://www.hornetsfanshop.com" title="">Hornets Fan Shop</a></li>
</ul></div>
  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-menu-tree pane-menu-footer-column-3" >
  
      
  
  <div class="pane-content">
    <div class="menu-block-wrapper menu-block-ctools-menu-footer-column-3-1 menu-name-menu-footer-column-3 parent-mlid-menu-footer-column-3:0 menu-level-1">
  <ul class="menu nav nav-tabs nav-stacked"><li class="first leaf menu-mlid-4933"><a href="https://www.nba.com/standings/team_record_comparison/conferenceNew_Std_Cnf.html" title="">Team Standings</a></li>
<li class="leaf menu-mlid-4927"><a href="https://www.nba.com/hornets/stats/team" title="">Team Stats</a></li>
<li class="leaf menu-mlid-4923"><a href="https://www.nba.com/hornets/roster/2013" title="">Roster</a></li>
<li class="leaf menu-mlid-4925"><a href="https://www.nba.com/hornets/stats/leaders" title="">Leaders</a></li>
<li class="last leaf menu-mlid-4929"><a href="https://www.nba.com/hornets/stats/2013" title="">Player Stats</a></li>
</ul></div>
  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-column-4" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://www.nba.com/hornets/photos/" title="">Photo Galleries</a></li>
<li class="leaf"><a href="https://www.nba.com/hornets/video/channel/team-originals/" title="">Video</a></li>
<li class="leaf"><a href="https://www.nba.com/hornets/hsecareers" title="">Hornets Careers</a></li>
<li class="leaf"><a href="https://www.nba.com/hornets/honeybees" title="">Honey Bees</a></li>
<li class="last leaf"><a href="https://www.nba.com/hornets/corporate-social-responsibility" title="">Community</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-column-5" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://www.facebook.com/hornets" title="">Facebook</a></li>
<li class="leaf"><a href="https://twitter.com/hornets" title="">Twitter</a></li>
<li class="leaf"><a href="https://instagram.com/hornets/" title="">Instagram</a></li>
<li class="leaf"><a href="https://www.nba.com/hornets/app" title="">Official Hornets Mobile App</a></li>
<li class="last leaf"><a href="https://www.nba.com/hornets/email-signup" title="">Signup for Email Updates</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c39ab-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c39ab-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
          </li>
        </ul>
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-top -->

  <div class="footer-bottom">
    <div class="container">
      <div class="row">
        <div class="footer-left col-xs-12 col-md-6">
          <p class="copyrights">
  Copyright © 2021 NBA Media Ventures, LLC. All rights reserved.
  No portion of NBA.com may be duplicated, redistributed or manipulated in any form.
  This site is operated jointly by NBA and WarnerMedia. To opt out of the sale of your personal information as permitted by the California Consumer 
  Privacy Act, please use the links below to visit each company’s privacy center. If you make a request through the WarnerMedia Privacy Center, 
  it will apply to data controlled jointly by the NBA and WarnerMedia as well as other data controlled by WarnerMedia. If you make a request through 
  the NBA Privacy Center, it will apply to data controlled independently by the NBA.
  <a href="https://www.nba.com/privacy-policy#Cookies">NBA Privacy Center</a>  |
  <a href="https://www.warnermediaprivacy.com">WarnerMedia Privacy Center</a>  |
  <a href="https://privacy.nba.com">Do Not Sell My Personal Information</a>  |
  <a href="http://www.nba.com/news/termsofuse">Terms of Use</a>  |
  <a href="https://www.nba.com/accessibility">Accessibility and Closed Caption</a>  |
  <a id="nba_cnsnt_trst" class="nbaAdChoices" consent="null">
    <script type="text/javascript" src="//consent.truste.com/notice?domain=turner.com&amp;c=nba_cnsnt_trst&amp;text=true&amp;country=us" id="truste_0.7941776050720364"></script>
    <script async="async" type="text/javascript" crossorigin="" src="//consent.truste.com/get?name=notice.js"></script>
  </a>
  |
  <a class="ot-sdk-show-settings">Manage Preferences</a>
</p>
        </div><!-- End .footer-right .col-md-6 -->
        <div class="footer-right col-xs-12 col-md-6 pull-left">
          <ul class="footer-nav">
  <li class="footer-nav__menu-item">
    <a href="http://adspecs.nba.com" target="_blank">Advertise on NBA.com</a>    </li>
  <li class="footer-nav__menu-item">
    <a href="https://support.watch.nba.com/hc/en-us" target="_blank">NBA.com Help</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/help/fan_relations_faq.html" target="_blank">Fan Relations FAQ</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="https://careers.nba.com/" target="_blank">NBA Career Opportunities</a>  </li>
<ul>
        </div><!-- End .footer-left .col-md-6 -->
      </div><!-- End .row -->
      <div class="row">
        <div class="col-md-12">
          <div class="turner-logo"></div>NBA.com is part of Turner Sports Digital, part of the Turner Sports & Entertainment Digital Network.        </div><!-- End col-md-6 -->
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-bottom -->
</footer> <!-- End .footer -->
  </div>
</div>
  </div>
  <div id="closure" style="visibility:hidden; position:absolute; bottom:0; right:0; max-height :1px; max-width:1px;"><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-58352673-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-58352673-1');
</script>



<script type="text/javascript">
(function() {
  var didInit = false;
  function initMunchkin() {
    if(didInit === false) {
      didInit = true;
      Munchkin.init('701-VUL-688');
    }
  }
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = '//munchkin.marketo.net/munchkin.js';
  s.onreadystatechange = function() {
    if (this.readyState == 'complete' || this.readyState == 'loaded') {
      initMunchkin();
    }
  };
  s.onload = initMunchkin;
  document.getElementsByTagName('head')[0].appendChild(s);
})();
</script>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NSCMV6C"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<!-- Facebook Pixel Code -->

<script>

!function(f,b,e,v,n,t,s)

{if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');


fbq('init', '1974376702790496'); 
fbq('track', 'PageView');


</script>

<noscript>

<img height="1" width="1" src="https://www.facebook.com/tr?id=1974376702790496&ev=PageView&noscript=1"/>

</noscript>

<!-- End Facebook Pixel Code -->
</div><div id="parsely-root" style="display: none">
                  <span id="parsely-cfg" data-parsely-site="hornets.nba.com"></span>
                </div><script type="text/javascript" src="https://www.nba.com/ngteams/runtime.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/polyfills.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/vendor.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/main.js"></script>
<script type="text/javascript" src="https://z.cdn.turner.com/nba/tmpl_asset/static/nba-cms3-base/latest/js/pkgCustomLibs-min.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_ROY4zcHmM4k19meZDVZumyAgHlEizExYwYth1i_9mkw.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_KdQWIKINQBZyGu1LBsBAYG_as7pgvy5uNErmTAOuhbw.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_aiQf68XsPM6zndplRn7gli6laergl9IvwXahO765-90.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/js/js_CpKA_1OC8W0diAfzqJsNEAadBhdt9xR0Fdb4Guu-nJ8.js"></script>
<script type="text/javascript" src="https://www.nba.com/hornets/sites/hornets/files/sitewide_overrides/active/etowah_swo_80646/footer_sitewide_overrides.js?r132sy"></script>
  </body>
</html>