<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr"
  xmlns:fb="http://ogp.me/ns/fb#"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <script type="text/javascript" src="//cdn.optimizely.com/js/2727400142.js"></script>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo" />
<meta name="timestamp" content="1526405818" />
<meta property="google-site-verification" content="9HHWIRDhKScG8XrLbmN9OD6e-TYklksT8u-dPkA0g80"><meta property="fb:pages" content="98534743609"><meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo"><link rel="amphtml" href="https://www.nba.com/amp/nuggets/news/murray-career-night-111117" />
<link rel="shortcut icon" href="https://www.nba.com/nuggets/sites/nuggets/files/dn-pickaxe-favicon.ico" type="image/vnd.microsoft.icon" />
<script type="text/javascript">var turner_metadata = {
        teamPageType        : "custom",
        turnerId            : "aa41822-1193725393-1389694715530-1",
        entity              : "nba:team:nuggets",
        analyticsVersion    : "2.0",
        appName             : "app:nba - desktop",
        registrationState   : "not signed in",
        page                : "nba:team:nuggets:features:Jamal Murrays Career Night Powers Nuggets Past Magic",
        section             : "nba:team:nuggets:features",
        subsection          :  "nuggets:features",
        articleCategory     : "news",
        articleTitle        : "Jamal Murrays Career Night Powers Nuggets Past Magic",
        articleAuthor       : "cdempsey",
        articlePublishDate  : "11/11/2017",
        articleTags         : "Millsap, Paul, Mudiay, Emmanuel, Murray, Jamal, Malone, Michael, Nuggets",
        eventPageView       : "1",
        offsiteSource       : "Team Site"
      };</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Jamal Murray\u0027s Career Night Powers Nuggets Past Magic","url":"https:\/\/www.nba.com\/nuggets\/news\/murray-career-night-111117","dateCreated":"2017-11-12T06:00:00Z","articleSection":"news","creator":["cdempsey"],"keywords":["Millsap, Paul","Mudiay, Emmanuel","Murray, Jamal","Malone, Michael","Nuggets"],"author":["cdempsey"],"datePublished":"2017-11-12T06:00:00Z","image":"https:\/\/www.nba.com\/nuggets\/sites\/nuggets\/files\/getty-images-873080220.jpg","publisher":{"@type":"Organization","name":"NBA.com\/nuggets","logo":{"@type":"ImageObject","url":"https:\/\/i.cdn.turner.com\/nba\/nba\/.element\/img\/1.0\/teamsites\/logos\/teamlogos_500x500\/DEN.png","width":180,"height":60}},"dateModified":"2017-12-28T18:18:19Z","mainEntityOfPage":"https:\/\/www.nba.com\/nuggets\/news\/murray-career-night-111117","thumbnailUrl":"https:\/\/www.nba.com\/nuggets\/sites\/nuggets\/files\/getty-images-873080220.jpg"}</script>
<meta name="description" content="Playing in Denver on the second of a back-to-back used to have this look more often than not. Team X arrives late at night, and even if they played a yawner the night before that didn’t tax them too much, they were still too tired to keep up with the Nuggets, who ran their legs off early and kept the pressure up all night." />
<meta name="keywords" content="Denver Nuggets, Nuggets, Nuggets vs Magic, Jamal Murray" />
<meta name="news_keywords" content="Denver Nuggets, Nuggets, Nuggets vs Magic, Jamal Murray" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.nba.com/nuggets/news/murray-career-night-111117" />
<link rel="shortlink" href="https://www.nba.com/nuggets/node/25507" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="Denver Nuggets" />
<meta property="og:title" content="Jamal Murray&#039;s Career Night Powers Nuggets Past Magic | Denver Nuggets" />
<meta property="og:url" content="https://www.nba.com/nuggets/news/murray-career-night-111117" />
<meta property="og:description" content="Playing in Denver on the second of a back-to-back used to have this look more often than not. Team X arrives late at night, and even if they played a yawner the night before that didn’t tax them too much, they were still too tired to keep up with the Nuggets, who ran their legs off early and kept the pressure up all night." />
<meta property="og:image" content="https://www.nba.com/nuggets/sites/nuggets/files/getty-images-873080220.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.nba.com/nuggets/news/murray-career-night-111117" />
<meta name="twitter:title" content="Jamal Murray&#039;s Career Night Powers Nuggets Past Magic | Denver Nuggets" />
<meta name="twitter:description" content="Playing in Denver on the second of a back-to-back used to have this look more often than not. Team X arrives late at night, and even if they played a yawner the night before that didn’t tax them too much, they were still too tired to keep up with the Nuggets, who ran their legs off early and kept the pressure up all night." />
<meta name="twitter:image:src" content="https://www.nba.com/nuggets/sites/nuggets/files/getty-images-873080220.jpg" />
  <title>Jamal Murray's Career Night Powers Nuggets Past Magic | Denver Nuggets</title>
  <link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_WdqLW9bb5jNLXNSKGXJiwH2paPLJNKAb8HiZFZviYzM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_XQvmAYJnSmVwW8qFuiL_uKQXprU7wPiCYJm4-X1ou8I.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_vALo0L1WFFL38i9izHxLeUcj-JzCeuhQesOW0Iyckl8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_YOAv9gEpZ3UhkgQPocy_kPXKT77DuztAEiE94_CNBj4.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/stylesheets/ie8_fallback.css?p87s58" media="all" />
<![endif]-->

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/stylesheets/ie7_fallback.css?p87s58" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/stylesheets/bootstrap.css?p87s58" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/stylesheets/screen.css?p87s58" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_T-TZfTydUwB664EEKJHDcuk7jy4tISCzGTq3m7vhy9Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_BCB628l_h53mXwkvjd6omwC2qvhBUHS4CCLe77RpTzk.css" media="print" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?p87s58" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?p87s58" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?p87s58" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?p87s58" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/colorizer/etowah_radix-7f7fbaaf.css" media="all" />
<style type="text/css" media="(min-width: 640px)">
<!--/*--><![CDATA[/*><!--*/
.page{background-image:url(https://www.nba.com/nuggets/sites/nuggets/files/dn-1718-webbgv3.jpg)}

/*]]>*/-->
</style>
<style type="text/css" media="(-webkit-min-device-pixel-ratio: 2) and (min-width: 640px), (min-resolution: 192dpi) and (min-width: 640px)">
<!--/*--><![CDATA[/*><!--*/
.page{background-image:url(https://www.nba.com/nuggets/sites/nuggets/files/styles/hi_res_images/public/dn-1718-webbgv3.jpg?itok=J75vWgNi);background-size :1900px auto}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_9My-7H_MRfnJxM37nvTyruoguw4EBPtdmS3ZSv9dCpk.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/sitewide_overrides/active/etowah_swo_46762/style_sitewide_overrides.css?p87s58" media="all" />
    <script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_sOTmJnDhZ0YaYTQBr9FPewnH0WbS6pH--oA8_JDPY0w.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var jQuery1111 = jQuery.noConflict(); var jQuery111 = jQuery1111;
//--><!]]>
</script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_hulMQeqjF8ve0NZMub5AoK8cNJYigyJDRVHqsNsO5gQ.js"></script>
<script type="text/javascript" src="//www.nba.com/javascriptGlobalSettings.js.html"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_eAtNCuh9Vfx9qN14qMJAChJnBHm5P4auvYGH7pl0im8.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_MR3p0_6meFWoLP4wRlqyHQSzuYOeoN-KDGgBPv5Wzw4.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_Bt_rYlKYL2a_VqFY9doVxDjjSF-zCiBM5_3ksRfpUCg.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_JuH2ophJ6jfV9TDNwuxKv8K9MJLi7EZx4QqA-D26Ico.js"></script>
<script type="text/javascript" src="//nexus.ensighten.com/turner/nba-prod/Bootstrap.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/sitewide_overrides/active/etowah_swo_46762/header_sitewide_overrides.js?p87s58"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_cJm9LdCwmPAu2B2m_sYaE_zfjMGhWlX9dPuMXylJwY0.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]>
   <script>
      document.createElement('header');
      document.createElement('nav');
      document.createElement('section');
      document.createElement('article');
      document.createElement('aside');
      document.createElement('footer');
   </script>
   <link id="respond-proxy" rel="respond-proxy" href="http://i.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="http://z.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="https://s.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-redirect" rel="respond-redirect" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.gif" />
   <script type="text/javascript" src="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.min.js" />
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/src/respond.min.js" />
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/javascripts/vendor/selectivizr-min.js" />
  <![endif]-->

</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-25507 node-type-story region-content" data-gameid="0021700185" data-gameurl="20171111/ORLDEN">
  <div id="skip-link">
    <a tabindex="1" href="#content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <header class="header" role="header">
  <nav class="global-nav-wrapper">
    <div class="container">
    <!--Top of the page navigation and NBA logo -->
      <div class="row">
        <div class="col-xs-12">
          <div class="utility-logo">
            <a tabindex="1" href = "http://www.nba.com"><span class="element-invisible">NBA</span></a>
          </div>
          <ul class="global-nav">
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/" class="teamNavGlobal global-nav__hidden-xs" title="Link to NBA Global">Global</a></li>
            <li class="global-nav__menu-item expanded has-dropdown">
              <a tabindex="1" href="javascript:void(0)" id="global-nav__menu-item__teams-link">Teams</a>
              <ul class="global-nav__menu-item__sub-menu" id="global-nav__menu-item__teams-link-dropdown">
                <li><a class="global-nav__menu-item__sub-menu__sub-item" href="http://www.nba.com/teams/" title="Link to NBA Teams">Teams</a></li>
                <li class="teamHDR">Team Sites</li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hawks/" title="Link to Atlanta Hawks Team Site">Atlanta</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/heat/" title="Link to Miami Heat Team Site">Miami</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/celtics/" title="Link to Boston Celtics Team Site">Boston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bucks/" title="Link to Milwaukee Bucks Team Site">Milwaukee</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nets/" title="Link to Brooklyn Nets Team Site">Brooklyn</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/timberwolves/" title="Link to Minnesota Timberwolves Team Site">Minnesota</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hornets/" title="Link to Charlotte Hornets Team Site">Charlotte</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pelicans/" title="Link to New Orleans Pelicans Team Site">New Orleans</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bulls/" title="Link to Chicago Bulls Team Site">Chicago</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/knicks/" title="Link to New York Knicks Team Site">New York</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/cavaliers/" title="Link to Cleveland Cavaliers Team Site">Cleveland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/thunder/" title="Link to Oklahoma City Thunder Team Site">Oklahoma City</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/mavericks/" title="Link to Dallas Mavericks Team Site">Dallas</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/magic/" title="Link to Orlando Magic Team Site">Orlando</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nuggets/" title="Link to Denver Nuggets Team Site">Denver</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/sixers/" title="Link to Philadelphia 76ers Team Site">Philadelphia</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pistons/" title="Link to Detroit Pistons Team Site">Detroit</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/suns/" title="Link to Phoenix Suns Team Site">Phoenix</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/warriors/" title="Link to Golden State Warriors Team Site">Golden State</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/blazers/" title="Link to Portland Blazers Team Site">Portland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/rockets/" title="Link to Houston Rockets Team Site">Houston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/kings/" title="Link to Sacramento Kings Team Site">Sacramento</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pacers/" title="Link to Indiana Pacers Team Site">Indiana</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/spurs/" title="Link to San Antonio Spurs Team Site">San Antonio</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/clippers/" title="Link to LA Clippers Team Site">LA Clippers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/raptors/" title="Link to Toronto Raptors Team Site">Toronto</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/lakers/" title="Link to LA Lakers Team Site">LA Lakers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/jazz/" title="Link to Utah Jazz Team Site">Utah</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/grizzlies/" title="Link to Memphis Grizzlies Team Site">Memphis</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/wizards/" title="Link to Washington Wizards Team Site">Washington</a></li>
              </ul>
            </li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://gleague.nba.com" title="Link to G League">G League</a></li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://www.wnba.com" title="Link to WNBA" class="teamNavWNBA">WNBA</a></li>
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/storelinkhandler.html" class="teamNavStore" title="Link to NBA Store">NBA Store</a></li>
          </ul>
        </div>
      </div>
    </div>
  </nav>
</header>

<main id="main" class="main">
  <div id="page" class="page">
    <header>
      <nav class="main-nav-wrapper">
        <div class="main-nav-wrapper-inner">
        <div class="container">
          <div class="row">
            <div class="col-md-12">
              <!-- Site Logo -->
              <div class="navbar-brand-wrapper">
                <a tabindex="1" href="/nuggets/" id="logo" class="navbar-brand" title="Home" rel="home">
                                      <img src="https://www.nba.com/nuggets/sites/nuggets/files/styles/logo/public/dn-sitelogo-pickaxe-105x105.png?itok=4Xiwf3Sd" width="" height="" alt="Site Logo" title="Site Logo" />                                    <span class="element-invisible">Denver Nuggets</span>
                </a>
              </div>
              <!-- Presented by Advertisement -->
              <div class="presented-by presented-by--header">
                  <div class="region region-promo-region">
    <div id="block-bean-presented-by-promo" class="block block-bean">

    <h2>Presented by Western Union</h2>
  
  <div class="content">
      <span class="presented-by__text">Presented by</span>
  <a tabindex="1" href="https://www.westernunion.com/us/en/home.html" target="_blank">
  <img class="block__img" src="/nuggets/sites/nuggets/files/styles/presented_by/public/wu_logo_horizontal_pms123-082417.png?itok=HRsIKjaV" alt="Presented by Western Union" title="Presented by Western Union" /></a>
  </div>
</div>
  </div>
              </div>
              <!-- Main Navigation for Users -->
              <div class="mobile-menu-hamburger"><a href="javascript:;"></a></div>

              <ul id="main-menu" class="main-nav left"><li class="visible-xs mobile-menu-top">Menu</li><li class="first leaf main-nav__menu-item"><a href="/nuggets/tickets">Tickets</a></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/nuggets/roster" title="">Team</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf"><a href="/nuggets/roster">Roster</a></li><li class="leaf"><a href="/nuggets/stats/leaders">Leaders</a></li><li class="leaf"><a href="/nuggets/stats/team">Team Stats</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/nuggets/stats">Player Stats</a></li><li class="leaf" target="_blank" title=""><a href="https://i.cdn.turner.com/nba/nba/.element/media/2.0/teamsites/nuggets/DenverNuggets_2017-18_MediaGuide.pdf" target="_blank" title="">Media Guide</a></li><li class="leaf"><a href="/nuggets/staff-directory">Staff Directory</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf"><a href="/nuggets/nuggets-top-50">Nuggets Top 50</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/nuggets/schedule" title="">Schedule</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-1 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="/nuggets/schedule" title="">2017-18 Schedule</a></li><li class="last leaf"><a href="/nuggets/schedule/watch-parties">Watch Parties</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/nuggets/news" title="">News</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="/nuggets/news" title="">News Archive</a></li><li class="leaf" target="_blank" title=""><a href="https://www.nba.com/gamenotes/nuggets.pdf" target="_blank" title="">Game Notes</a></li><li class="leaf" title=""><a href="/nuggets/nuggets-en-espanol" title="">Nuggets En Espanol</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="/nuggets/denver-nuggets-international" title="">Nuggets International</a></li><li class="leaf" title=""><a href="/nuggets/photos" title="">Photo Galleries</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/photos/nuggets%20dancers%20" title="">Dancer Galleries</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="http://forms.ksecolorado.com/af2?LinkID=CH00096812eR00000034AD" target="_blank" title="">Newsletter Sign-Up</a></li><li class="leaf" title=""><a href="/nuggets/news/dempseys-deliveries" title="">Dempsey&#039;s Deliveries</a></li><li class="leaf"><a href="/nuggets/nuggets-text-club">Nuggets Text Club</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf"><a href="/nuggets/live">Nuggets Live</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/nuggets/video" title="">Video</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/nuggets/video/archive" title="">All Videos</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/video/channel/team_highlights" title="">Highlights</a></li><li class="leaf" title=""><a href="/nuggets/live" title="">Nuggets Live</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/nuggets/video/channel/community" title="">Community</a></li><li class="leaf" title="" target="_blank"><a href="https://www.youtube.com/user/NuggetsTV" title="" target="_blank">YouTube</a></li><li class="last leaf" title=""><a href="https://www.nba.com/nuggets/video/channel/nuggets_360" title="">Nuggets 360</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/nuggets/game-night" title="">Game Night</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf"><a href="/nuggets/denver-nuggets-dancers">Dancers</a></li><li class="leaf"><a href="/nuggets/game-night/supermascot-rocky">SuperMascot Rocky</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/game-night/skyline-drumline" title="">Skyline Drumline</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/nuggets/game-night/avaya-fan-engagement-team">Avaya Fan Engagement Team</a></li><li class="leaf"><a href="/nuggets/game-night/in-game-hosts">In-Game Hosts</a></li><li class="leaf"><a href="/nuggets/game-night/pa-announcer">PA Announcer</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf"><a href="/nuggets/game-night/faqs">Game Night FAQs</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/nuggets/" title="">Fans</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/nuggets/mobile-app" title="">Mobile App</a></li><li class="leaf"><a href="/nuggets/fan-zone/infographics">Infographics</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/fan-zone/contests/king-soopers-honorary-hero-game/" title="">King Soopers Honorary Hero of the Game</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf"><a href="/nuggets/sage">Preferred Hotel Partners</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/nuggets/community" title="">Community</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="/nuggets/community/charity-events" title="">Charity Events</a></li><li class="leaf" title=""><a href="/nuggets/community/educational-athletic-programs" title="">Educational and Athletic Programs</a></li><li class="leaf"><a href="/nuggets/community/jr-nuggets-program">Western Union Junior Nuggets</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/nuggets/community/donations">Donations</a></li><li class="leaf"><a href="/nuggets/community/community-ambassadors">Community Ambassadors</a></li><li class="leaf"><a href="/nuggets/community/license-plate">License Plate</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="https://www.facebook.com/KroenkeSportsCharities" target="_blank" title="">Kroenke Sports Charities Facebook</a></li><li class="leaf" target="_blank" title=""><a href="https://www.pepsicenter.com/media/32991/ksc_annualreport_2016-17.pdf" target="_blank" title="">Community Report</a></li><li class="last leaf" title=""><a href="https://www.nba.com/nuggets/program-sales" title="">Program Sales</a></li></ul></li></ul></li><li class="last expanded main-nav__menu-item has-dropdown" target="_blank" title=""><a href="http://www.altitudeauthentics.com/c-34-nuggets.aspx" target="_blank" title="">Store</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/jerseys" target="_blank" title="">Jerseys</a></li><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-hats" target="_blank" title="">Hats</a></li><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-mens" target="_blank" title="">Men&#039;s</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/womens-gear" target="_blank" title="">Women&#039;s</a></li><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/kids-gear" target="_blank" title="">Kids&#039;</a></li><li class="last leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-novelties" target="_blank" title="">Novelties</a></li></ul></li></ul></li></ul>                            <div class="search-box">
                <p><span class="search-box__pre-text">Search</span> <a tabindex="-1" class="search-box__icon" href="#"><span tabindex="-1" class="element-invisible">Toggle Search Input</span></a>
                </p>
                <div class="search-box__form-wrapper">
                  <form>
                    <label for="search-box__input-box" class="element-invisible">Search Box</label>
                    <input tabindex="1" id="search-box__input-box" class="search-box__input-box" alt="search box" type="text" placeholder="Search" />
                    <input tabindex="1" type="submit" class="submit search-box__submit-btn" value="Search" />
                    <div class="search-box__submit-btn-icon"></div>
                  </form>
                </div>
              </div>
              <!-- Social Bar -->
              <div class="social-bar-wrapper">
                <a class="social-bar__mobile-icon visible-xs" href="#"><span class="element-invisible">Social Menu</span></a>
                  <div class="region region-header-social">
    <div id="block-etowah-marketing-social-links-header" class="block block-etowah-marketing">

    
  <div class="content">
    <ul class="social-bar social-bar--header"><li class="social-bar__item"><a href="http://www.facebook.com/DenverNuggets" target="_blank" class="social-facebook-icon social-facebook-link facebook-color" alt="facebook social link" title="facebook social link"><span class="element-invisible">facebook</span></a></li><li class="social-bar__item"><a href="http://twitter.com/nuggets" target="_blank" class="social-twitter-icon social-twitter-link twitter-color" alt="twitter social link" title="twitter social link"><span class="element-invisible">twitter</span></a></li><li class="social-bar__item"><a href="http://instagram.com/nuggets/" target="_blank" class="social-instagram-icon social-instagram-link instagram-color" alt="instagram social link" title="instagram social link"><span class="element-invisible">instagram</span></a></li><li class="social-bar__item"><a href="http://forms.ksecolorado.com/af2?LinkID=CH00096812eR00000034AD" target="_blank" class="social-tumblr-icon social-tumblr-link tumblr-color" alt="tumblr social link" title="tumblr social link"><span class="element-invisible">tumblr</span></a></li></ul>  </div>
</div>
  </div>
              </div>
            </div><!-- End .col-lg-12 -->
          </div><!-- End .row -->
        </div><!-- End .container -->
      </div><!-- End .main-nav-wrapper-inner -->
      </nav><!-- End .main-nav-wrapper -->
    </header>

    <div class="container">
      
    </div>

  <div class="page-header-ad">
    <div class="container">
        <div class="region region-header">
    <div id="block-panels-mini-mini-panel-top-banner-ad" class="block block-panels-mini">

    
  <div class="content">
    <div class="panel-display panel-1col clearfix" id="mini-panel-mini_panel_top_banner_ad">
  <div class="panel-panel panel-col">
    <div><div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1293-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1293-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1292-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1292-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
</div>
  </div>
</div>
  </div>
</div>
  </div>
    </div>
  </div>

     <div tabindex="0" id="content" class="">

    <div id="page-header">
                      </div>
           <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    
<div class="panel-display moscone-flipped clearfix " >

  <div class="moscone-container moscone-header clearfix panel-panel">
    <div id='moscone-header-inner' class="moscone-container-inner moscone-header-inner panel-panel-inner">
          </div>
  </div>

  <div class="moscone-flipped-container moscone-flipped-column-content clearfix">
    <div class="moscone-flipped-column-content-region moscone-flipped-content panel-panel">
      <div id='moscone-flipped-content-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-content-inner panel-panel-inner">
        <div class="panel-pane pane-etowah-story-pane-photo" >
  
      
  
  <div class="pane-content">
      
  <img src="/nuggets/sites/nuggets/files/styles/story_main_photo/public/getty-images-873080220.jpg?itok=NFpsSgab" alt="" />      <div class="story-photo-caption">
      DENVER, CO - NOVEMBER 11:  Jamal Murray #27 of the Denver Nuggets handles the ball against the Orlando Magic on November 11, 2017 at the Pepsi Center in Denver, Colorado.     </div> 
        <div class="story-photo-credit">
      Garrett Ellwood/NBAE via Getty Images    </div>
  

  <div>
    <h1>Jamal Murray's Career Night Powers Nuggets Past Magic</h1>
     
      <div class="field field-name-field-subheadline field-type-text field-label-hidden">
              </div>
      </div>
  </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-author" >
  
      
  
  <div class="pane-content">
     
<div class="author-block">
   
   
  <div class="author-block__author">by Christopher Dempsey</div>
      <div class="author-block__author-title">Nuggets Insider <br/> <a href="https://twitter.com/chrisadempsey" target="_blank">@chrisadempsey</a></div>
    <div class="author-block__post-date">Posted: Nov 11, 2017</div>
    <div class="social-bar--author-block__wrapper"><div class='social-bar-wrapper social-bar--author-block' id='social-bar-wrapper-255075afb1ab9d8835'><div class="item-list"><ul class="social-bar "><li class="social-bar__item first"><a href="https://facebook.com/sharer.php?u=https://www.nba.com/nuggets/news/murray-career-night-111117&amp;t=Jamal+Murray%27s+Career+Night+Powers+Nuggets+Past+Magic" class="social-facebook-icon facebook-color social-facebook-popup" title="Share on Facebook" target="_blank"><span class='element-invisible'>Facebook</span></a></li>
<li class="social-bar__item"><a href="https://plus.google.com/share?url=https://www.nba.com/nuggets/news/murray-career-night-111117" class="social-google-plus-icon google-plus-color social-google-plus-popup" title="Share on Google-Plus" target="_blank"><span class='element-invisible'>Google Plus</span></a></li>
<li class="social-bar__item last"><a href="https://twitter.com/intent/tweet?url=https://www.nba.com/nuggets/news/murray-career-night-111117&amp;text=Jamal+Murray%27s+Career+Night+Powers+Nuggets+Past+Magic&amp;via=nuggets" class="social-twitter-icon twitter-color social-twitter-popup" title="Share on Twitter" target="_blank"><span class='element-invisible'>Twitter</span></a></li>
</ul></div></div></div>
  </div><!-- End author-block -->  </div>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="pane-content">
    <div class="field field-name-body field-type-text-with-summary field-label-hidden">
  		  <p>Playing in Denver on the second of a back-to-back used to have this look more often than not.</p>
<p>Team X arrives late at night, and even if they played a yawner the night before that didn’t tax them too much, they were still too tired to keep up with the Nuggets, who ran their legs off early and kept the pressure up all night.</p>
<p>Saturday was that game for these Nuggets. Orlando was the opponent who had a relatively easy win over Phoenix the night before. That didn’t matter. The Magic quickly burned through whatever energy it had conserved in trying to keep up with the Nuggets on the Pepsi Center court.</p>
<p>And the Nuggets won, 125-107. </p>
<p>It wrapped up a wildly successful homestand in which the Nuggets won five of the six games. They’ve won seven of their last nine overall and are 6-2 at home in this still-young season. Saturday’s win? Powered by Jamal Murray.</p>
<p>The second-year point guard heated up early and broke out in a big way, setting a new career-high with 32 points on 11-of-19 shooting. Included in that was a career-high six 3-pointers. Nikola Jokic nearly had a triple-double with 12 points, 17 rebounds and eight assists, and Paul Millsap also nearly had a triple-double with 16 points, eight rebounds and eight assists.</p>
<p>“It was a lot of fun to watch those guys play,” Malone said.</p>
<p>Production came from everywhere.</p>
<p>But it was the guards who got the Nuggets off on the right foot. Murray led with 22 first half points, but Will Barton and Emmanuel Mudiay provided support. The three combined for 70 points on 25-of-45 shooting. Barton had a season-high 26 points and a season-high nine rebounds. Mudiay hit double figures yet again with 12 points.</p>
<p>But it was Murray’s night.</p>
<p>“Jamal and I talk a lot,” Malone said. “I talked to him after shootaround the other day and said, listen, you’re not shooting it consistently because you take a different shot all of the time. If you want to be a shooter, you have to take the same shot all of the time. And I want to see you start being more disciplined with your shot. And the other thing I said is ‘You’ve got to be aggressive.’”</p>
<p>Message received.</p>
<p>“I was just shooting,” Murray said. “One of the coaches on the staff…said if you’re open, shoot it. And I did just that.”</p>
<p>With the three guards in rhythm, the Nuggets never faltered. They built a 30-point lead in the third quarter and never looked back. Orlando never seriously challenged the rest of the way.</p>
<div class="nbaGalleryContainer">
<div class="nbaGallery nbaEmbeddedGallery" data-id="25487" data-path="/nuggets/photogallery/nuggets-beat-magic-111117">
<div class="nbaGalleryDetails">
<h2 class="galleryTitle" tabindex="0"></h2>
<div class="dateTag">
<div class="galleryDate" tabindex="0"></div>
<div class="galleryTagList">
<div class="tag__title">Tags</div>
<div class="tagList"></div>
</div>
</div>
</div>
<div class="nbaImageGallery">
<div class="gallery">
<div class="slides"></div>
<div class="galleryThumbs"></div>
<div class="gallery-ads__interstitial-ad">
<div class="galleryAd"></div>
<div class="gallery-ads__close-interstitial-ad">
<div class="circle-back"></div>
<div class="icon-close"></div>
</div>
</div>
<div class="galleryEndSlate loading">
          <button class="gallery-ads__close-overlay glyphicon glyphicon-remove"> Close related photo gallery overlay.</button></p>
<div class="galleryEndSlateRecommendations"></div>
<div class="galleryEndSlateAd"></div>
</div>
</div>
<div class="action">
<div class="gallery-ads__aside"></div>
<div class="galleryCaptions"></div>
<div class="gallerySlidePosition"><span class="currentSlide">1</span>/<span class="slideTotal"></span></div>
<div class="galleryShare">
<div class="social">
<p>Share Links:</p>
<div class="social-bar-wrapper " id="social-bar-wrapper-254875afb1aba02e2d">
<div class="item-list">
<ul class="social-bar ">
<li class="social-bar__item first"><a href="https://facebook.com/sharer.php?u=https://www.nba.com/nuggets/photogallery/nuggets-beat-magic-111117&amp;t=Nuggets+Beat+Magic" class="social-facebook-icon facebook-color social-facebook-popup" title="Share on Facebook" target="_blank"><span class="element-invisible">Facebook</span></a></li>
<li class="social-bar__item"><a href="https://plus.google.com/share?url=https://www.nba.com/nuggets/photogallery/nuggets-beat-magic-111117" class="social-google-plus-icon google-plus-color social-google-plus-popup" title="Share on Google-Plus" target="_blank"><span class="element-invisible">Google Plus</span></a></li>
<li class="social-bar__item last"><a href="https://twitter.com/intent/tweet?url=https://www.nba.com/nuggets/photogallery/nuggets-beat-magic-111117&amp;text=Nuggets+Beat+Magic&amp;via=nuggets" class="social-twitter-icon twitter-color social-twitter-popup" title="Share on Twitter" target="_blank"><span class="element-invisible">Twitter</span></a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<p>“What I like is offensively you can see we are starting to figure it out. You can see the confidence, the chemistry, the spacing, guys playing off of each other but more importantly, guys are playing for each other. We have a lot of weapons and obviously we had a great offense last year. Takes some time to acclimated these new guys into the lineup – we have a new player in Paul Millsap. But for me, you’re starting to see us offensively find our rhythm and find our groove.”</p>
<p>Christopher Dempsey: <a href="mailto:christopher.dempsey@altitude.tv">christopher.dempsey@altitude.tv</a> and @chrisadempsey on Twitter.</p>
<p><img src="https://i.cdn.turner.com/drp/nba/nuggets/sites/default/files/dn-nuggetofthenight-tw_2_1.jpg" /></p>
	</div>
  </div>

  
  </div>
<div class="panel-pane pane-node-links link-wrapper" >
  
      
  
  <div class="pane-content">
      </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-tags" >
  
      
  
  <div class="pane-content">
    <div class="tag__title">Tags</div><div class="tag__link-wrapper"><a href="/nuggets/archive/Millsap%2C%20Paul" class="tag__link" aria-label="Link to content tagged with Millsap, Paul">Millsap, Paul</a>, <a href="/nuggets/archive/Mudiay%2C%20Emmanuel" class="tag__link" aria-label="Link to content tagged with Mudiay, Emmanuel">Mudiay, Emmanuel</a>, <a href="/nuggets/archive/Murray%2C%20Jamal" class="tag__link" aria-label="Link to content tagged with Murray, Jamal">Murray, Jamal</a>, <a href="/nuggets/archive/Malone%2C%20Michael" class="tag__link" aria-label="Link to content tagged with Malone, Michael">Malone, Michael</a>, <a href="/nuggets/archive/Nuggets" class="tag__link" aria-label="Link to content tagged with Nuggets">Nuggets</a></div>  </div>

  
  </div>
      </div>
    </div>
    <div class="moscone-flipped-column-content-region moscone-flipped-sidebar panel-panel">
      <div id='moscone-flipped-sidebar-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-sidebar-inner panel-panel-inner">
        <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60ce-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60ce-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-etowah-story-pane-rel-stories" >
  
        <h4 class="pane-title" tabindex="0">Related Content</h4>
    
  
  <div class="pane-content">
      <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Millsap, Paul</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--videos" href="https://www.nba.com/nuggets/video/millsap-highlights-042718"><img class="content-image" width="210" height="140" alt="Paul Millsap 2017-18 Highlights" src="https://i.cdn.turner.com/nba/big/teams/nuggets/2018/04/27/2070126/1524849323440-SeasonRecap-Millsap-2-2070126-1.576x324.jpg"/></a>                    <div class="post__title"><a href="/nuggets/video/millsap-highlights-042718" class="node_title related-content__link related-content__link--title">Paul Millsap 2017-18 Highlights</a></div>
                    <div class="post__date">April 27, 2018</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/nuggets/story/millsap-player-breakdown-042718"><img class="content-image" src="/nuggets/sites/nuggets/files/styles/content_thumb/public/1718_seasonrecap_tw_millsap.png?itok=UYxQ8arr" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/story/millsap-player-breakdown-042718" class="node_title related-content__link related-content__link--title">2017-18 Nuggets Player Breakdown: Paul Millsap</a></div>
                    <div class="post__date">April 27, 2018</div>
        </li>
          </ul>
  </div>
  <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Mudiay, Emmanuel</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--videos" href="https://www.nba.com/nuggets/video/n360-mudiay-malone-africa-011718"><img class="content-image" width="210" height="140" alt="N360: Mudiay and Malone's Trip to NBA Africa Game" src="https://i.cdn.turner.com/nba/big/teams/nuggets/2018/01/17/1865389/1516224656424-N360-Africa-short-Vidanta-1865389-5.576x324.jpg"/></a>                    <div class="post__title"><a href="/nuggets/video/n360-mudiay-malone-africa-011718" class="node_title related-content__link related-content__link--title">N360: Mudiay and Malone&#039;s Trip to NBA Africa Game</a></div>
                    <div class="post__date">January 17, 2018</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--photos" href="https://www.nba.com/nuggets/photogallery/shootaround-before-grizzlies-011218"><img class="content-image" src="/nuggets/sites/nuggets/files/styles/content_thumb/public/167a9788websize_0.jpg?itok=Y1ydFJh8" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/photogallery/shootaround-before-grizzlies-011218" class="node_title related-content__link related-content__link--title">Friday Morning Shootaround</a></div>
                    <div class="post__date">January 12, 2018</div>
        </li>
          </ul>
  </div>
  <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Murray, Jamal</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--videos" href="https://www.nba.com/nuggets/video/murray-season-recap-042618"><img class="content-image" width="210" height="140" alt="Jamal Murray Season Recap" src="https://i.cdn.turner.com/nba/big/teams/nuggets/2018/04/26/2068294/1524762645507-SeasonRecap-Murray-2068294-1.576x324.jpg"/></a>                    <div class="post__title"><a href="/nuggets/video/murray-season-recap-042618" class="node_title related-content__link related-content__link--title">Jamal Murray Season Recap</a></div>
                    <div class="post__date">April 26, 2018</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/nuggets/story/murry-sesaon-breakdown-042618"><img class="content-image" src="/nuggets/sites/nuggets/files/styles/content_thumb/public/1718_seasonrecap_tw_murray.png?itok=V1clI8RI" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/story/murry-sesaon-breakdown-042618" class="node_title related-content__link related-content__link--title">2017-18 Nuggets Player Breakdown: Jamal Murray</a></div>
                    <div class="post__date">April 26, 2018</div>
        </li>
          </ul>
  </div>
  </div>

  
  </div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60d1-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60d1-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
      </div>
    </div>
  </div>

  <div class="moscone-container moscone-footer clearfix panel-panel">
    <div id='moscone-footer-inner' class="moscone-container-inner moscone-footer-inner panel-panel-inner">
      <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60cf-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60cf-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
    </div>
  </div>

</div><!-- /.moscone-flipped -->
  </div>
</div>
  </div>
    </div>
  </div><!-- End .page -->

</main>

  <div class="region region-footer">
    <div id="block-panels-mini-mini-panel-footer" class="block block-panels-mini">

    
  <div class="content">
    
<footer id="footer" role="footer" class="footer panel-display etowah-footer clearfix etowah-footer" id="mini-panel-mini_panel_footer">
  <div class="footer-top">
    <div class="container">
      <div class="row">
        <div class="custom-page-ad_bottom">
          <div class="panel-pane pane-fieldable-panels-pane pane-uuid-b244530f-50b5-4b48-abd1-615c8cb48ea4 pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		  <img height="1" width="1" style="border-style:none;" alt="" src="//insight.adsrvr.org/track/evnt/?adv=puaym5k7&ct=0:hu4awgww&fmt=3"/>  	</div>
</div>

  
</div>
        </div>
      </div>
      <div class="row">
        <ul class="col-xs-12 footer-top-sponsors">
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-fieldable-panels-pane pane-uuid-49971dc6-c9f4-4e39-8508-a3f7233296b3 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
                        <div class="field field-name-field-etowah-promo-image field-type-image field-label-hidden">
  		  <img src="/nuggets/sites/nuggets/files/dn-sitelogo-pickaxe-105x105.png" width="105" height="105" alt="Denver Nuggets Pick Axe Logo" title="Denver Nuggets Pick Axe Logo" />	</div>
       
      </div>

  
</div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-navigation" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="/nuggets/tickets/contact-us" title="">Contact Us</a></li>
<li class="leaf"><a href="https://www.nba.com/nuggets/staff_directory/employment.html" target="_blank" title="">Employment</a></li>
<li class="leaf"><a href="/nuggets/contact/faqs" title="">FAQs</a></li>
<li class="last leaf"><a href="/nuggets/staff-directory" title="">Staff Directory</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-menu-kse-info" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="http://forms.ksecolorado.com/af2?LinkID=CH00096812eR00000034AD" target="_blank" title="">Newsletter Sign-Up</a></li>
<li class="leaf"><a href="http://www.pepsicenter.com/tours" target="_blank" title="">Pepsi Center Tours</a></li>
<li class="leaf"><a href="/nuggets/advertise-with-us" title="">Advertise With Us</a></li>
<li class="leaf"><a href="http://www.pepsicenter.com/AboutUs/KSEMission/Default.aspx" target="_blank" title="">KSE Mission Statement</a></li>
<li class="last leaf"><a href="/nuggets/nba-fan-code-conduct" title="">NBA Fan Code of Conduct</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-menu-column-three" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="http://www.altitudeauthentics.com/" target="_blank" title="">Altitude Authentics</a></li>
<li class="leaf"><a href="http://www.altitudetickets.com/" target="_blank" title="">Altitude Tickets</a></li>
<li class="leaf"><a href="http://www.altitudesports950.com/" target="_blank" title="">Altitude Sports Radio</a></li>
<li class="leaf"><a href="http://www.pepsicenter.com/" target="_blank" title="">Pepsi Center</a></li>
<li class="last leaf"><a href="http://www.altitude.tv/" target="_blank" title="">Altitude TV</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-fieldable-panels-pane pane-uuid-cf1a69be-44a5-49e9-896f-1f7cd81cfdc3 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
          <a href="http://www.pepsi.com/en-us/d" target="_blank">              <div class="field field-name-field-etowah-promo-image field-type-image field-label-hidden">
  		  <img src="/nuggets/sites/nuggets/files/promos/dn-footerpepsilogo_180x120_0.png" width="180" height="120" alt="Pepsi Logo" title="Pepsi" />	</div>
       
    </a>  </div>

  
</div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
                      </li>
        </ul>
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-top -->

  <div class="footer-bottom">
    <div class="container">
      <div class="row">
        <div class="footer-left col-xs-12 col-md-6">
          <p class="copyrights">
  Copyright © 2018 NBA Media Ventures, LLC. All rights reserved.
  No portion of NBA.com may be duplicated, redistributed or manipulated in any form.
  By accessing any information beyond this page, you agree to abide by the
  <a href="http://www.nba.com/news/privacy_policy.html">Privacy Policy</a>  /
  <a href="http://www.nba.com/news/privacy_policy.html#priv11">Your California Privacy Rights</a>  and
  <a href="http://www.nba.com/news/termsofuse">Terms of Use</a>  |
  <a href="http://www.nba.com/closed_captioning">Accessibility and Closed Caption</a>  |
  <a id="nba_cnsnt_trst" class="nbaAdChoices" consent="null">
    <script type="text/javascript" src="//consent.truste.com/notice?domain=turner.com&amp;c=nba_cnsnt_trst&amp;text=true&amp;country=us" id="truste_0.7941776050720364"></script>
    <script async="async" type="text/javascript" crossorigin="" src="//consent.truste.com/get?name=notice.js"></script>
  </a>
</p>
        </div><!-- End .footer-right .col-md-6 -->
        <div class="footer-right col-xs-12 col-md-6 pull-left">
          <ul class="footer-nav">
  <li class="footer-nav__menu-item">
    <a href="http://adspecs.nba.com" target="_blank">Advertise on NBA.com</a>    </li>
  <li class="footer-nav__menu-item">
    <a href="http://leaguepasssupport.nba.com" target="_blank">NBA.com Help</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/help/fan_relations_faq.html" target="_blank">Fan Relations FAQ</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/careers/" target="_blank">NBA Career Opportunities</a>  </li>
<ul>
        </div><!-- End .footer-left .col-md-6 -->
      </div><!-- End .row -->
      <div class="row">
        <div class="col-md-12">
          <div class="turner-logo"></div>NBA.com is part of Turner Sports Digital, part of the Turner Sports & Entertainment Digital Network.        </div><!-- End col-md-6 -->
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-bottom -->
</footer> <!-- End .footer -->
  </div>
</div>
  </div>
  <div id="closure" style="visibility:hidden; position:absolute; bottom:0; right:0; max-height :1px; max-width:1px;"><script type="text/javascript">if (document.getElementById("user-login--2")) {document.getElementsByClassName("form-item-pass")[0].getElementsByClassName("description")[0].innerHTML = "Enter the password that accompanies your username.";}</script>

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '276454472733728');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=276454472733728&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
</div><div id="parsely-root" style="display: none">
                  <span id="parsely-cfg" data-parsely-site="nuggets.nba.com"></span>
                </div><script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_EMQJwL3nP_esrf5NoUhG5IKV6OTnU8bxfLxROZZ-06Q.js"></script>
<script type="text/javascript" src="https://z.cdn.turner.com/nba/tmpl_asset/static/nba-cms3-base/latest/js/pkgCustomLibs-min.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_CiOhDD7IeMZY58QyKL3dvueXynVIcn4msmnvHhyX-g8.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_KdQWIKINQBZyGu1LBsBAYG_as7pgvy5uNErmTAOuhbw.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_aiQf68XsPM6zndplRn7gli6laergl9IvwXahO765-90.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_frXquBpHyCVl9ii-2y0kCBVS2zJ9j7XytRdXfa1yMlo.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/sitewide_overrides/active/etowah_swo_46762/footer_sitewide_overrides.js?p87s58"></script>
  </body>
</html>