<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr"
  xmlns:fb="http://ogp.me/ns/fb#"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="timestamp" content="1553029073" />
<link rel="amphtml" href="https://www.nba.com/amp/knicks/2019-memorial-stair-climb" />
<meta property="fb:pages" content="21410634615"><meta name="google-site-verification" content="hz_pPJ7KM3gzMVIlIkcI27IAGIfeaP4d2AgcSRvaEp8"><meta name="p:domain_verify" content="f63e44224ffb3eb9bba0ea3cb07775ef"><meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo"><meta name="google-site-verification" content="UpgGaMYoU8WG0ULgTMdXLJdIXOFeLwqzCC9i5QMNLvY"><link rel="shortcut icon" href="https://www.nba.com/knicks/sites/all/themes/etowah_radix/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="is_https" content="true" />
<script type="text/javascript">var turner_metadata = {
        teamPageType        : "custom",
        turnerId            : "aa41822-1193725393-1389694715530-1",
        entity              : "nba:team:knicks",
        analyticsVersion    : "2.0",
        appName             : "app:nba - desktop",
        registrationState   : "not signed in",
        page                : "nba:team:knicks:features:2019 New York Knicks 911 Memorial Stair Climb Presented by Chase",
        section             : "nba:team:knicks:features",
        subsection          :  "knicks:features",
        articleCategory     : "Features",
        articleTitle        : "2019 New York Knicks 911 Memorial Stair Climb Presented by Chase",
        articleAuthor       : "",
        articlePublishDate  : "03/14/2019",
        articleTags         : "Knicks, Features, Memorial Stair Climb, Chase",
        eventPageView       : "1",
        offsiteSource       : "Team Site"
      };</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"2019 New York Knicks 9\/11 Memorial Stair Climb Presented by Chase","url":"https:\/\/www.nba.com\/knicks\/2019-memorial-stair-climb","dateCreated":"2019-03-14T18:30:00Z","articleSection":"Features","creator":[""],"keywords":["Knicks"],"author":[""],"datePublished":"2019-03-14T18:30:00Z","image":"https:\/\/www.nba.com\/knicks\/sites\/knicks\/files\/nyk_040718_0106w_copy.jpg","publisher":{"@type":"Organization","name":"NBA.com\/knicks","logo":{"@type":"ImageObject","url":"https:\/\/www.nba.com\/.element\/img\/1.0\/teamsites\/logos\/teamlogos_500x500\/NYK.png","width":180,"height":60}},"dateModified":"2019-03-14T18:32:40Z","mainEntityOfPage":"https:\/\/www.nba.com\/knicks\/2019-memorial-stair-climb","thumbnailUrl":"https:\/\/www.nba.com\/knicks\/sites\/knicks\/files\/nyk_040718_0106w_copy.jpg"}</script>
<meta name="description" content="The New York Knicks 9/11 Memorial Stair Climb honors and remembers the FDNY Firefighters who selflessly gave their lives so that others might live on 9/11/2001." />
<meta name="abstract" content="The New York Knicks 9/11 Memorial Stair Climb honors and remembers the FDNY Firefighters who selflessly gave their lives so that others might live on 9/11/2001." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.nba.com/knicks/2019-memorial-stair-climb" />
<link rel="shortlink" href="https://www.nba.com/knicks/node/36725" />
<meta property="og:site_name" content="New York Knicks" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.nba.com/knicks/2019-memorial-stair-climb" />
<meta property="og:title" content="2019 New York Knicks 9/11 Memorial Stair Climb Presented by Chase | New York Knicks" />
<meta property="og:description" content="On Sunday, April 7, the Knicks will host the second annual Knicks 9/11 Memorial Stair Climb Presented by Chase at Madison Square Garden, honoring and remembering the FDNY Firefighters who selflessly gave their lives on 9/11." />
<meta property="og:image" content="https://www.nba.com/knicks/sites/knicks/files/styles/mobile__700x500_/public/nyk_040718_0106w_copy.jpg?itok=j3Ja39dN" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.nba.com/knicks/2019-memorial-stair-climb" />
<meta name="twitter:title" content="2019 New York Knicks 9/11 Memorial Stair Climb Presented by Chase |" />
<meta name="twitter:description" content="On Sunday, April 7, the Knicks will host the second annual Knicks 9/11 Memorial Stair Climb Presented by Chase at Madison Square Garden, honoring and remembering the FDNY Firefighters who selflessly" />
<meta name="twitter:image" content="https://www.nba.com/knicks/sites/knicks/files/styles/mobile__700x500_/public/nyk_040718_0106w_copy.jpg?itok=j3Ja39dN" />
  <title>2019 New York Knicks 9/11 Memorial Stair Climb Presented by Chase | New York Knicks</title>
  <link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/css/css_jYAsS_MaBdjAJUGsB2ia7j9fLNiY8EaPBw1gzqWaBn8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/css/css_an7tFXfSjmI9_Kn7Nw91zch8E40iXgUKOZ1kolcslB4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/css/css_2cz2PryoDx7VDK86rNlyCnwSUmexljArlJcMpt7o2Do.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/css/css_GlsFIjUb7_LzbZh0eyRDyTa1Bg_m9CVgLG4G6AcudHA.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/all/themes/etowah_radix/assets/stylesheets/ie8_fallback.css?po9ct3" media="all" />
<![endif]-->

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/all/themes/etowah_radix/assets/stylesheets/ie7_fallback.css?po9ct3" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/all/themes/etowah_radix/assets/stylesheets/bootstrap.css?po9ct3" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/all/themes/etowah_radix/assets/stylesheets/screen.css?po9ct3" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/css/css_T-TZfTydUwB664EEKJHDcuk7jy4tISCzGTq3m7vhy9Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/css/css_xRL_n5ofpr14VVyq-efCk9FBuKmGPFZ0ZHCBxShpjvM.css" media="print" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?po9ct3" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?po9ct3" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?po9ct3" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?po9ct3" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/colorizer/etowah_radix-dcdd4a60.css" media="all" />
<style type="text/css" media="(min-width: 640px)">
<!--/*--><![CDATA[/*><!--*/
.page{background-image:url(https://www.nba.com/knicks/sites/knicks/files/site_bkgd_0.png)}

/*]]>*/-->
</style>
<style type="text/css" media="(-webkit-min-device-pixel-ratio: 2) and (min-width: 640px), (min-resolution: 192dpi) and (min-width: 640px)">
<!--/*--><![CDATA[/*><!--*/
.page{background-image:url(https://www.nba.com/knicks/sites/knicks/files/styles/hi_res_images/public/site_bkgd_0.png?itok=bYphca4F);background-size :256px auto}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/css/css_oY_1tgZ0-aAt85PHX--Hzt-b_TasypTSRUnFyYbt4QI.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/knicks/sites/knicks/files/sitewide_overrides/active/etowah_swo_61887/style_sitewide_overrides.css?po9ct3" media="all" />
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
var splashify_setting = {"js_splash_always":"0","js_expire_after":86400,"js_mode":"redirect","js_mode_settings":{"mode":"sequence","system_splash":"","urls":["http:\/\/www.nba.com\/knicks\/tickets\/opening-night-splash"],"total_urls":1},"js_disable_referrer_check":0,"schedule":{"activate":"","deactivate":"1508630400"}};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_sOTmJnDhZ0YaYTQBr9FPewnH0WbS6pH--oA8_JDPY0w.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var jQuery1111 = jQuery.noConflict(); var jQuery111 = jQuery1111;
//--><!]]>
</script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_hulMQeqjF8ve0NZMub5AoK8cNJYigyJDRVHqsNsO5gQ.js"></script>
<script type="text/javascript" src="//www.nba.com/javascriptGlobalSettings.js.html"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_eAtNCuh9Vfx9qN14qMJAChJnBHm5P4auvYGH7pl0im8.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_Y9FAYoQEvUHlIziemnM2LVc94gXKH2LLeR6dyp1Zg-w.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_X7IktmZTtApW6d5gSrkqShuy9nI3zNR_kGGp4OW3qPQ.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_iQUZw9q4O0XZrKFg2A4TMLO-25MVhM3NYa9C1NH8U_I.js"></script>
<script type="text/javascript" src="//agility.nba.com/turner/nba-prod/Bootstrap.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/sitewide_overrides/active/etowah_swo_61887/header_sitewide_overrides.js?po9ct3"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_cJm9LdCwmPAu2B2m_sYaE_zfjMGhWlX9dPuMXylJwY0.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]>
   <script>
      document.createElement('header');
      document.createElement('nav');
      document.createElement('section');
      document.createElement('article');
      document.createElement('aside');
      document.createElement('footer');
   </script>
   <link id="respond-proxy" rel="respond-proxy" href="http://i.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="http://z.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="https://s.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-redirect" rel="respond-redirect" href="https://www.nba.com/knicks/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.gif" />
   <script type="text/javascript" src="https://www.nba.com/knicks/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.min.js" />
<script type="text/javascript" src="https://www.nba.com/knicks/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/src/respond.min.js" />
<script type="text/javascript" src="https://www.nba.com/knicks/sites/all/themes/etowah_radix/assets/javascripts/vendor/selectivizr-min.js" />
  <![endif]-->

</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-36725 node-type-story article-detail region-content" data-gameid="0021801204" data-gameurl="20190407/WASNYK">
  <div id="skip-link">
    <a tabindex="1" href="#content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    
<header class="header" role="header">
  <nav class="global-nav-wrapper">
    <div class="container">
    <!--Top of the page navigation and NBA logo -->
      <div class="row">
        <div class="col-xs-12">
          <div class="utility-logo">
            <a tabindex="1" href = "http://www.nba.com"><span class="element-invisible">NBA</span></a>
          </div>
          <ul class="global-nav">
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/" class="teamNavGlobal global-nav__hidden-xs" title="Link to NBA Global">Global</a></li>
            <li class="global-nav__menu-item expanded has-dropdown">
              <a tabindex="1" href="javascript:void(0)" id="global-nav__menu-item__teams-link">Teams</a>
              <ul class="global-nav__menu-item__sub-menu" id="global-nav__menu-item__teams-link-dropdown">
                <li><a class="global-nav__menu-item__sub-menu__sub-item" href="http://www.nba.com/teams/" title="Link to NBA Teams">Teams</a></li>
                <li class="teamHDR">Team Sites</li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hawks/" title="Link to Atlanta Hawks Team Site">Atlanta</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/heat/" title="Link to Miami Heat Team Site">Miami</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/celtics/" title="Link to Boston Celtics Team Site">Boston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bucks/" title="Link to Milwaukee Bucks Team Site">Milwaukee</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nets/" title="Link to Brooklyn Nets Team Site">Brooklyn</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/timberwolves/" title="Link to Minnesota Timberwolves Team Site">Minnesota</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hornets/" title="Link to Charlotte Hornets Team Site">Charlotte</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pelicans/" title="Link to New Orleans Pelicans Team Site">New Orleans</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bulls/" title="Link to Chicago Bulls Team Site">Chicago</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/knicks/" title="Link to New York Knicks Team Site">New York</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/cavaliers/" title="Link to Cleveland Cavaliers Team Site">Cleveland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/thunder/" title="Link to Oklahoma City Thunder Team Site">Oklahoma City</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/mavericks/" title="Link to Dallas Mavericks Team Site">Dallas</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/magic/" title="Link to Orlando Magic Team Site">Orlando</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nuggets/" title="Link to Denver Nuggets Team Site">Denver</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/sixers/" title="Link to Philadelphia 76ers Team Site">Philadelphia</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pistons/" title="Link to Detroit Pistons Team Site">Detroit</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/suns/" title="Link to Phoenix Suns Team Site">Phoenix</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/warriors/" title="Link to Golden State Warriors Team Site">Golden State</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/blazers/" title="Link to Portland Blazers Team Site">Portland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/rockets/" title="Link to Houston Rockets Team Site">Houston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/kings/" title="Link to Sacramento Kings Team Site">Sacramento</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pacers/" title="Link to Indiana Pacers Team Site">Indiana</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/spurs/" title="Link to San Antonio Spurs Team Site">San Antonio</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/clippers/" title="Link to LA Clippers Team Site">LA Clippers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/raptors/" title="Link to Toronto Raptors Team Site">Toronto</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/lakers/" title="Link to LA Lakers Team Site">LA Lakers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/jazz/" title="Link to Utah Jazz Team Site">Utah</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/grizzlies/" title="Link to Memphis Grizzlies Team Site">Memphis</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/wizards/" title="Link to Washington Wizards Team Site">Washington</a></li>
              </ul>
            </li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://gleague.nba.com" title="Link to G League">G League</a></li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://www.wnba.com" title="Link to WNBA" class="teamNavWNBA">WNBA</a></li>
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/storelinkhandler.html" class="teamNavStore" title="Link to NBA Store">NBA Store</a></li>
            <li class="global-nav__menu-item"><a href="/knicks/leaguepass/pricing" class="teamLeaguePass" title="Link to NBA League Pass" tabindex="1">NBA League Pass</a></li>
          </ul>
        </div>
      </div>
    </div>
  </nav>
</header>

<main id="main" class="main">
  <div id="page" class="page">
          <header>
        <nav class="main-nav-wrapper">
          <div class="main-nav-wrapper-inner">
          <div class="container">
            <div class="row">
              <div class="col-md-12">
                <!-- Site Logo -->
                <div class="navbar-brand-wrapper">
                  <a tabindex="1" href="/knicks/" id="logo" class="navbar-brand" title="Home" rel="home">
                                          <img src="https://www.nba.com/knicks/sites/knicks/files/styles/logo/public/logo_1_1.png?itok=atMjbEBz" width="" height="" alt="Site Logo" title="Site Logo" />                                        <span class="element-invisible">New York Knicks</span>
                  </a>
                </div>
                <!-- Presented by Advertisement -->
                <div class="presented-by presented-by--header">
                    <div class="region region-promo-region">
    <div id="block-bean-presented-by-promo" class="block block-bean">

    <h2>Chase at Madison Square Garden</h2>
  
  <div class="content">
      <span class="presented-by__text">Presenting Partner of the New York Knicks</span>
  <a tabindex="1" href="https://madisonsquaregarden.chase.com/" target="_blank">
  <img class="block__img" src="/knicks/sites/knicks/files/styles/presented_by/public/4-30-chase-v3_2.png?itok=9hxwca6d" alt="Chase at Madison Square Garden" title="Chase at Madison Square Garden" /></a>
  </div>
</div>
  </div>
                </div>
                <!-- Main Navigation for Users -->
                <div class="mobile-menu-hamburger"><a href="javascript:;"></a></div>

                <ul id="main-menu" class="main-nav left"><li class="visible-xs mobile-menu-top">Menu</li><li class="first expanded main-nav__menu-item has-dropdown" title="Click to explore tickets"><a href="https://www.nba.com/knicks/ticket-central?icmp=int_knicks_tickets_tc_nav" title="Click to explore tickets">Tickets</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="Click to explore Knicks ticket options"><a href="/knicks/ticket-central" title="Click to explore Knicks ticket options">Ticket Plans</a></li><li class="leaf" title="Click to purchase single game tickets." target="_blank"><a href="https://www.ticketmaster.com/New-York-Knicks-tickets/artist/805988?brand=knicks&amp;camefrom=NBAKNICKS_web_nav_od_180822&amp;utm_source=NBA.com&amp;utm_medium=client&amp;utm_campaign=NBA_TEAM_NY&amp;utm_content=NAV" title="Click to purchase single game tickets." target="_blank">Single Game Tickets with Ticketmaster</a></li><li class="leaf" title=""><a href="https://www.nba.com/knicks/tickets/deposits?icmp=int_web_knicks_tickets_deposits_nav_190205" title="">Place Your Deposit for the 2019-20 Season</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="Click to learn about becoming a Full or Half Season Ticket Member."><a href="https://www.nba.com/knicks/season-membership?icmp=int_web_knicks_tickets_stm_nav_190306" title="Click to learn about becoming a Full or Half Season Ticket Member.">Season Ticket Membership</a></li><li class="leaf" title=""><a href="https://www.nba.com/knicks/tickets/groups?icmp=int_knicks_tickets_groups_nav_190107" title="">Group Tickets</a></li><li class="leaf" title=""><a href="https://www.nba.com/knicks/tickets/group-experiences?icmp=int_knicks_tickets_group-experiences_nav_190107" title="">Group Experiences</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/knicks/tickets/theme-nights?icmp=int_knicks_tickets_theme-nights_nav_190107" title="">Theme Nights</a></li><li class="leaf" title="Click for information on premium and corporate tickets" target="_blank"><a href="https://www.msg.com/premium-hospitality#madison-square-garden&amp;cmp=msgsalescenter_refdom_s-Knicks_t-awa_top nav" title="Click for information on premium and corporate tickets" target="_blank">Premium &amp; Corporate</a></li><li class="leaf" title="Questions? Click here to request info"><a href="/knicks/#open-ticket-form" title="Questions? Click here to request info">Request Ticket Info</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="Click for information on The Garden"><a href="https://www.nba.com/knicks/madison-square-garden-info" title="Click for information on The Garden">Garden Info</a></li><li class="last leaf" title=""><a href="https://www.nba.com/knicks/last-minute-pass?icmp=int_knicks_tickets_last-min-pass_nav_190123" title="">Last Minute Ticket Alerts</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title="Click to view 2017-18 schedule"><a href="/knicks/schedule" title="Click to view 2017-18 schedule">Schedule</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="Click to View the Knicks Season Schedule."><a href="https://www.nba.com/knicks/schedule?icmp=int_knicks_1819schedule_nav_schedule-c" title="Click to View the Knicks Season Schedule.">View 2018-19 Schedule</a></li><li class="leaf" title="Click to add Knicks games to your calendar" target="_blank"><a href="https://www.stanza.co/@nba-knicks/sync?mixpanel#/subscribe/nba-knicks" title="Click to add Knicks games to your calendar" target="_blank">Add To Calendar</a></li><li class="leaf" title="Print the New York Knicks&#039; 2018-19 season schedule!" target="_blank"><a href="https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/media/2018-19/pdf/Knicks2018SeasonSchedule.pdf" title="Print the New York Knicks&#039; 2018-19 season schedule!" target="_blank">Print Schedule</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title="Click to view upcoming theme nights"><a href="https://www.nba.com/knicks/theme-nights?icmp=int_knicks_tickets_theme-nights_nav_schedule-child" title="Click to view upcoming theme nights">View Theme Nights</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title="Click to view roster"><a href="/knicks/roster" title="Click to view roster">Team</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="Click to view roster"><a href="/knicks/roster" title="Click to view roster">Roster</a></li><li class="leaf" title="Click to view leader stats"><a href="/knicks/stats/leaders" title="Click to view leader stats">Leaders</a></li><li class="leaf" title="Click to view team stats"><a href="/knicks/stats" title="Click to view team stats">Team &amp; Player Stats</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="Click to view Westchester Knicks" target="_blank"><a href="http://westchester.gleague.nba.com/" title="Click to view Westchester Knicks" target="_blank">Westchester Knicks</a></li><li class="leaf" title="Click to view Knicks leadership"><a href="/knicks/front-office" title="Click to view Knicks leadership">Knicks Leadership</a></li><li class="last leaf" title="Click to view Knicks history"><a href="/knicks/knicks-history-according-dennis-dagostino" title="Click to view Knicks history">Knicks History</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title="Click to view Knicks news"><a href="https://www.nba.com/knicks/news?icmp=int_knicks_news_parent_nav_190226" title="Click to view Knicks news">News</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-1 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="Click for latest Knicks news."><a href="https://www.nba.com/knicks/news?icmp=int_knicks_news_all_nav_190226" title="Click for latest Knicks news.">All News</a></li><li class="leaf" title=""><a href="https://www.nba.com/knicks/archive/Front%20Office%20News" title="">Front Office News</a></li><li class="last leaf" target="_blank" title="Click to view MSG Blog"><a href="https://blog.msg.com/?cmp=garden_refdom_s-Knicks_t-awa_blog" target="_blank" title="Click to view MSG Blog">MSG Blog</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title="Click to watch Knicks videos"><a href="https://www.nba.com/knicks/video?icmp=int_knicks_video_parent_nav_190226" title="Click to watch Knicks videos">Video</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-1 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="Click to watch all Knicks videos."><a href="https://www.nba.com/knicks/video?icmp=int_knicks_video_all_nav_190226" title="Click to watch all Knicks videos.">All Videos</a></li><li class="leaf" title=""><a href="https://www.nba.com/knicks/archive/Knicks%20Highlights" title="">Highlights</a></li><li class="last leaf" title=""><a href="https://www.nba.com/knicks/archive/Knicks%20Postgame" title="">Knicks Postgame</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/knicks/photos?icmp=int_knicks_photos_parent_nav_190226" title="">Photos</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-1 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="Click to view latest galleries "><a href="https://www.nba.com/knicks/photos?icmp=int_knicks_photos_all_nav_190226" title="Click to view latest galleries ">All Photos</a></li><li class="leaf" title=""><a href="https://www.nba.com/knicks/archive/On%20The%20Court" title="">Knicks on the Court</a></li><li class="last leaf" title="Click to view photos"><a href="https://www.nba.com/knicks/celebrityrow?icmp=int_knicks_photos_celebrity-row_nav_190226" title="Click to view photos">Douglas Elliman Celebrity Row</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title="Click to view Knicks in the community"><a href="/knicks/community" title="Click to view Knicks in the community">Community</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="Click for Knicks in the community"><a href="/knicks/community" title="Click for Knicks in the community">Knicks In The Community</a></li><li class="leaf" title="Click for information on Garden of Dreams" target="_blank"><a href="https://www.gardenofdreamsfoundation.org/" title="Click for information on Garden of Dreams" target="_blank">Garden of Dreams Foundation</a></li><li class="leaf" title="Click for information on Hoops for Troops"><a href="https://www.nba.com/knicks/hoopsfortroops" title="Click for information on Hoops for Troops">Hoops For Troops</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="Click for Sweetwater Clifton Award recipients"><a href="/knicks/sweetwater" title="Click for Sweetwater Clifton Award recipients">Sweetwater Clifton Award</a></li><li class="leaf" title="Click for information on Knicks donation requests" target="_blank"><a href="https://www.nba.com/knicks/community/charitable-donation-request-guidelines" title="Click for information on Knicks donation requests" target="_blank">Donation Requests</a></li><li class="last leaf" title="Click to submit your nomination for the 2018 Dave DeBusshere Award"><a href="http://www.nba.com/knicks/community/dave-debusschere-award-recipients" title="Click to submit your nomination for the 2018 Dave DeBusshere Award">Dave DeBusschere Award</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/knicks/kcd-2015site#/" title="">Fans</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://donate.gardenofdreamsfoundation.org/default.aspx?tsid=9222#.VxFNUPkrJaT" title="">Fan Experiences</a></li><li class="leaf" title="Click to go meet the Knicks City Dancers" target="_blank"><a href="https://www.nba.com/knicks/kcd-2016" title="Click to go meet the Knicks City Dancers" target="_blank">Knicks City Dancers</a></li><li class="leaf" title="Click to learn about Knicks City Kids"><a href="https://nba.com/knicks/knicks-city-kids-open-auditions" title="Click to learn about Knicks City Kids">Knicks City Kids</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="/knicks/official-new-york-knicks-mobile-app" title="">Knicks Mobile App</a></li><li class="last leaf" title="Click to explore official viewing party locations. "><a href="https://www.nba.com/knicks/viewing-headquarters" title="Click to explore official viewing party locations. ">NYC Viewing Parties</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title="Click to learn about our Junior Knicks programs"><a href="https://www.nba.com/knicks/junior" title="Click to learn about our Junior Knicks programs">JR KNICKS</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-1 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="" target="_blank"><a href="https://juniorknicks.leagueapps.com/signup?bid=203853" title="" target="_blank">Junior Knicks Membership</a></li><li class="last leaf" title="Click to explore Junior Knicks Summer Camp sessions"><a href="https://nba.com/knicks/camp?icmp=int_jrk-camp_site-nav_jrk_jrk-camp" title="Click to explore Junior Knicks Summer Camp sessions">Junior Knicks Summer Camp</a></li></ul></li></ul></li><li class="last expanded main-nav__menu-item has-dropdown" title="Click to shop Knicks gear." target="_blank"><a href="https://www.nyknicksstore.com/?_s=bm-Knicks-topnavshoptab" title="Click to shop Knicks gear." target="_blank">STORE</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="" target="_blank"><a href="https://www.nyknicksstore.com/?_s=bm-Knicks-.comtopnavgraphic" title="" target="_blank">Get Knicks Gear</a></li><li class="leaf" target="_blank" title=""><a href="https://www.nyknicksstore.com/new-york-knicks/t-36586331+z-9214017-2129455442?_s=bm-Knicks-.comtopnav-topsellers" target="_blank" title="">Top Sellers</a></li><li class="leaf" target="_blank" title=""><a href="https://www.nyknicksstore.com/new-york-knicks-jerseys/t-14583097+d-6749516316+z-98-4056188827?_s=bm-Knicks-.comtopnav-jerseys" target="_blank" title="">Jerseys</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="" target="_blank"><a href="https://www.nyknicksstore.com/new-york-knicks-hats/t-14033075+d-2361953639+z-96-2448698840?_s=bm-Knicks-.comtopnav-hats" title="" target="_blank">Hats</a></li><li class="leaf" target="_blank" title=""><a href="https://www.nyknicksstore.com/new-york-knicks-kids/t-25367419+ga-36+z-85634-4153879044?ab-bm-Knickscms-TopNav-Kids-5.9.14?_s=bm-Knicks-.comtopnav-jerseys" target="_blank" title="">Kids</a></li><li class="last leaf" target="_blank" title=""><a href="https://www.steinersports.com/collections/new-york-knicks" target="_blank" title="">Knicks Memorabilia by Steiner Sports</a></li></ul></li></ul></li></ul>                                <div class="search-box">
                  <p><span class="search-box__pre-text">Search</span> <a tabindex="-1" class="search-box__icon" href="#"><span tabindex="-1" class="element-invisible">Toggle Search Input</span></a>
                  </p>
                  <div class="search-box__form-wrapper">
                    <form>
                      <label for="search-box__input-box" class="element-invisible">Search Box</label>
                      <input tabindex="1" id="search-box__input-box" class="search-box__input-box" alt="search box" type="text" placeholder="Search" />
                      <input tabindex="1" type="submit" class="submit search-box__submit-btn" value="Search" />
                      <div class="search-box__submit-btn-icon"></div>
                    </form>
                  </div>
                </div>
                <!-- Social Bar -->
                <div class="social-bar-wrapper">
                  <a class="social-bar__mobile-icon visible-xs" href="#"><span class="element-invisible">Social Menu</span></a>
                    <div class="region region-header-social">
    <div id="block-etowah-marketing-social-links-header" class="block block-etowah-marketing">

    
  <div class="content">
    <ul class="social-bar social-bar--header"><li class="social-bar__item"><a href="https://www.facebook.com/NYKnicks" target="_blank" class="social-facebook-icon social-facebook-link facebook-color" alt="facebook social link" title="facebook social link"><span class="element-invisible">facebook</span></a></li><li class="social-bar__item"><a href="https://twitter.com/nyknicks" target="_blank" class="social-twitter-icon social-twitter-link twitter-color" alt="twitter social link" title="twitter social link"><span class="element-invisible">twitter</span></a></li><li class="social-bar__item"><a href="https://plus.google.com/+NYKnicks" target="_blank" class="social-google-plus-icon social-google-plus-link google-plus-color" alt="google-plus social link" title="google-plus social link"><span class="element-invisible">google-plus</span></a></li><li class="social-bar__item"><a href="https://instagram.com/nyknicks" target="_blank" class="social-instagram-icon social-instagram-link instagram-color" alt="instagram social link" title="instagram social link"><span class="element-invisible">instagram</span></a></li><li class="social-bar__item"><a href="https://form.jotform.com/63194219617965" target="_blank" class="social-pinterest-icon social-pinterest-link pinterest-color" alt="pinterest social link" title="pinterest social link"><span class="element-invisible">pinterest</span></a></li></ul>  </div>
</div>
  </div>
                </div>
              </div><!-- End .col-lg-12 -->
            </div><!-- End .row -->
          </div><!-- End .container -->
        </div><!-- End .main-nav-wrapper-inner -->
        </nav><!-- End .main-nav-wrapper -->
      </header>
    
    <div class="container">
      
    </div>
          <div class="page-header-ad">
        <div class="container">
            <div class="region region-header">
    <div id="block-panels-mini-mini-panel-top-banner-ad" class="block block-panels-mini">

    
  <div class="content">
    
<div class="panel-display boxton clearfix " id="mini-panel-mini_panel_top_banner_ad">

  <div class="boxton-container boxton-content boxton-content-region panel-panel">
    <div class="panel-pane pane-fieldable-panels-pane pane-uuid-50ace35d-a118-4a8a-9368-82aa8b06e831 pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		  <link rel="stylesheet" type="text/css" href="https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/prod/forms/ticket-form-modal/bundle.css"/>

  <div class="modal-container" id="form-modal">
      <div class="form-container">
        <div class="modal-toolbar">
          <h5>Get In Touch</h5>
          <div
            id="modal-close"
            class="modal-close"
            aa-analytics="aa-dtm-track"
            data-linklocation="modal"
            data-linkmodule="form-stack"
            data-linktype="lead-gen"
            data-linktitle="ticket-central-inquiry-form-prod"
            data-linkid="form-close"
          ></div>
        </div>
        <iframe id="iframe-resizer" src="/knicks/ticket-form" scrolling="no"></iframe>
      </div>
    </div>

<script type="text/javascript" src="https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/prod/forms/ticket-form-modal/bundle.js"></script>	</div>
</div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-fe4a828a-4d24-44b9-abdd-611dfe586362 pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		  <div class="gpt_container banner-ad" data-type="takeover">

		<script type='text/javascript'>
		  var googletag = googletag || {};
		  googletag.cmd = googletag.cmd || [];
		  (function() {
		    var gads = document.createElement('script');
		    gads.async = true;
		    gads.type = 'text/javascript';
		    var useSSL = 'https:' == document.location.protocol;
		    gads.src = (useSSL ? 'https:' : 'http:') +
		      '//www.googletagservices.com/tag/js/gpt.js';
		    var node = document.getElementsByTagName('script')[0];
		    node.parentNode.insertBefore(gads, node);
		  })();
		</script>

		<script type='text/javascript'>
		  googletag.cmd.push(function() {
		    googletag.defineSlot('/2117/knicks_desktop_1024px/homepage_pencil_ad_1150x440_1x1', [1, 1], 'div-gpt-ad-1503346478559-0').addService(googletag.pubads());
		    googletag.pubads().enableSingleRequest();
		    googletag.enableServices();
		  });
		</script>

		<!-- /2117/hornets_cha_desktop_1024px/homepage_pencil_ad_1150x440_1x1 -->
		<div id='div-gpt-ad-1503346478559-0' style='height:1px; width:1px;'>
		<script type='text/javascript'>
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1503346478559-0'); });
		</script>
		</div>
</div>
	</div>
</div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1293-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1293-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
  </div>

</div><!-- /.boxton -->
  </div>
</div>
  </div>
        </div>
      </div>
    
     <div tabindex="0" id="content" class="">

    <div id="page-header">
                      </div>
           <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    
<div class="panel-display moscone-flipped clearfix " >

  <div class="moscone-container moscone-header clearfix panel-panel">
    <div id='moscone-header-inner' class="moscone-container-inner moscone-header-inner panel-panel-inner">
      <div class="panel-pane pane-fieldable-panels-pane pane-current-1587 pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		  <link rel="stylesheet" type="text/css" href="https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/prod/article-detail/related-articles/bundle.css"/>

    <div class="title-photo-wrapper responsive">
      <div class="title-wrapper">
        <div class="hero-content">
          <div class="subheadline"></div>
        </div>
      </div>
      <div class="adp-hero-image"></div>
    </div>	</div>
</div>

  
</div>
<div class="panel-pane pane-etowah-story-pane-author" >
  
      
  
  <div class="pane-content">
     
<div class="author-block">
   
      <div class="author-block__post-date">Posted: Mar 14, 2019</div>
    <div class="social-bar--author-block__wrapper"><div class='social-bar-wrapper social-bar--author-block' id='social-bar-wrapper-367255c9157d0b71c7'><div class="item-list"><ul class="social-bar "><li class="social-bar__item first"><a href="https://facebook.com/sharer.php?u=https://www.nba.com/knicks/2019-memorial-stair-climb&amp;t=2019+New+York+Knicks+9%2F11+Memorial+Stair+Climb+Presented+by+Chase" class="social-facebook-icon facebook-color social-facebook-popup" title="Share on Facebook" target="_blank"><span class='element-invisible'>Facebook</span></a></li>
<li class="social-bar__item"><a href="https://plus.google.com/share?url=https://www.nba.com/knicks/2019-memorial-stair-climb" class="social-google-plus-icon google-plus-color social-google-plus-popup" title="Share on Google-Plus" target="_blank"><span class='element-invisible'>Google Plus</span></a></li>
<li class="social-bar__item last"><a href="https://twitter.com/intent/tweet?url=https://www.nba.com/knicks/2019-memorial-stair-climb&amp;text=2019+New+York+Knicks+9%2F11+Memorial+Stair+Climb+Presented+by+Chase&amp;via=nyknicks" class="social-twitter-icon twitter-color social-twitter-popup" title="Share on Twitter" target="_blank"><span class='element-invisible'>Twitter</span></a></li>
</ul></div></div></div>
  </div><!-- End author-block -->  </div>

  
  </div>
    </div>
  </div>

  <div class="moscone-flipped-container moscone-flipped-column-content clearfix">
    <div class="moscone-flipped-column-content-region moscone-flipped-content panel-panel">
      <div id='moscone-flipped-content-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-content-inner panel-panel-inner">
        <div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="pane-content">
    <div class="field field-name-body field-type-text-with-summary field-label-hidden">
  		  <p>On Sunday, April 7, the Knicks will host the second annual Knicks 9/11 Memorial Stair Climb Presented by Chase at Madison Square Garden, honoring and remembering the FDNY Firefighters who selflessly gave their lives on 9/11.</p>
<p>Participants will pay <span>tribute by climbing the equivalent of the 110 stories of the World Trade Center.</span> 343 people (equivalent to the 343 firefighters who lost their lives on 9/11) will participate in t<span>he Stair Climb, which benefits the FDNY CSU, UFA Widows and Children's Fund and the programs provided by the National Fallen Firefighters Foundation to support the families of our nation's fallen firefighters.</span></p>
</p>
<p><strong>Register for the Stair Climb: </strong><a href="http://knicks.com/Stair-Climb-Registration">Knicks.com/Stair-Climb-Registration</a><a href="http://events.firehero.org/site/TR?fr_id=2051&amp;pg=entry"><br /></a></p>
</p>
<p><strong>Location: </strong>Madison Square Garden | 4 Pennsylvania Plaza, New York, NY 10121</p>
</p>
<p><strong>Date: </strong>Sunday, April 7, 2019</p>
</p>
<p><strong>Time: </strong><br />Onsite check-in: 11:00am<br />Opening ceremony: 12:00pm<br />Climb start: Immediately after ceremony<br />Climb end: 2:00pm</p>
</p>
<p><strong>Participants: </strong>343 people (equivalent to the 343 firefighters who lost their lives on 9/11) will participate in the stair climb. Each participant is allowed to bring up to three (3) guests.</p>
</p>
<p><strong>Registration Information:</strong><br />- $50 per climber, with proceeds going to the United Firefighter Association and the National Fallen Firefighters Foundation.<br />- Climbers will receive a t-shirt, name badge for the firefighter they are honoring and entrance for up to three (3) guests.<br />- The climb is not open to the public (participants and guests of climbers only).<br />- There will be peer-to-peer fundraising in which participants can receive a Knicks hat, an autographed photo of Larry Johnson or an autographed photo of Walt Frazier.</p>
</p>
<p><strong>Stair Climb Route:</strong> The climb will take place throughout the lower bowl. It will start on-court and wrap around the arena twice, ending back on the court.</p>
</p>
<p>Presented by <a href="http://bit.ly/2t3dK4M"><br />
<div class="media media-element-container media-default">
<div id="file-89047" class="file file-image file-image-png">
<h2 class="element-invisible"><a href="/knicks/file/chaselogoblackblueoctagonpng-0">chase_logo_black_blue_octagon.png</a></h2>
<div class="content">
    <img alt="Chase" title="Chase" height="31" width="167" class="media-element file-default" data-delta="1" src="/knicks/sites/knicks/files/chase_logo_black_blue_octagon_0.png" /></div>
</div>
</div>
<p></a></p>
	</div>
  </div>

  
  </div>
      </div>
    </div>
    <div class="moscone-flipped-column-content-region moscone-flipped-sidebar panel-panel">
      <div id='moscone-flipped-sidebar-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-sidebar-inner panel-panel-inner">
        <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60ce-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60ce-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
      </div>
    </div>
  </div>

  <div class="moscone-container moscone-footer clearfix panel-panel">
    <div id='moscone-footer-inner' class="moscone-container-inner moscone-footer-inner panel-panel-inner">
      <div class="panel-pane pane-fieldable-panels-pane pane-uuid-e1973dfb-61c1-4dc7-8ca7-932ee6ac0ca3 pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		  <link rel="stylesheet" type="text/css" href="https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/prod/custom-panels/flexible-panel/bundle.css"/>

<div class="flexible-panel"></div>

<script type="text/javascript" src="https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/prod/custom-panels/flexible-panel/bundle.js"></script>	</div>
</div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60cf-c062-11e3-8a33-0800200c9a66 orange-dfp-panel pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60cf-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-etowah-story-pane-photo" >
  
      
  
  <div class="pane-content">
      
  <img src="/knicks/sites/knicks/files/styles/story_main_photo/public/nyk_040718_0106w_copy.jpg?itok=MwU6uZWT" alt="" />    

  <div>
    <h1>2019 New York Knicks 9/11 Memorial Stair Climb Presented by Chase</h1>
     
      <div class="field field-name-field-subheadline field-type-text field-label-hidden">
              </div>
      </div>
  </div>

  
  </div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-a5c3efe4-4d0b-44c8-afbc-53cdd2869ed6 pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		      <div class="related-container">
      <div class="content-container">
        <div class="related-upper">
          <div class="adp-related-title"><span class="orange">Related</span> <span class="blue">Articles</span></div>
        </div>

        <div id="related-articles"></div>

      </div>
    </div>

<script type="text/javascript" src="https://cdn.polyfill.io/v2/polyfill.min.js?features=default,es6,fetch,promise,find,Map"></script>
<script type="text/javascript" src="https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/prod/article-detail/related-articles/bundle.js"></script>	</div>
</div>

  
</div>
    </div>
  </div>

</div><!-- /.moscone-flipped -->
  </div>
</div>
  </div>
    </div>
  </div><!-- End .page -->

</main>

  <div class="region region-footer">
    <div id="block-panels-mini-mini-panel-footer" class="block block-panels-mini">

    
  <div class="content">
    
<footer id="footer" role="footer" class="footer panel-display etowah-footer clearfix etowah-footer" id="mini-panel-mini_panel_footer">
  <div class="footer-top">
    <div class="container">
      <div class="row">
        <div class="custom-page-ad_bottom">
          <div class="panel-pane pane-fieldable-panels-pane pane-current-1627 pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		  </div>
<!-- (the above is needed to break out of a container; we reopen it at the end of the file) -->

  <style>
    .footer-image-1 { background-image: url('https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/media/2016-17/img/Knicks_Footer-01_S.png'); }
    .footer-image-2 { background-image: url('https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/media/2018-19/img/Knicks_Footer-02_S.jpg'); }
    .footer-image-3 { background-image: url('https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/media/2016-17/staging/img/Knicks_Footer-03_S.jpg'); }

    @media (min-width: 768px) {
      .footer-image-1 { background-image: url('https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/media/2016-17/img/Knicks_Footer-01_L.png'); }
      .footer-image-2 { background-image: url('https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/media/2018-19/img/Knicks_Footer-02_L.jpg'); }
      .footer-image-3 { background-image: url('https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/media/2016-17/staging/img/Knicks_Footer-03_L.jpg'); }
    }
  </style>

  <div class="footer-images">
    <div class="footer-image footer-image-1">
       <a
        href="https://www.ticketmaster.com/New-York-Knicks-tickets/artist/805988?CAMEFROM=NBAKNICKS_WEB_FOOTER-TILE_190116"
        aa-analytics="aa-dtm-track"
        data-linklocation="footer"
        data-linkmodule="footer-internal-promo"
        data-linktype="internal-promo"
        data-linkid="get-season-tickets"
        target="_blank"
      >
        <span class="link-text">GET SINGLE GAME TICKETS</span>
      </a>
    </div>
    <div class="footer-image footer-image-2">
      <a
        href="/knicks/official-new-york-knicks-mobile-app"
        aa-analytics="aa-dtm-track"
        data-linklocation="footer"
        data-linkmodule="footer-internal-promo"
        data-linktype="internal-promo"
        data-linkid="download=the-mobile-app"
      >
        <span class="link-text">Download the mobile app</span>
      </a>
    </div>
    <div class="footer-image footer-image-3">
      <a
        href="https://www.nyknicksstore.com/New_York_Knicks/"
        target="_blank"
        aa-analytics="aa-dtm-track"
        data-linklocation="footer"
        data-linkmodule="footer-internal-promo"
        data-linktype="internal-promo"
        data-linkid="get-knicks-gear"
      >
        <span class="link-text">Get Knicks gear</span>
      </a>
    </div>
  </div>

<div>	</div>
</div>

  
</div>
        </div>
      </div>
      <div class="row">
        <ul class="col-xs-12 footer-top-sponsors">
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-tickets" >
  
        <h4 class="pane-title" tabindex="0">Tickets</h4>
    
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://nba.com/knicks/ticket-central" title="Click to view ticket plans">Ticket Plans</a></li>
<li class="leaf"><a href="https://www.ticketmaster.com/New-York-Knicks-tickets/artist/805988?brand=knicks&amp;camefrom=NBAKNICKS_web_footer_od_180822&amp;utm_source=NBA.com&amp;utm_medium=client&amp;utm_campaign=NBA_TEAM_NY&amp;utm_content=FOOTER" title="Click to purchase single game tickets" target="_blank">Single Game Tickets by Ticketmaster</a></li>
<li class="leaf"><a href="https://www.nba.com/knicks/tickets/deposits?icmp=int_web_knicks_tickets_deposits_footer_190205" title="">Place Your Deposit for the 2019-20 Season</a></li>
<li class="leaf"><a href="https://www.nba.com/knicks/season-membership?icmp=int_web_knicks_tickets_stm_footer_190306" title="Click to learn about Season Ticket Memberships">Season Ticket Membership</a></li>
<li class="leaf"><a href="https://www.nba.com/knicks/tickets/groups?icmp=int_knicks_tickets_groups_footer_190107" title="">Group Tickets</a></li>
<li class="leaf"><a href="https://www.nba.com/knicks/tickets/group-experiences?icmp=int_knicks_tickets_group-experiences_footer_190107" title="">Group Experiences</a></li>
<li class="leaf"><a href="https://www.nba.com/knicks/tickets/theme-nights?icmp=int_knicks_tickets_theme-nights_footer_190107" title="">Theme Nights</a></li>
<li class="leaf"><a href="https://www.msg.com/premium-hospitality#madison-square-garden&amp;cmp=msgsalescenter_refdom_s-Knicks_t-awa_footer" title="">Premium &amp; Corporate</a></li>
<li class="leaf"><a href="/knicks/#open-ticket-form" title="Click to request info or call from Sales Rep">Contact Us</a></li>
<li class="leaf"><a href="https://www.nyksubcentral.com/user/login" title="">My Knicks Membership</a></li>
<li class="last leaf"><a href="https://www.nba.com/knicks/last-minute-pass?icmp=int_knicks_tickets_last-min-pass_footer_190123" title="">Last Minute Ticket Alerts</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-schedule" >
  
        <h4 class="pane-title" tabindex="0">Schedule</h4>
    
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://www.nba.com/knicks/schedule?icmp=int_knicks_schedule_footer" title="Click to view schedule">2018-19 Schedule</a></li>
<li class="leaf"><a href="https://www.stanza.co/@nba-knicks/sync?mixpanel#/" target="_blank" title="Click to add to calendar">Add to Calendar</a></li>
<li class="last leaf"><a href="https://io.cnn.net/nba/nba/.element/media/2.0/teamsites/knicks/media/2018-19/pdf/Knicks2018SeasonSchedule.pdf" target="_blank" title="Click to print schedule">Print Schedule</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-fans" >
  
        <h4 class="pane-title" tabindex="0">Fans</h4>
    
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://www.msg.com/venue-tours/madison-square-garden?cmp=garden_refdom_s-Knicks_t-awa_fan experiences" title="Click to view fan experiences">Fan Experiences</a></li>
<li class="leaf"><a href="https://www.nba.com/knicks/kcd-2017#/" title="">Knicks City Dancers</a></li>
<li class="leaf"><a href="https://www.nba.com/knicks/official-new-york-knicks-mobile-app" title="">Knicks Mobile App</a></li>
<li class="last leaf"><a href="https://www.nba.com/knicks/junior-knicks-youth-basketball	" title="">Junior Knicks</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-msg" >
  
        <h4 class="pane-title" tabindex="0">MSG</h4>
    
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://www.msg.com/madison-square-garden/seating?cmp=garden_refdom_s-Knicks_t-awa_footerchildren" title="" target="_blank">Seat Map</a></li>
<li class="leaf"><a href="https://www.msg.com/madison-square-garden/directions?cmp=garden_refdom_s-Knicks_t-awa_footerchildren" title="" target="_blank">Getting There</a></li>
<li class="leaf"><a href="https://www.msg.com/madison-square-garden/faqs?cmp=garden_refdom_s-Knicks_t-awa_footerchildren" title="Click to purchase MSG All-Access Tour" target="_blank">Venue FAQs</a></li>
<li class="leaf"><a href="https://www.msg.com/madison-square-garden/disabled-services?cmp=garden_refdom_s-Knicks_t-awa_footerchildren" title="" target="_blank">Disabled Services</a></li>
<li class="leaf"><a href="https://www.msg.com/venue-tours/madison-square-garden?cmp=garden_refdom_s-Knicks_t-awa_footerchildren" title="" target="_blank">Venue Tours</a></li>
<li class="last leaf"><a href="https://www.msg.com/madison-square-garden?cmp=garden_refdom_s-Knicks_t-awa_footerchildren" title="Click to explore MSG properties" target="_blank">Experience MSG</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-shop" >
  
        <h4 class="pane-title" tabindex="0">Shop</h4>
    
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://www.nyknicksstore.com/?_s=bm-Knicks-.comfootergraphic" target="_blank" title="">Get Knicks Gear</a></li>
<li class="leaf"><a href="https://www.nyknicksstore.com/new-york-knicks/t-36586331+z-9214017-2129455442?_s=bm-Knicks-.comfooter-topsellers" title="" target="_blank">Top Sellers</a></li>
<li class="leaf"><a href="https://www.nyknicksstore.com/new-york-knicks-hats/t-14033075+d-2361953639+z-96-2448698840?_s=bm-Knicks-.comfooter-hats" title="" target="_blank">Hats</a></li>
<li class="leaf"><a href="https://www.nyknicksstore.com/new-york-knicks-jerseys/t-14583097+d-6749516316+z-98-4056188827?_s=bm-Knicks-.comfooter-jerseys" title="" target="_blank">Jerseys</a></li>
<li class="leaf"><a href="https://www.nyknicksstore.com/new-york-knicks-kids/t-25367419+ga-36+z-85634-4153879044?ab-bm-Knickscms-TopNav-Kids-5.9.14?_s=bm-Knicks-.comfooter-jerseys" title="" target="_blank">Kids</a></li>
<li class="last leaf"><a href="https://www.steinersports.com/collections/new-york-knicks" title="" target="_blank">Knicks Memorabilia by Steiner Sports</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
                      </li>
        </ul>
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-top -->

  <div class="footer-bottom">
    <div class="container">
      <div class="row">
        <div class="footer-left col-xs-12 col-md-6">
          <p class="copyrights">
  Copyright © 2019 NBA Media Ventures, LLC. All rights reserved.
  No portion of NBA.com may be duplicated, redistributed or manipulated in any form.
  By accessing any information beyond this page, you agree to abide by the
  <a href="http://www.nba.com/news/privacy_policy.html">Privacy Policy</a>  /
  <a href="http://www.nba.com/news/privacy_policy.html#priv11">Your California Privacy Rights</a>  and
  <a href="http://www.nba.com/news/termsofuse">Terms of Use</a>  |
  <a href="http://www.nba.com/closed_captioning">Accessibility and Closed Caption</a>  |
  <a id="nba_cnsnt_trst" class="nbaAdChoices" consent="null">
    <script type="text/javascript" src="//consent.truste.com/notice?domain=turner.com&amp;c=nba_cnsnt_trst&amp;text=true&amp;country=us" id="truste_0.7941776050720364"></script>
    <script async="async" type="text/javascript" crossorigin="" src="//consent.truste.com/get?name=notice.js"></script>
  </a>
</p>
        </div><!-- End .footer-right .col-md-6 -->
        <div class="footer-right col-xs-12 col-md-6 pull-left">
          <ul class="footer-nav">
  <li class="footer-nav__menu-item">
    <a href="http://adspecs.nba.com" target="_blank">Advertise on NBA.com</a>    </li>
  <li class="footer-nav__menu-item">
    <a href="http://leaguepasssupport.nba.com" target="_blank">NBA.com Help</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/help/fan_relations_faq.html" target="_blank">Fan Relations FAQ</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/careers/" target="_blank">NBA Career Opportunities</a>  </li>
<ul>
        </div><!-- End .footer-left .col-md-6 -->
      </div><!-- End .row -->
      <div class="row">
        <div class="col-md-12">
          <div class="turner-logo"></div>NBA.com is part of Turner Sports Digital, part of the Turner Sports & Entertainment Digital Network.        </div><!-- End col-md-6 -->
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-bottom -->
</footer> <!-- End .footer -->
  </div>
</div>
  </div>
  <div id="closure" style="visibility:hidden; position:absolute; bottom:0; right:0; max-height :1px; max-width:1px;"><meta name="p:domain_verify" content="0dc279e98d2c792e47f229a144269b55"/>
<script type="text/javascript">if (document.getElementById("user-login--2")) {document.getElementsByClassName("form-item-pass")[0].getElementsByClassName("description")[0].innerHTML = "Enter the password that accompanies your username.";}</script></div><div id="parsely-root" style="display: none">
                  <span id="parsely-cfg" data-parsely-site="knicks.nba.com"></span>
                </div><script type="text/javascript" src="https://www.nba.com/modules/custom/nba/js/tos/tos.js"></script>
<script type="text/javascript" src="https://z.cdn.turner.com/nba/tmpl_asset/static/nba-cms3-base/latest/js/pkgCustomLibs-min.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_xOb__DZCM_pE6FdBk52Y3X6MBTU7t70aUKRfAnvD3n0.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_KdQWIKINQBZyGu1LBsBAYG_as7pgvy5uNErmTAOuhbw.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_aiQf68XsPM6zndplRn7gli6laergl9IvwXahO765-90.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/js/js_YfkduG9SbnIUE5dKk1TDewY7aHQByK7cjo3-k8mJO9s.js"></script>
<script type="text/javascript" src="https://www.nba.com/knicks/sites/knicks/files/sitewide_overrides/active/etowah_swo_61887/footer_sitewide_overrides.js?po9ct3"></script>
  </body>
</html>