<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr"
  xmlns:fb="http://ogp.me/ns/fb#"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="is_https" content="true" />
<meta name="timestamp" content="1576774384" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="shortcut icon" href="https://www.nba.com/timberwolves/sites/timberwolves/files/mn_timberwolves_official_site_favicon_171001_0pk_icon.ico" type="image/vnd.microsoft.icon" />
<meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo" />
<meta property="fb:pages" content="8373804260"/><meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo"/><link rel="amphtml" href="https://www.nba.com/amp/timberwolves/news/scouting-report-wolves-nuggets-12-20-2019" />
<script type="text/javascript">var turner_metadata = {
        teamPageType        : "custom",
        turnerId            : "aa41822-1193725393-1389694715530-1",
        entity              : "nba:team:timberwolves",
        analyticsVersion    : "2.0",
        appName             : "app:nba - desktop",
        registrationState   : "not signed in",
        page                : "nba:team:timberwolves:features:Scouting Report  Wolves at Nuggets",
        section             : "nba:team:timberwolves:features",
        subsection          :  "timberwolves:features",
        articleCategory     : "news",
        articleTitle        : "Scouting Report  Wolves at Nuggets",
        articleAuthor       : "kratke",
        articlePublishDate  : "12/19/2019",
        articleTags         : "Culver, Jarrett, Teague, Jeff, Towns, Karl-Anthony, Wiggins, Andrew, Nuggets, Timberwolves, Scouting Report",
        eventPageView       : "1",
        offsiteSource       : "Team Site"
      };</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Scouting Report | Wolves at Nuggets","url":"https:\/\/www.nba.com\/timberwolves\/news\/scouting-report-wolves-nuggets-12-20-2019","dateCreated":"2019-12-19T16:13:00Z","articleSection":"news","creator":["kratke"],"keywords":["Culver, Jarrett","Teague, Jeff","Towns, Karl-Anthony","Wiggins, Andrew","Nuggets","Timberwolves"],"author":["kratke"],"datePublished":"2019-12-19T16:13:00Z","image":"https:\/\/www.nba.com\/timberwolves\/sites\/timberwolves\/files\/sr-wolves-nuggets_0.jpg","publisher":{"@type":"Organization","name":"NBA.com\/timberwolves","logo":{"@type":"ImageObject","url":"https:\/\/www.nba.com\/.element\/img\/1.0\/teamsites\/logos\/teamlogos_500x500\/MIN.png","width":180,"height":60}},"dateModified":"2019-12-19T16:49:11Z","mainEntityOfPage":"https:\/\/www.nba.com\/timberwolves\/news\/scouting-report-wolves-nuggets-12-20-2019","thumbnailUrl":"https:\/\/www.nba.com\/timberwolves\/sites\/timberwolves\/files\/sr-wolves-nuggets_0.jpg"}</script>
<meta name="description" content="Minnesota has dropped eight-straight games, most recently on Wednesday night to the Pelicans. Denver, meanwhile, has won four straight." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.nba.com/timberwolves/news/scouting-report-wolves-nuggets-12-20-2019" />
<link rel="shortlink" href="https://www.nba.com/timberwolves/node/49269" />
<meta property="og:site_name" content="Minnesota Timberwolves" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Scouting Report | Wolves at Nuggets | Minnesota Timberwolves" />
<meta property="og:url" content="https://www.nba.com/timberwolves/news/scouting-report-wolves-nuggets-12-20-2019" />
<meta property="og:description" content="Minnesota has dropped eight-straight games, most recently on Wednesday night to the Pelicans. Denver, meanwhile, has won four straight." />
<meta property="og:image" content="https://www.nba.com/timberwolves/sites/timberwolves/files/sr-wolves-nuggets_0.jpg?cw=700&amp;ch=500&amp;w=1067&amp;h=500&amp;x=184&amp;y=0" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.nba.com/timberwolves/news/scouting-report-wolves-nuggets-12-20-2019" />
<meta name="twitter:title" content="Scouting Report | Wolves at Nuggets | Minnesota Timberwolves" />
<meta name="twitter:description" content="Minnesota has dropped eight-straight games, most recently on Wednesday night to the Pelicans. Denver, meanwhile, has won four straight." />
<meta name="twitter:image" content="https://www.nba.com/timberwolves/sites/timberwolves/files/sr-wolves-nuggets_0.jpg?cw=700&amp;ch=500&amp;w=1067&amp;h=500&amp;x=184&amp;y=0" />
  <title>Scouting Report | Wolves at Nuggets | Minnesota Timberwolves</title>
  <link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/css/css_NWg5s4-IdxhcPoJJBHzy5_0duqDxSn1Hx1t3CP8ctDI.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/css/css_MC5Fl2IJ24qnJxqqapZYOGmPEUr6ef8UNoksvrx6Bbo.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/css/css_6klLCvmTSl9w4XMlHaw6MYpLQ8D5ls8B1E22Jqr3JVs.css" media="screen" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/css/css_Zr6GMgQYoJStNP0Xoqx1A8an5XNqKAuR30KOqaCXOdY.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/css/css_tQPKY8fEpSD1z_7vA5v6jaX3mKMsdOSMmblni58u370.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/all/themes/etowah_radix/assets/stylesheets/ie8_fallback.css?q2rqpz" media="all" />
<![endif]-->

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/all/themes/etowah_radix/assets/stylesheets/ie7_fallback.css?q2rqpz" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/all/themes/etowah_radix/assets/stylesheets/bootstrap.css?q2rqpz" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/all/themes/etowah_radix/assets/stylesheets/screen.css?q2rqpz" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/css/css_T-TZfTydUwB664EEKJHDcuk7jy4tISCzGTq3m7vhy9Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/css/css_4qdgx2mlG6KtrmxssvxcU6E8S5L42inTLu07rDqRHD4.css" media="print" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?q2rqpz" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?q2rqpz" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?q2rqpz" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?q2rqpz" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/colorizer/etowah_radix-e5488fb7.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/css/css_C_7P68QI1fhjvybyU6CiwdmbslkPv778caWeN2OxSpU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/timberwolves/sites/timberwolves/files/sitewide_overrides/active/etowah_swo_93124/style_sitewide_overrides.css?q2rqpz" media="all" />
    <script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_sOTmJnDhZ0YaYTQBr9FPewnH0WbS6pH--oA8_JDPY0w.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var jQuery1111 = jQuery.noConflict(); var jQuery111 = jQuery1111;
//--><!]]>
</script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_x1iuGxwJfnnJ-GMJTcWTIxc5ZuFXXYggcjhWM9dco0k.js"></script>
<script type="text/javascript" src="//www.nba.com/javascriptGlobalSettings.js.html"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_eAtNCuh9Vfx9qN14qMJAChJnBHm5P4auvYGH7pl0im8.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_Y9FAYoQEvUHlIziemnM2LVc94gXKH2LLeR6dyp1Zg-w.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_lIrYjw88ZYMAOjUr6Bw4pOWhZwMOgtLzjxtc8yN7yLc.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_ZwBk8Lv2vN8x5nzMJhc-Yrzr6lJXTUrWzrD38AVesTc.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_WnwS-0maauXQoGgSUJB1CBWRfTg0hfd-32jrhIboqug.js"></script>
<script type="text/javascript" src="https://turnip.cdn.turner.com/top/core/1.3.6/default/top.sdk.min.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_95g3RZwdtAw9ZwLc3UEBLnW4DAJMkXf_CPVeEoy8a3k.js"></script>
<script type="text/javascript" src="//agility.nba.com/turner/nba-prod/Bootstrap.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/sitewide_overrides/active/etowah_swo_93124/header_sitewide_overrides.js?q2rqpz"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_O-8YMkEHkTJ_L_8yhpg2uFQGunL4rJ_A62ML0Znf6o8.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]>
   <script>
      document.createElement('header');
      document.createElement('nav');
      document.createElement('section');
      document.createElement('article');
      document.createElement('aside');
      document.createElement('footer');
   </script>
   <link id="respond-proxy" rel="respond-proxy" href="http://i.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="http://z.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="https://s.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-redirect" rel="respond-redirect" href="https://www.nba.com/timberwolves/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.gif" />
   <script type="text/javascript" src="https://www.nba.com/timberwolves/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.min.js" />
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/src/respond.min.js" />
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/all/themes/etowah_radix/assets/javascripts/vendor/selectivizr-min.js" />
  <![endif]-->

</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-49269 node-type-story story-flood region-content" data-gameid="0021900427" data-gameurl="20191220/MINDEN">
  <div id="skip-link">
    <a tabindex="1" href="#content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    
<header class="header" role="header">
  <nav class="global-nav-wrapper">
    <div class="container">
    <!--Top of the page navigation and NBA logo -->
      <div class="row">
        <div class="col-xs-12">
          <div class="utility-logo">
            <a tabindex="1" href = "http://www.nba.com"><span class="element-invisible">NBA</span></a>
          </div>
          <ul class="global-nav">
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/" class="teamNavGlobal global-nav__hidden-xs" title="Link to NBA Global">Global</a></li>
            <li class="global-nav__menu-item expanded has-dropdown">
              <a tabindex="1" href="javascript:void(0)" id="global-nav__menu-item__teams-link">Teams</a>
              <ul class="global-nav__menu-item__sub-menu" id="global-nav__menu-item__teams-link-dropdown">
                <li><a class="global-nav__menu-item__sub-menu__sub-item" href="http://www.nba.com/teams/" title="Link to NBA Teams">Teams</a></li>
                <li class="teamHDR">Team Sites</li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hawks/" title="Link to Atlanta Hawks Team Site">Atlanta</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/heat/" title="Link to Miami Heat Team Site">Miami</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/celtics/" title="Link to Boston Celtics Team Site">Boston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bucks/" title="Link to Milwaukee Bucks Team Site">Milwaukee</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nets/" title="Link to Brooklyn Nets Team Site">Brooklyn</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/timberwolves/" title="Link to Minnesota Timberwolves Team Site">Minnesota</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hornets/" title="Link to Charlotte Hornets Team Site">Charlotte</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pelicans/" title="Link to New Orleans Pelicans Team Site">New Orleans</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bulls/" title="Link to Chicago Bulls Team Site">Chicago</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/knicks/" title="Link to New York Knicks Team Site">New York</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/cavaliers/" title="Link to Cleveland Cavaliers Team Site">Cleveland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/thunder/" title="Link to Oklahoma City Thunder Team Site">Oklahoma City</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/mavericks/" title="Link to Dallas Mavericks Team Site">Dallas</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/magic/" title="Link to Orlando Magic Team Site">Orlando</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nuggets/" title="Link to Denver Nuggets Team Site">Denver</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/sixers/" title="Link to Philadelphia 76ers Team Site">Philadelphia</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pistons/" title="Link to Detroit Pistons Team Site">Detroit</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/suns/" title="Link to Phoenix Suns Team Site">Phoenix</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/warriors/" title="Link to Golden State Warriors Team Site">Golden State</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/blazers/" title="Link to Portland Blazers Team Site">Portland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/rockets/" title="Link to Houston Rockets Team Site">Houston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/kings/" title="Link to Sacramento Kings Team Site">Sacramento</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pacers/" title="Link to Indiana Pacers Team Site">Indiana</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/spurs/" title="Link to San Antonio Spurs Team Site">San Antonio</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/clippers/" title="Link to LA Clippers Team Site">LA Clippers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/raptors/" title="Link to Toronto Raptors Team Site">Toronto</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/lakers/" title="Link to LA Lakers Team Site">LA Lakers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/jazz/" title="Link to Utah Jazz Team Site">Utah</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/grizzlies/" title="Link to Memphis Grizzlies Team Site">Memphis</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/wizards/" title="Link to Washington Wizards Team Site">Washington</a></li>
              </ul>
            </li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://gleague.nba.com" title="Link to G League">G League</a></li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://www.wnba.com" title="Link to WNBA" class="teamNavWNBA">WNBA</a></li>
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/storelinkhandler.html" class="teamNavStore" title="Link to NBA Store">NBA Store</a></li>
            <li class="global-nav__menu-item"><a href="/timberwolves/leaguepass/pricing" class="teamLeaguePass" title="Link to NBA League Pass" tabindex="1">NBA League Pass</a></li>
          </ul>
        </div>
      </div>
    </div>
  </nav>
</header>

<main id="main" class="main">
  <div id="page" class="page">
          <header>
        <nav class="main-nav-wrapper">
          <div class="main-nav-wrapper-inner">
          <div class="container">
            <div class="row">
              <div class="col-md-12">
                <!-- Site Logo -->
                <div class="navbar-brand-wrapper">
                  <a tabindex="1" href="/timberwolves/" id="logo" class="navbar-brand" title="Home" rel="home">
                                          <img src="https://www.nba.com/timberwolves/sites/timberwolves/files/mtimberwolves_primary_timberwolves-site.png?w=180&amp;h=105" alt="Site Logo" title="Site Logo" />                                        <span class="element-invisible">Minnesota Timberwolves</span>
                  </a>
                </div>
                <!-- Presented by Advertisement -->
                <div class="presented-by presented-by--header">
                    <div class="region region-promo-region">
    <div id="block-bean-presented-by-promo" class="block block-bean">

    <h2>Presented by US Bank</h2>
  
  <div class="content">
      <span class="presented-by__text">Presented by</span>
  <a tabindex="1" href="https://www.usbank.com/index.html" target="_blank">
  <img class="block__img" src="/timberwolves/sites/timberwolves/files/wolves-site-sponsored-by-usbank-161101.png?w=87&amp;h=22" alt="Presented by US Bank" title="Presented by US Bank" /></a>
  </div>
</div>
  </div>
                </div>
                <!-- Main Navigation for Users -->
                <div class="mobile-menu-hamburger"><a href="javascript:;"></a></div>

                <ul id="main-menu" class="main-nav left"><li class="visible-xs mobile-menu-top">Menu</li><li class="first expanded main-nav__menu-item has-dropdown" title=""><a href="/timberwolves/ticketcentral" title="">Tickets</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/timberwolves/tickets" title="">Single Game Tickets</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/tickets/holiday?utm_source=TM.WEB&amp;utm_medium=MAIN.NAV&amp;utm_campaign=TW.1920.HOLIDAY.PACK&amp;utm_content=NAVIGATION" title="">Holiday Pack</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/tickets/flex?utm_source=TW.WEB&amp;utm_medium=MAIN.NAV&amp;utm_campaign=TW.1920.FLEX" title="">Flex Pack</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/groups" title="">Groups</a></li><li class="leaf" target="_blank" title=""><a href="https://3ddigitalvenue.com/3dmap/clients/timberwolves/" target="_blank" title="">3D Seat Viewer</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/tickets/memberships?utm_source=TW.Web&amp;utm_medium=MAINNAV&amp;utm_campaign=packages_1920&amp;utm_content=TICKETS_DROPDOWN" title="">2019-20 Season Ticket Memberships</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/ticketcentral" title="">Ticket Central</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/promotions" title="">Single Game Promotions</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/premium" title="">Premium Seating</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/minnesota-timberwolves-and-metro-transit" title="">Getting to the Game</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/partneroffers?utm_source=TW.Web.Nav&amp;utm_medium=Main.Nav&amp;utm_campaign=1819onsale&amp;utm_content=MAIN_NAV" title="">Partner Offers</a></li><li class="last leaf" title=""><a href="https://www.nba.com/timberwolves/tickets/govx?utm_source=TW.WEB&amp;utm_medium=MAIN.NAV&amp;utm_campaign=TW.1920.GOVX" title="">GovX Military Discount</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/timberwolves/schedule/" title="">Schedule</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/timberwolves/schedule/" title="">2019-20 Schedule</a></li><li class="leaf" title=""><a href="http://bit.ly/31wSiBz" title="">Download Schedule</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/schedule/2017" title="">Past Season Results</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/broadcasting.html" title="">Broadcast Info</a></li><li class="leaf" target="_blank" title=""><a href="http://msn.foxsports.com/north/story/fox-sports-north-plus-channel-information-011214" target="_blank" title="">FSN Channel Finder </a></li><li class="leaf" title=""><a href="https://www.targetcenter.com/" title="">Target Center Schedule</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="http://bit.ly/2MYUduA" title="">Add Schedule to Calendar</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/timberwolves/roster" title="">Team</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf"><a href="/timberwolves/roster">Roster</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/standings" title="">Standings</a></li><li class="leaf"><a href="/timberwolves/stats/team">Team Stats</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="http://www.nba.com/timberwolves/photos" title="">Photos</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/team/basketball-operations" title="">Staff Directory</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/timberwolves-communications" title="">Communications</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="https://iowa.gleague.nba.com/" target="_blank" title="">Iowa Wolves (G-League)</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/contact-us" title="">Contact Us</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/mobile" title="">Mobile App</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="https://twitter.com/Timberwolves" title="">@Timberwolves</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/timberwolves/stats" title="">Stats</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="/timberwolves/stats/team" title="">Team Stats</a></li><li class="leaf"><a href="/timberwolves/stats">Player Stats</a></li><li class="leaf" title=""><a href="/timberwolves/stats/leaders" title="">Leader Board</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/standings" title="">Team Standings</a></li><li class="leaf" title=""><a href="https://stats.nba.com/" title="">Advanced Stats</a></li><li class="leaf" title=""><a href="https://stats.nba.com/leaders/" title="">League Leaders</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="https://www.nba.com/timberwolves/standings" title="">Full Standings &amp; Statistics</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/timberwolves/news/" title="">News</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-1"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/timberwolves/news/" title="">Recent Headlines</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/photos" title="">Photo Galleries</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/mediaguide" title="">Media Guide</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/news/wolveswire" title="">WolvesWire</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/community" title="">Community News</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/wolvescast" title="">Recent Audio</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/mobile" title="">Mobile App</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/wolvescast" title="">Podcasts</a></li></ul></li><li class="dropdown-row block"><ul><li class="last leaf" title="" target="_blank"><div class="menu-attach-block-wrapper orientation-vertical">
  <div id="block-bean-news-promo-us-bank-power-of-poss" class="block block-bean">

    
  <div class="content">
    <div class="menu-block">
<a href="https://www.usbank.com/index.html" title="News Promo: US Bank Power of Possible" class="menu-block__link"><img class="block__img" src="/timberwolves/sites/timberwolves/files/wolves-nav-news-190812.png?" width="100%" alt="News Promo: US Bank Power of Possible" title="News Promo: US Bank Power of Possible" /></a>
<a href="https://www.usbank.com/index.html" title="News Promo: US Bank Power of Possible" class="menu-block__link menu-block__link--title">News Promo: US Bank Power of Possible</a>
</div>  </div>
</div>
</div>
</li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/timberwolves/video" title="">Video</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/timberwolves/video" title="">Video Stream</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/video/channel/gameday" title="">Gameday</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/video/channel/team_highlights" title="">Highlights</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/video/channel/practice_central/" title="">Practice Central</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/video/channel/team_originals" title="">Team Originals</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/video/channel/community" title="">Community</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" target="_blank" title=""><a href="https://on.nba.com/2jQX22y" target="_blank" title="">NBA League Pass</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/timberwolves/community/" title="">Community</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="http://www.nba.com/timberwolves/community/community-relations-basketball" title="">Basketball</a></li><li class="leaf" title=""><a href="http://www.nba.com/timberwolves/community/community-relations-education" title="">Education</a></li><li class="leaf" title=""><a href="http://www.nba.com/timberwolves/community/community-relations-military" title="">Military</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/community-relations-hunger" title="">Hunger</a></li><li class="leaf" title=""><a href="http://www.nba.com/timberwolves/community/community-relations-giving" title="">Giving</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/community/community-relations-pack-day-of-service" title="">PACK Day of Service</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="http://www.nba.com/timberwolves/community-archives" title="">Community Archives</a></li><li class="last leaf" target="_blank" title=""><a href="https://www.timberwolvesbasketballacademy.com/" target="_blank" title="">Basketball Academy</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://timberwolvesteamstore.com/" title="">Shop</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" target="_blank" title=""><a href="https://timberwolvesteamstore.com/collections/new-arrivals" target="_blank" title="">New Arrivals</a></li><li class="leaf" title=""><a href="http://bit.ly/2KWFpLu" title="">The Cities Collection</a></li><li class="leaf" target="_blank" title=""><a href="https://timberwolvesteamstore.com/collections/jerseys" target="_blank" title="">Jerseys</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://timberwolvesteamstore.com/collections/mens" title="">Mens</a></li><li class="leaf" target="_blank" title=""><a href="https://timberwolvesteamstore.com/collections/womens" target="_blank" title="">Womens</a></li><li class="leaf" title=""><a href="https://timberwolvesteamstore.com/collections/hats" title="">Hats</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="https://timberwolvesteamstore.com/collections/outerwear" target="_blank" title="">Outerwear</a></li><li class="leaf" target="_blank" title=""><a href="https://timberwolvesteamstore.com/collections/accessories" target="_blank" title="">Accessories </a></li><li class="last leaf" title=""><a href="https://timberwolvesteamstore.com/" title="">Timberwolves Team Store</a>
<a href="# " class="menu-attach-block-drop-link" id="https://timberwolvesteamstore.com/-drop-link-0">More</a><div class="menu-attach-block-wrapper orientation-horizontal">
  <div id="block-bean-team-store-new-gear" class="block block-bean">

    
  <div class="content">
    <div class="menu-block">
<a href="https://timberwolvesteamstore.com/" title="Team Store New Gear" class="menu-block__link"><img class="block__img" src="/timberwolves/sites/timberwolves/files/wolves-menu-tagline2-171017.jpg?" width="100%" alt="Team Store New Gear" title="Team Store New Gear" /></a>
<a href="https://timberwolvesteamstore.com/" title="Team Store New Gear" class="menu-block__link menu-block__link--title">Team Store New Gear</a>
</div>  </div>
</div>
</div>
</li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment" title="">Entertainment</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-6 blocks-1"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-1st-avenue-breakers" title="">1st Avenue Breakers</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-612-crew" title="">612 Crew</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/actionpack" title="">Action Pack</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-crunch" title="">Crunch</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/dancers" title="">Timberwolves Dancers</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-game-night-sounds" title="">Game Night Sounds</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-man-dance" title="">MANDANCE</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-packcussion" title="">PACKcussion</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-the-pups" title="">The Pups</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-senior-dancers" title="">Senior Dancers</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment-slam-squad" title="">Slam Squad</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/fans/timberwolves-entertainment" title="">Performance Groups</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/gamenightmusic" title="">Game Night Music</a></li></ul></li><li class="dropdown-row block"><ul><li class="last leaf" title=""><div class="menu-attach-block-wrapper orientation-horizontal">
  <div id="block-bean-nav-menu-dancers-image" class="block block-bean">

    <h2>Timberwolves Dancers</h2>
  
  <div class="content">
    <div class="menu-block">
<a href="https://www.nba.com/timberwolves/dancers" title="Timberwolves Dancers" class="menu-block__link"><img class="block__img" src="/timberwolves/sites/timberwolves/files/wolves-nav-ent-170822_0.jpg?" width="100%" alt="Timberwolves Dancers" title="Timberwolves Dancers" /></a>
<a href="https://www.nba.com/timberwolves/dancers" title="Timberwolves Dancers" class="menu-block__link menu-block__link--title">Timberwolves Dancers</a>
</div>  </div>
</div>
</div>
</li></ul></li></ul></li><li class="last expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/timberwolves/careers" title="">Careers</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/timberwolves/careers/career-opportunities-fellowship-program-timberwolves-and-lynx" title="">Fellowship Program</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/careers/join-the-pack" title="">Joining The Pack</a></li><li class="leaf" title=""><a href="https://www.nba.com/timberwolves/careers/contact-us" title="">Contact Us</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" target="_blank" title=""><a href="https://www.teamworkonline.com/basketball-jobs/nbateamjobs/minnesota-timberwolves" target="_blank" title="">Current Openings</a></li></ul></li></ul></li></ul>                                <div class="search-box">
                  <p><span class="search-box__pre-text">Search</span> <a tabindex="-1" class="search-box__icon" href="#"><span tabindex="-1" class="element-invisible">Toggle Search Input</span></a>
                  </p>
                  <div class="search-box__form-wrapper">
                    <form>
                      <label for="search-box__input-box" class="element-invisible">Search Box</label>
                      <input tabindex="1" id="search-box__input-box" class="search-box__input-box" alt="search box" type="text" placeholder="Search" />
                      <input tabindex="1" type="submit" class="submit search-box__submit-btn" value="Search" />
                      <div class="search-box__submit-btn-icon"></div>
                    </form>
                  </div>
                </div>
                <!-- Social Bar -->
                <div class="social-bar-wrapper">
                  <!-- <a class="social-bar__mobile-icon visible-xs" href="#"><span class="element-invisible">Social Menu</span></a> -->
                    <div class="region region-header-social">
    <div id="block-etowah-marketing-social-links-header" class="block block-etowah-marketing">

    
  <div class="content">
    <ul class="social-bar first social-bar--header"><li class="social-bar__item "><a href="https://www.facebook.com/MNTimberwolves" target="_blank" class="" alt="Facebook social link" title="Facebook social link" style="background-color:#3b5998"><i class="fab fa-facebook"></i></a></li><li class="social-bar__item "><a href="https://twitter.com/Timberwolves" target="_blank" class="" alt="Twitter social link" title="Twitter social link" style="background-color:#1da1f2"><i class="fab fa-twitter"></i></a></li><li class="social-bar__item "><a href="https://www.instagram.com/timberwolves/" target="_blank" class="" alt="Instagram social link" title="Instagram social link" style="background-color:#000000"><i class="fab fa-instagram"></i></a></li></ul>  </div>
</div>
  </div>
                </div>
              </div><!-- End .col-lg-12 -->
            </div><!-- End .row -->
          </div><!-- End .container -->
        </div><!-- End .main-nav-wrapper-inner -->
        </nav><!-- End .main-nav-wrapper -->
      </header>
    
    <div class="container">
      
    </div>
          <div class="page-header-ad">
        <div class="container">
            <div class="region region-header">
    <div id="block-panels-mini-mini-panel-top-banner-ad" class="block block-panels-mini">

    
  <div class="content">
    <div class="panel-display panel-1col clearfix" id="mini-panel-mini_panel_top_banner_ad">
  <div class="panel-panel panel-col">
    <div><div class="panel-pane pane-fieldable-panels-pane pane-uuid-97104c93-4879-44f9-8fe1-72c9951ad2fc hide pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
          <div id=div-gpt-ad-custom-409964 class="gpt_container" data-size-mobile_320px="320x50" data-size-tablet_640px="468x60" data-size-tablet_768px="728x90" data-size-desktop_1024px="728x90" data-pos-two="" data-pos-one="top_left" data-section="tickets_main" data-background="false"></div>  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60c3-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60c3-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
</div>
  </div>
</div>
  </div>
</div>
  </div>
        </div>
      </div>
    
     <div tabindex="0" id="content" class="">

    <div id="page-header">
                      </div>
           <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    
<div class="panel-display moscone-flipped clearfix " >

  <div class="moscone-container moscone-header clearfix panel-panel">
    <div id='moscone-header-inner' class="moscone-container-inner moscone-header-inner panel-panel-inner">
      <div class="panel-pane pane-etowah-story-pane-photo" >
  
      
  
  <div class="pane-content">
      
  <img src="/timberwolves/sites/timberwolves/files/sr-wolves-nuggets_0.jpg?w=756&amp;h=354" />        <div class="story-photo-credit">
      Getty Images    </div>
  

  <div>
    <h1>Scouting Report | Wolves at Nuggets</h1>
     
      <div class="field field-name-field-subheadline field-type-text field-label-hidden">
              </div>
      </div>
  </div>

  
  </div>
    </div>
  </div>

  <div class="moscone-flipped-container moscone-flipped-column-content clearfix">
    <div class="moscone-flipped-column-content-region moscone-flipped-content panel-panel">
      <div id='moscone-flipped-content-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-content-inner panel-panel-inner">
        <div class="panel-pane pane-etowah-story-pane-author" >
  
      
  
  <div class="pane-content">
     
<div class="author-block">
  <img class="author-block__icon" src="/timberwolves/sites/timberwolves/files/pictures/ratkecleanheadshot-2.jpg?w=100&amp;h=100" alt="" /> 
   
  <div class="author-block__author">by Kyle Ratke, Digital Content Manager</div>
      <div class="author-block__author-title"><p class="ratke-title">Digital Content Manager</p><a href="https://twitter.com/Kyle_Ratke" target="_blank">Follow</a></div>
    <div class="author-block__post-date">Posted: Dec 19, 2019</div>
    <div class="social-bar--author-block__wrapper"><div class='social-bar-wrapper social-bar--author-block' id='social-bar-wrapper-492695dfbaaef01292'><div class="item-list"><ul class="social-bar "><li class="social-bar__item first"><a href="https://facebook.com/sharer.php?u=https://www.nba.com/timberwolves/news/scouting-report-wolves-nuggets-12-20-2019&amp;t=Scouting+Report+%7C+Wolves+at+Nuggets" class="social-facebook-icon facebook-color social-facebook-popup" title="Share on Facebook" target="_blank"><span class='element-invisible'>Facebook</span></a></li>
<li class="social-bar__item last"><a href="https://twitter.com/intent/tweet?url=https://www.nba.com/timberwolves/news/scouting-report-wolves-nuggets-12-20-2019&amp;text=Scouting+Report+%7C+Wolves+at+Nuggets&amp;via=Timberwolves" class="social-twitter-icon twitter-color social-twitter-popup" title="Share on Twitter" target="_blank"><span class='element-invisible'>Twitter</span></a></li>
</ul></div></div></div>
  </div><!-- End author-block -->  </div>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="pane-content">
    <div class="field field-name-body field-type-text-with-summary field-label-hidden">
  		  <p><strong>The Game</strong></p>
<p>The Wolves are hoping to get back on track on Friday night in Denver.</p>
<p>Minnesota has dropped eight-straight games, most recently on Wednesday night to the Pelicans. Denver, meanwhile, has won four straight.</p>
<p>This is the first of a four-game road trip that also includes the Blazers, Warriors and Kings.</p>
<p>The Wolves go into the game with a 10-16 record, tied for 11th in the West. The Nuggets are 18-8, third in the West.</p>
<p>This is the second matchup between the two teams this season. Denver beat Minnesota 100-98 in overtime back on Nov. 10 at Target Center.</p>
<p>We’ll see if Karl-Anthony Towns plays in this one. Towns sat out of Wednesday’s game with a left knee sprain. The team had practice off on Thursday. We’ll likely know more about Towns’ status after Friday’s shootaround. </p>
<p><strong>What: Wolves at Nuggets</strong> <br /><strong>When: 8 p.m. CT, Dec. 20, 2019</strong><br /><strong>Where: Pepsi Center</strong><br /><strong>Watch:<a href="https://www.nba.com/timberwolves/app?_ga=2.209891734.2097191804.1575212413-1996567174.1574728043"> Fox Sports North<br /></a>Listen: <a href="https://www.nba.com/timberwolves/app?_ga=2.209891734.2097191804.1575212413-1996567174.1574728043">830 WCCO</a></strong></p>
<h3><strong>Well-Rounded Machine</strong></h3>
<p>The Nuggets are one of the deepest teams in the league. Need proof? Denver has five players averaging 11 or more points, but nobody is scoring more than 18 points per game. There are also 12 players averaging four or more points.</p>
<p>You look up and down this roster and there really isn’t a clear weakness. If someone gets hurt (which is unavoidable during an NBA season), there’s not much of a drop off to the next guy, apart from maybe going from Nikola Jokic to Mason Plumlee at center. </p>
<p>This is the first of seven-straight games against Western Conference opponents for Denver. There has been plenty of talk about both LA teams, and for good reason, but let’s not sleep on the team that won 54 games last season.</p>
<h3><strong>Would You Believe Me If I Told You …</strong></h3>
<p>After finishing with 27 points against the Pelicans on Wednesday, Andrew Wiggins has now scored 20 or more points in 18 games and 25 or more points in 13 games this season.</p>
<p>Last season, Wiggins hit the 20-point mark 29 times and scored more than 25 points eight times.</p>
<p>If Towns can’t play in this one, the Wolves will need Wiggins to get Minnesota’s offense rolling. </p>
<p>Jarrett Culver (illness) also missed Wednesday night’s game. His availability would be a boost to the starting lineup to give the bench another offensive threat with Jeff Teague. </p>
<h3><strong>Injury Report:</strong></h3>
<p><strong>Wolves: </strong>Karl-Anthony Towns (knee) and Jarrett Culver (illness) are questionable. Jake Layman (toe) is out.</p>
<p><strong>Nuggets:</strong> Torrey Craig (illness) is questionable. </p>
<h3><strong>Projected Starters:</strong></h3>
<p><strong>Wolves:</strong> PG—Wiggins, SG—Culver, SF—Okogie, PF—Covington, C—Dieng</p>
<p><strong>Nuggets:</strong> PG—Murray, SG – Barton, SF – Harris, PF- Millsap, C – Jokic </p>
	</div>
  </div>

  
  </div>
<div class="panel-pane pane-node-links link-wrapper" >
  
      
  
  <div class="pane-content">
      </div>

  
  </div>
<div class="panel-pane pane-custom pane-1" >
  
      
  
  <div class="pane-content">
    <h4 class="pane-title-upcoming" style="display:none;">Upcoming Games</h4>  </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-tags" >
  
      
  
  <div class="pane-content">
    <div class="tag__title">Tags</div><div class="tag__link-wrapper"><a href="/timberwolves/archive/Culver%2C%20Jarrett" class="tag__link" aria-label="Link to content tagged with Culver, Jarrett">Culver, Jarrett</a>, <a href="/timberwolves/archive/Teague%2C%20Jeff" class="tag__link" aria-label="Link to content tagged with Teague, Jeff">Teague, Jeff</a>, <a href="/timberwolves/archive/Towns%2C%20Karl-Anthony" class="tag__link" aria-label="Link to content tagged with Towns, Karl-Anthony">Towns, Karl-Anthony</a>, <a href="/timberwolves/archive/Wiggins%2C%20Andrew" class="tag__link" aria-label="Link to content tagged with Wiggins, Andrew">Wiggins, Andrew</a>, <a href="/timberwolves/archive/Nuggets" class="tag__link" aria-label="Link to content tagged with Nuggets">Nuggets</a></div>  </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-comment" >
  
      
  
  <div class="pane-content">
    <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) {return;}
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));</script>
<div class="fb-comments" data-href="https://www.nba.com/timberwolves/news/scouting-report-wolves-nuggets-12-20-2019" data-num-posts="15" data-width="620" data-colorscheme="light"></div>  </div>

  
  </div>
      </div>
    </div>
    <div class="moscone-flipped-column-content-region moscone-flipped-sidebar panel-panel">
      <div id='moscone-flipped-sidebar-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-sidebar-inner panel-panel-inner">
        <div class="panel-pane pane-custom pane-4" >
  
      
  
  <div class="pane-content">
    <div class="stanza-hold twHP-white-container">
<h3 class="sub-caption-title"><a href="http://bit.ly/2YPzqkF" target="_blank">Download Schedule <span><i class="fa fa-download" aria-hidden="true"></i></span></a></h3>
<div class="stanzacal" data-stanzacal="nba-timberwolves" data-width="100%" data-height="250px" ></div> <script src="https://dff2h0hbfv6w4.cloudfront.net/scripts/embed-stanzacal-v1.js" type="text/javascript"></script>

</div>  </div>

  
  </div>
<div class="panel-pane pane-custom pane-5"  id="trending">
  
      
  
  <div class="pane-content">
    &nbsp;  </div>

  
  </div>
<div class="panel-pane pane-custom pane-6" >
  
      
  
  <div class="pane-content">
    <style>
	#trending {
		background-color: #fff;
		margin-bottom: 15px;
	}
	.trending__title {
		background-image: url(https://www.nba.com/.element/media/2.0/teamsites/timberwolves/media/mntw-trending-background-180416.svg);
		background-color: #0a2240;
		background-clip: border-box;
		background-origin: padding-box;
		background-position: left top;
		background-repeat: no-repeat;
		background-size: auto 100%;
		color: #fff;
		padding-left: 20px;
		font-weight: 400;
		text-transform: uppercase;
		display: -webkit-box;
		display: -ms-flexbox;
		display: flex;
		-webkit-box-pack: justify;
		    -ms-flex-pack: justify;
		        justify-content: space-between;
		margin: 0;
	}
	.trending__title__inner {
		padding: 15px 0;
	}
	.trending__buttons {
		display: -webkit-box;
		display: -ms-flexbox;
		display: flex;
	}
	button.trending__button {
		background-color: transparent;
		border: none;
		font-size: 12px;
		padding: 0 10px;
		-webkit-transition: background-color 300ms ease-in-out;
		transition: background-color 300ms ease-in-out;
	}
	button.trending__button:hover, button.trending__button:focus {
		background-color: #236092;
	}
	button.trending__button.trending__button--active {
		background-color: #76bc21;
		cursor: default;
	}
	.trending__content {
		padding: 15px 20px;
		border: 1px solid #dfe6ea;
		border-top: none;
		min-height: 400px;
	}
	.trending__content ol {
		list-style: none;
		padding: 0;
		margin: 0;
	}
	.trending__article {
		display: -webkit-box;
		display: -ms-flexbox;
		display: flex;
		-webkit-box-pack: justify;
		    -ms-flex-pack: justify;
		        justify-content: space-between;
	}
	.trending__content li {
		padding-bottom: 10px;
		border-bottom: 1px solid #e6e6e6;
		margin-bottom: 10px;
	}
	.trending__content li:last-child {
		border-bottom: none;
		padding-bottom: 0;
		margin-bottom: 0;
	}
	.trending__article__image {
		position: relative;
		max-width: 130px;
		width: 42%;
		-ms-flex-negative: 0;
		    flex-shrink: 0;
		-webkit-box-flex: 1;
		    -ms-flex-positive: 1;
		        flex-grow: 1;
	}
	.trending__article__image::before {
		content: '';
		position: absolute;
		top: 0;
		left: 0;
		bottom: 0;
		right: 0;
		background-color: transparent;
		background-image: linear-gradient(45deg, rgba(118, 188, 33, 0.72) 0%, rgba(118, 188, 33, 0) 100%);
		-webkit-transition: opacity 300ms ease-in-out;
		transition: opacity 300ms ease-in-out;
		opacity: 0;
	}
	.trending__article:hover .trending__article__image::before, 
	.trending__article:focus .trending__article__image::before {
		opacity: 1;
	}
	.trending__article__rank {
		position: absolute;
		top: 0;
		left: 0;
		background-color: #76bc21;
		color: #fff;
		text-align: center;
		font-size: 11px;
		height: 2em;
		width: 2em;
		line-height: 2em;
		-webkit-box-sizing: content-box;
		        box-sizing: content-box;
		border: 2px solid #fff;
		border-radius: 2em;
		-webkit-transform: translate3d(-20%, -20%, 0);
		        transform: translate3d(-20%, -20%, 0);
		-webkit-transition: background-color 300ms ease-in-out;
		transition: background-color 300ms ease-in-out;
	}
	.trending__article__text {
		margin-left: 10px;
		min-width: 130px;
		-webkit-box-flex: 1;
		    -ms-flex-positive: 1;
		        flex-grow: 1;
	}
	.trending__article__headline {
		-webkit-transition: color 300ms ease-in-out;
		transition: color 300ms ease-in-out;
	}
	.trending__article:visited .trending__article__headline {
		color: #9ea1a2;
	}
	.trending__article:hover .trending__article__headline, 
	.trending__article:focus .trending__article__headline {
		color: #76bc21;
	}
	.trending__article__date {
		font-size: 12px;
		color: #9ea1a2;
	}
	@media screen and (min-width: 600px) and (max-width: 992px) {
		.trending__article__text {
			font-size: 1.25em;
		}
	}
</style>
<script src="//cdn.polyfill.io/v2/polyfill.min.js?features=default,es6,es5&excludes=fetch"></script>
<script src="//www.nba.com/.element/media/2.0/teamsites/timberwolves/js/mntw-parsely-trending-sidebar-180418.min.js"></script>  </div>

  
  </div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60ce-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60ce-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60d1-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60d1-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
      </div>
    </div>
  </div>

  <div class="moscone-container moscone-footer clearfix panel-panel">
    <div id='moscone-footer-inner' class="moscone-container-inner moscone-footer-inner panel-panel-inner">
      <div class="panel-pane pane-custom pane-2 hide" >
  
      
  
  <div class="pane-content">
    <div class="stanza-article">
<h4 class="pane-title">DOWNLOAD SCHEDULE</h4>
<!-- REMOVED STANZA THAT USED TO GO HERE-->
</div>  </div>

  
  </div>
<div class="panel-pane pane-custom pane-3" >
  
      
  
  <div class="pane-content">
    <script src="https://www.nba.com/.element/media/2.0/teamsites/timberwolves/js/readingTime.js"></script>
		
		  <script>
		 
		
			jQuery(document).ready(function() {
				
				var bodyElement = jQuery('body');
		
				//if page is a story node
				if(bodyElement.hasClass('story-flood')){
					var img = jQuery('.pane-etowah-story-pane-photo').find('img'),
						imgSrc = img.attr('src');
		
					var newImgSrc = imgSrc.replace(/\?(.*)$/,'');
					img.attr('src',newImgSrc);
				}
			
				jQuery('.field-name-body p').readingTime({
					readingTimeTarget: jQuery(this).find('.eta'),
					wordCountTarget: jQuery(this).find('.words'),
					success: function() {
						console.log('Timberwolves Read Time Calculation Successful');
					},
					
					error: function(message) {
						console.log(message);
						jQuery(this).find('.eta').remove();
					}
				});

                                   //Start Story Photo Credit Position Check
					
					if (jQuery('.story-photo-caption').length) {
						  jQuery('.story-photo-credit').addClass('story-photo-credit-up');
					  }
						
				    //end story photo credit position check
				
			});
			
			var wolvesReadTime = '<p class="wolves-read-time"><small><span class="eta"></span></small></p>';
			
			 jQuery( ".social-bar--author-block__wrapper" ).append(wolvesReadTime);
			 jQuery( ".author-block__post-date" ).append(wolvesReadTime);


		
		</script>  </div>

  
  </div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60cf-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60cf-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
    </div>
  </div>

</div><!-- /.moscone-flipped -->
  </div>
</div>
<div class="etowah_ticket_share mfp-hide">
  <app-ticket-share></app-ticket-share>
</div>
  <div class="nextup_wrapper nextup_original">
    <div class="nextup_contain">
      <div class="nextup_header">
        <div class="nextup_image">
          <img src="" class="thumb" />
        </div>
        <div class="nextup_details">
          <div class="nextup_timer">NEXT UP: <span></span></div>
          <div class="nextup_title"></div>
          <div class="nextup_desc"></div>
        </div>
      </div>
      <div class="nextup_playback">
        <button class="nextup_replay" title="Replay Video">Replay</button>
        <button class="nextup_playnext" title="Play Next Video">Play Next</button>
      </div>
      <div class="nextup_social">
        <hr />
        <ul>
          <li id="nextup_fb">
            <a href="#" target="_blank" title="Share to Facebook">
              <img src="https://cdn.nba.net/assets/video/icons/social_fb.png" alt="Facebook" />
            </a>
          </li>
          <li id="nextup_tw">
            <a href="#" target="_blank" title="Share to Twitter">
              <img src="https://cdn.nba.net/assets/video/icons/social_tw.png" alt="Twitter" />
            </a>
          </li>
          <li id="nextup_link">
            <a href="#" title="Copy share link">
              <img src="https://cdn.nba.net/assets/video/icons/social_lk.png" alt="Share Link" />
            </a>
            <div id="nextup_link_message">Link copied to clipboard</div>
          </li>
        </ul>
      </div>
    </div>
  </div>  </div>
    </div>
  </div><!-- End .page -->

</main>

  <div class="region region-footer">
    <div id="block-panels-mini-mini-panel-footer" class="block block-panels-mini">

    
  <div class="content">
    
<footer id="footer" role="footer" class="footer panel-display etowah-footer clearfix etowah-footer" id="mini-panel-mini_panel_footer">
  <div class="footer-top">
    <div class="container">
      <div class="row">
        <div class="custom-page-ad_bottom">
                  </div>
      </div>
      <div class="row">
        <ul class="col-xs-12 footer-top-sponsors">
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-fieldable-panels-pane pane-current-1129 pane-bundle-etowah-promo"  id="footer-logo-1st">
  
      
  <div class="fieldable-panels-pane">
      <div class="gpt_container">
      <a href="http://bit.ly/2Q8rqTS"><img src="/timberwolves/sites/timberwolves/files/promos/wolves-target-footer-161016.png" class="img-responsive"></a>    </div>
  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-1133 pane-bundle-etowah-promo"  id="footer-logo-2nd">
  
      
  <div class="fieldable-panels-pane">
          <a targediv-gpt-ad-custom-625476"_blank" href="https://mayocl.in/2VujugP"><img src="/timberwolves/sites/timberwolves/files/promos/wolves-mayoclinic-footer-161016.png" class="img-responsive"></a>  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-1641 pane-bundle-etowah-promo"  id="footer-logo-3rd">
  
      
  <div class="fieldable-panels-pane">
      <div class="gpt_container">
      <a href="http://bit.ly/2W6mxAs"><img src="/timberwolves/sites/timberwolves/files/promos/wolves-target-fitbit-170811.png" class="img-responsive"></a>    </div>
  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-1854 pane-bundle-etowah-promo"  id="footer-logo-5th">
  
      
  <div class="fieldable-panels-pane">
          <a href="http://bit.ly/2LKe6qh" target="_blank">              <div class="field field-name-field-etowah-promo-image field-type-file field-label-hidden">
  		  <img src="/timberwolves/sites/timberwolves/files/promos/mntw-sharecare-footer-191001.png?cw=865&amp;ch=484&amp;w=298&amp;h=199&amp;x=0&amp;y=0" width="865" height="484" alt="" title="mntw-sharecare-footer-191001.png" />	</div>
       
    </a>  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-1137 pane-bundle-etowah-promo"  id="footer-logo-4th">
  
      
  <div class="fieldable-panels-pane">
      <div class="gpt_container">
      <a href="http://bit.ly/30rEd8L"><img src="/timberwolves/sites/timberwolves/files/promos/wolves-usbank-footer-161016.png" class="img-responsive"></a>    </div>
  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-1135 pane-bundle-etowah-promo"  id="footer-logo-6th">
  
      
  <div class="fieldable-panels-pane">
      <div class="gpt_container">
      <a href="http://bit.ly/2w48sEW"><img src="/timberwolves/sites/timberwolves/files/promos/wolves-ti-footer-161016.png" class="img-responsive"></a>    </div>
  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-1131 pane-bundle-etowah-promo"  id="footer-logo-7th">
  
      
  <div class="fieldable-panels-pane">
      <div class="gpt_container">
      <a href="http://bit.ly/2VZUkv9"><img src="/timberwolves/sites/timberwolves/files/promos/wolves-federated-footer-161016.png" class="img-responsive"></a>    </div>
  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-1499 pane-bundle-etowah-promo"  id="footer-logo-8th">
  
      
  <div class="fieldable-panels-pane">
      <div class="gpt_container">
      <a href="http://bit.ly/2LPz0EB" target="_blank"><img src="/timberwolves/sites/timberwolves/files/promos/wolves-jacklinks-footer-161016.png" class="img-responsive"></a>    </div>
  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-11 pane-bundle-etowah-promo"  id="footer-logo-9th">
  
      
  <div class="fieldable-panels-pane">
      <div class="gpt_container">
      <a href="https://on.nba.com/2JIvVDG"><img src="/timberwolves/sites/timberwolves/files/promos/wolves-tcl-footer2-161016.png" class="img-responsive"></a>    </div>
  </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-current-1643 pane-bundle-etowah-promo"  id="footer-logo-10th">
  
      
  <div class="fieldable-panels-pane">
          <a href="http://bit.ly/2JkbBcg" target="_blank">              <div class="field field-name-field-etowah-promo-image field-type-file field-label-hidden">
  		  <img src="/timberwolves/sites/timberwolves/files/promos/wolves-target-lifetime-170811.png?cw=865&amp;ch=484&amp;w=596&amp;h=398&amp;x=0&amp;y=0" width="865" height="484" alt="" title="wolves-target-lifetime-170811.png" />	</div>
       
    </a>  </div>

  
</div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
                      </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
                      </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
                      </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
                      </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
                      </li>
        </ul>
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-top -->

  <div class="footer-bottom">
    <div class="container">
      <div class="row">
        <div class="footer-left col-xs-12 col-md-6">
          <p class="copyrights">
  Copyright © 2019 NBA Media Ventures, LLC. All rights reserved.
  No portion of NBA.com may be duplicated, redistributed or manipulated in any form.
  This site is operated jointly by NBA and WarnerMedia. To opt out of the sale of your personal information as permitted by the California Consumer 
  Privacy Act, please use the links below to visit each company’s privacy center. If you make a request through the WarnerMedia Privacy Center, 
  it will apply to data controlled jointly by the NBA and WarnerMedia as well as other data controlled by WarnerMedia. If you make a request through 
  the NBA Privacy Center, it will apply to data controlled independently by the NBA.
  <a href="https://www.nba.com/news/privacy_policy.html#California_Privacy_Rights">NBA Privacy Center</a>  |
  <a href="https://www.nba.com/privacycenter">WarnerMedia Privacy Center</a>  |
  <a href="https://www.nba.com/privacycenter">Do Not Sell My Personal Information</a>  |
  <a href="http://www.nba.com/news/termsofuse">Terms of Use</a>  |
  <a href="http://www.nba.com/closed_captioning">Accessibility and Closed Caption</a>  |
  <a id="nba_cnsnt_trst" class="nbaAdChoices" consent="null">
    <script type="text/javascript" src="//consent.truste.com/notice?domain=turner.com&amp;c=nba_cnsnt_trst&amp;text=true&amp;country=us" id="truste_0.7941776050720364"></script>
    <script async="async" type="text/javascript" crossorigin="" src="//consent.truste.com/get?name=notice.js"></script>
  </a>
</p>
        </div><!-- End .footer-right .col-md-6 -->
        <div class="footer-right col-xs-12 col-md-6 pull-left">
          <ul class="footer-nav">
  <li class="footer-nav__menu-item">
    <a href="http://adspecs.nba.com" target="_blank">Advertise on NBA.com</a>    </li>
  <li class="footer-nav__menu-item">
    <a href="http://leaguepasssupport.nba.com" target="_blank">NBA.com Help</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/help/fan_relations_faq.html" target="_blank">Fan Relations FAQ</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/careers/" target="_blank">NBA Career Opportunities</a>  </li>
<ul>
        </div><!-- End .footer-left .col-md-6 -->
      </div><!-- End .row -->
      <div class="row">
        <div class="col-md-12">
          <div class="turner-logo"></div>NBA.com is part of Turner Sports Digital, part of the Turner Sports & Entertainment Digital Network.        </div><!-- End col-md-6 -->
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-bottom -->
</footer> <!-- End .footer -->
  </div>
</div>
  </div>
  <div id="closure" style="visibility:hidden; position:absolute; bottom:0; right:0; max-height :1px; max-width:1px;"><script type="text/javascript">if (document.getElementById("user-login--2")) {document.getElementsByClassName("form-item-pass")[0].getElementsByClassName("description")[0].innerHTML = "Enter the password that accompanies your username.";}</script>

<!-- Google Tag Manager TRUE MEDIA (noscript) 12/28/16 -->

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KZT9NJ"

height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<!-- End Google Tag Manager (noscript) -->


<!-- Facebook Tracking Pixel for Umbel: 3/22/17-->
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=283939748729566&ev=PageView&noscript=1"
/></noscript>

<!-- end Facebook Tracking Pixel for Umbel -->



<!-- True Media 2018 "New Vendor Test" pixel: 9/25/18 -->
<script src="//action.dstillery.com/orbserv/nsjs?adv=cl1024338&ns=2955&nc=MTHP&ncv=50&dstOrderId=[OrderId]&dstOrderAmount=[OrderAmount]" type="text/javascript"></script>
<noscript><img width="1" height="1" src="//action.dstillery.com/orbserv/nspix?adv=cl1024338&ns=2955&nc=MTHP&ncv=50&dstOrderId=[OrderId]&dstOrderAmount=[OrderAmount]" /></noscript>
<!--/end True Media script -->


<!-- Facebook Lead Ad Tracking Pixel: 11/7/19 -->

<!-- Facebook Pixel Code -->

<script>

!function(f,b,e,v,n,t,s)

{if(f.fbq)return;n=f.fbq=function(){n.callMethod?

n.callMethod.apply(n,arguments):n.queue.push(arguments)};

if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';

n.queue=[];t=b.createElement(e);t.async=!0;

t.src=v;s=b.getElementsByTagName(e)[0];

s.parentNode.insertBefore(t,s)}(window,document,'script',

'https://connect.facebook.net/en_US/fbevents.js');


fbq('init', '437421927128704'); 

fbq('track', 'PageView');

</script>

<noscript>

<img height="1" width="1" 

src="https://www.facebook.com/tr?id=437421927128704&ev=PageView

&noscript=1"/>

</noscript>

<!-- End Facebook Pixel Code --></div><div id="parsely-root" style="display: none">
                  <span id="parsely-cfg" data-parsely-site="timberwolves.nba.com"></span>
                </div><script type="text/javascript" src="https://www.nba.com/modules/custom/nba/js/tos/tos.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/runtime.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/polyfills.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/vendor.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/main.js"></script>
<script type="text/javascript" src="https://z.cdn.turner.com/nba/tmpl_asset/static/nba-cms3-base/latest/js/pkgCustomLibs-min.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_ROY4zcHmM4k19meZDVZumyAgHlEizExYwYth1i_9mkw.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_KdQWIKINQBZyGu1LBsBAYG_as7pgvy5uNErmTAOuhbw.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_aiQf68XsPM6zndplRn7gli6laergl9IvwXahO765-90.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/js/js_gRa7DZJT8EWvd9F4TnC5RJpwv6HbCrxWZDlSUN-n5ig.js"></script>
<script type="text/javascript" src="https://www.nba.com/timberwolves/sites/timberwolves/files/sitewide_overrides/active/etowah_swo_93124/footer_sitewide_overrides.js?q2rqpz"></script>
  </body>
</html>