<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr"
  xmlns:fb="http://ogp.me/ns/fb#"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <script type="text/javascript" src="//cdn.optimizely.com/js/2702680368.js"></script>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="is_https" content="true" />
<meta name="timestamp" content="1590073327" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="shortcut icon" href="https://www.nba.com/pistons/sites/all/themes/etowah_radix/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo" />
<meta name="google-site-verification" content="9TSjz0smj43KYaGT23S4PiioxSwwuhw-yHT6YNTvjqw"/><meta property="fb:pages" content="71284685294"/><meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo"/><meta property="fb:app_id" content="146432205812426" />
<link rel="amphtml" href="https://www.nba.com/amp/pistons/news/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"The off-season ahead, already uncertain for Pistons, faces an additional layer of mystery","url":"https:\/\/www.nba.com\/pistons\/news\/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery","dateCreated":"2020-05-21T13:54:00Z","articleSection":"news","creator":["klanglois"],"keywords":["Rose, Derrick","Pistons"],"author":["klanglois"],"datePublished":"2020-05-21T13:54:00Z","image":"https:\/\/www.nba.com\/pistons\/sites\/pistons\/files\/rose_800_20119.jpg","publisher":{"@type":"Organization","name":"NBA.com\/pistons","logo":{"@type":"ImageObject","url":"https:\/\/www.nba.com\/.element\/img\/1.0\/teamsites\/logos\/teamlogos_500x500\/DET.png","width":180,"height":60}},"dateModified":"2020-05-21T13:56:52Z","mainEntityOfPage":"https:\/\/www.nba.com\/pistons\/news\/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery","thumbnailUrl":"https:\/\/www.nba.com\/pistons\/sites\/pistons\/files\/rose_800_20119.jpg"}</script>
<script type="text/javascript">var turner_metadata = {
        teamPageType        : "custom",
        turnerId            : "aa41822-1193725393-1389694715530-1",
        entity              : "nba:team:pistons",
        analyticsVersion    : "2.0",
        appName             : "app:nba - desktop",
        registrationState   : "not signed in",
        page                : "nba:team:pistons:features:The offseason ahead already uncertain for Pistons faces an additional layer of mystery",
        section             : "nba:team:pistons:features",
        subsection          :  "pistons:features",
        articleCategory     : "news",
        articleTitle        : "The offseason ahead already uncertain for Pistons faces an additional layer of mystery",
        articleAuthor       : "klanglois",
        articlePublishDate  : "05/21/2020",
        articleTags         : "Rose, Derrick, Pistons, Tom Gores, #Trending, True Blue Pistons",
        eventPageView       : "1",
        offsiteSource       : "Team Site"
      };</script>
<meta name="description" content="The world was a very different place in the first days of 2020. We now know the coronavirus was already on the radar of public health and intelligence officials, but it had yet to penetrate mainstream consciousness – or transform the world as we know it. The Pistons were in a different place then, too. The season had taken a hard wrong turn a few months before that when a wave" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.nba.com/pistons/news/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery" />
<link rel="shortlink" href="https://www.nba.com/pistons/node/35445" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="Detroit Pistons" />
<meta property="og:url" content="https://www.nba.com/pistons/news/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery" />
<meta property="og:title" content="The off-season ahead, already uncertain for Pistons, faces an additional layer of mystery | Detroit Pistons" />
<meta property="og:description" content="The world was a very different place in the first days of 2020. We now know the coronavirus was already on the radar of public health and intelligence officials, but it had yet to penetrate mainstream consciousness – or transform the world as we know it. The Pistons were in a different place then, too. The season had taken a hard wrong turn a few months before that when a wave of injuries washed over them, but as an organization they’d not yet made any hard calls on their future. But they knew that day was staring them down." />
<meta property="og:image" content="https://www.nba.com/pistons/sites/pistons/files/rose_800_20119.jpg?cw=700&amp;ch=500&amp;w=889&amp;h=500&amp;x=121&amp;y=0" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.nba.com/pistons/news/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery" />
<meta name="twitter:title" content="The off-season ahead, already uncertain for Pistons, faces an" />
<meta name="twitter:description" content="The world was a very different place in the first days of 2020. We now know the coronavirus was already on the radar of public health and intelligence officials, but it had yet to penetrate" />
<meta name="twitter:image" content="https://www.nba.com/pistons/sites/pistons/files/rose_800_20119.jpg?cw=700&amp;ch=500&amp;w=889&amp;h=500&amp;x=121&amp;y=0" />
  <title>The off-season ahead, already uncertain for Pistons, faces an additional layer of mystery | Detroit Pistons</title>
  <link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/css/css_63DdcQktJ6CmQDuj-MqgNhJHhnBqcqBDmOr_pdlEBho.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/css/css_4bSZWM1Qh9_Oc9hitkSo_UIam03Bn9DHh9v6FKNiUCQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/css/css_6klLCvmTSl9w4XMlHaw6MYpLQ8D5ls8B1E22Jqr3JVs.css" media="screen" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/css/css_XxyQp66Fe5-FD6GGfiv4yD0cNUWm5mLxfCAhAqTwnZo.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/css/css_0zLZNBnJeRb2-n2HGI0fvZEq9tQFOu1X96G1HuMbxl8.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/all/themes/etowah_radix/assets/stylesheets/ie8_fallback.css?qaopes" media="all" />
<![endif]-->

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/all/themes/etowah_radix/assets/stylesheets/ie7_fallback.css?qaopes" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/all/themes/etowah_radix/assets/stylesheets/bootstrap.css?qaopes" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/all/themes/etowah_radix/assets/stylesheets/screen.css?qaopes" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/css/css_T-TZfTydUwB664EEKJHDcuk7jy4tISCzGTq3m7vhy9Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/css/css_2TWKaEyEq8y-UqVKB0B3w_6ifd0zK1wciTULcpfJXBw.css" media="print" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?qaopes" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?qaopes" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?qaopes" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/all/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?qaopes" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/colorizer/etowah_radix-7893e128.css" media="all" />
<style type="text/css" media="(min-width: 640px)">
<!--/*--><![CDATA[/*><!--*/
.page{background-image:url(https://www.nba.com/pistons/sites/pistons/files/pistonscom_bgrnd.jpg)}

/*]]>*/-->
</style>
<style type="text/css" media="(-webkit-min-device-pixel-ratio: 2) and (min-width: 640px), (min-resolution: 192dpi) and (min-width: 640px)">
<!--/*--><![CDATA[/*><!--*/
.page{background-image:url(https://www.nba.com/pistons/sites/pistons/files/pistonscom_bgrnd.jpg);background-size :1900px auto}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/css/css_3QcOAF9ooQEaP_bKabcuKD3EiqNSwyKEzOFHdoymBHc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/pistons/sites/pistons/files/sitewide_overrides/active/etowah_swo_56620/style_sitewide_overrides.css?qaopes" media="all" />
    <script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_sOTmJnDhZ0YaYTQBr9FPewnH0WbS6pH--oA8_JDPY0w.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var jQuery1111 = jQuery.noConflict(); var jQuery111 = jQuery1111;
//--><!]]>
</script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_x1iuGxwJfnnJ-GMJTcWTIxc5ZuFXXYggcjhWM9dco0k.js"></script>
<script type="text/javascript" src="//www.nba.com/javascriptGlobalSettings.js.html"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_eAtNCuh9Vfx9qN14qMJAChJnBHm5P4auvYGH7pl0im8.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_Y9FAYoQEvUHlIziemnM2LVc94gXKH2LLeR6dyp1Zg-w.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_lIrYjw88ZYMAOjUr6Bw4pOWhZwMOgtLzjxtc8yN7yLc.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_zykj1GuJRnNxoDrLXuFv6n-3vBWcf_mN56NiBXbkjgk.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_RUl525ZJlhTXbT69JUWad71UhhrjIMfJDJcEGJL1ZuA.js"></script>
<script type="text/javascript" src="https://turnip.cdn.turner.com/top/core/1.3.6/default/top.sdk.min.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_KIHp4guPgf5Jfyw9DE0DVs21k83syR-kCTCLqnLmpyY.js"></script>
<script type="text/javascript" src="//agility.nba.com/turner/nba-prod/Bootstrap.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/sitewide_overrides/active/etowah_swo_56620/header_sitewide_overrides.js?qaopes"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_O-8YMkEHkTJ_L_8yhpg2uFQGunL4rJ_A62ML0Znf6o8.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]>
   <script>
      document.createElement('header');
      document.createElement('nav');
      document.createElement('section');
      document.createElement('article');
      document.createElement('aside');
      document.createElement('footer');
   </script>
   <link id="respond-proxy" rel="respond-proxy" href="http://i.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="http://z.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="https://s.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-redirect" rel="respond-redirect" href="https://www.nba.com/pistons/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.gif" />
   <script type="text/javascript" src="https://www.nba.com/pistons/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.min.js" />
<script type="text/javascript" src="https://www.nba.com/pistons/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/src/respond.min.js" />
<script type="text/javascript" src="https://www.nba.com/pistons/sites/all/themes/etowah_radix/assets/javascripts/vendor/selectivizr-min.js" />
  <![endif]-->

</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-35445 node-type-story region-content">
  <div id="skip-link">
    <a tabindex="1" href="#content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    
<header class="header" role="header">
  <nav class="global-nav-wrapper">
    <div class="container">
    <!--Top of the page navigation and NBA logo -->
      <div class="row">
        <div class="col-xs-12">
          <div class="utility-logo">
            <a tabindex="1" href = "http://www.nba.com"><span class="element-invisible">NBA</span></a>
          </div>
          <ul class="global-nav">
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/" class="teamNavGlobal global-nav__hidden-xs" title="Link to NBA Global">Global</a></li>
            <li class="global-nav__menu-item expanded has-dropdown">
              <a tabindex="1" href="javascript:void(0)" id="global-nav__menu-item__teams-link">Teams</a>
              <ul class="global-nav__menu-item__sub-menu" id="global-nav__menu-item__teams-link-dropdown">
                <li><a class="global-nav__menu-item__sub-menu__sub-item" href="http://www.nba.com/teams/" title="Link to NBA Teams">Teams</a></li>
                <li class="teamHDR">Team Sites</li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hawks/" title="Link to Atlanta Hawks Team Site">Atlanta</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/heat/" title="Link to Miami Heat Team Site">Miami</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/celtics/" title="Link to Boston Celtics Team Site">Boston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bucks/" title="Link to Milwaukee Bucks Team Site">Milwaukee</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nets/" title="Link to Brooklyn Nets Team Site">Brooklyn</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/timberwolves/" title="Link to Minnesota Timberwolves Team Site">Minnesota</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hornets/" title="Link to Charlotte Hornets Team Site">Charlotte</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pelicans/" title="Link to New Orleans Pelicans Team Site">New Orleans</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bulls/" title="Link to Chicago Bulls Team Site">Chicago</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/knicks/" title="Link to New York Knicks Team Site">New York</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/cavaliers/" title="Link to Cleveland Cavaliers Team Site">Cleveland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/thunder/" title="Link to Oklahoma City Thunder Team Site">Oklahoma City</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/mavericks/" title="Link to Dallas Mavericks Team Site">Dallas</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/magic/" title="Link to Orlando Magic Team Site">Orlando</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nuggets/" title="Link to Denver Nuggets Team Site">Denver</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/sixers/" title="Link to Philadelphia 76ers Team Site">Philadelphia</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pistons/" title="Link to Detroit Pistons Team Site">Detroit</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/suns/" title="Link to Phoenix Suns Team Site">Phoenix</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/warriors/" title="Link to Golden State Warriors Team Site">Golden State</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/blazers/" title="Link to Portland Blazers Team Site">Portland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/rockets/" title="Link to Houston Rockets Team Site">Houston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/kings/" title="Link to Sacramento Kings Team Site">Sacramento</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pacers/" title="Link to Indiana Pacers Team Site">Indiana</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/spurs/" title="Link to San Antonio Spurs Team Site">San Antonio</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/clippers/" title="Link to LA Clippers Team Site">LA Clippers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/raptors/" title="Link to Toronto Raptors Team Site">Toronto</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/lakers/" title="Link to LA Lakers Team Site">LA Lakers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/jazz/" title="Link to Utah Jazz Team Site">Utah</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/grizzlies/" title="Link to Memphis Grizzlies Team Site">Memphis</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/wizards/" title="Link to Washington Wizards Team Site">Washington</a></li>
              </ul>
            </li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://gleague.nba.com" title="Link to G League">G League</a></li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://www.wnba.com" title="Link to WNBA" class="teamNavWNBA">WNBA</a></li>
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/storelinkhandler.html" class="teamNavStore" title="Link to NBA Store">NBA Store</a></li>
            <li class="global-nav__menu-item"><a href="/pistons/leaguepass/pricing" class="teamLeaguePass" title="Link to NBA League Pass" tabindex="1">NBA League Pass</a></li>
          </ul>
        </div>
      </div>
    </div>
  </nav>
</header>

<main id="main" class="main">
  <div id="page" class="page">
          <header>
        <nav class="main-nav-wrapper">
          <div class="main-nav-wrapper-inner">
          <div class="container">
            <div class="row">
              <div class="col-md-12">
                <!-- Site Logo -->
                <div class="navbar-brand-wrapper">
                  <a tabindex="1" href="/pistons/" id="logo" class="navbar-brand" title="Home" rel="home">
                                          <img src="https://www.nba.com/pistons/sites/pistons/files/main-pistons-logo_113x94.png?" alt="Site Logo" title="Site Logo" />                                        <span class="element-invisible">Detroit Pistons</span>
                  </a>
                </div>
                <!-- Presented by Advertisement -->
                <div class="presented-by presented-by--header">
                    <div class="region region-promo-region">
    <div id="block-bean-presented-by-promo" class="block block-bean">

    
  <div class="content">
      <img class="block__img" src="/pistons/sites/pistons/files/craftedbyflagstarbank_139.png?w=139&amp;h=22" alt="Presented by promo" title="Presented by promo" />  </div>
</div>
  </div>
                </div>
                <!-- Main Navigation for Users -->
                <div class="mobile-menu-hamburger"><a href="javascript:;"></a></div>

                <ul id="main-menu" class="main-nav left"><li class="visible-xs mobile-menu-top">Menu</li><li class="first expanded main-nav__menu-item has-dropdown" title=""><a href="/pistons/tickets" title="">Tickets</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="http://content.palacenet.com/content/pistons/renew/2020/buynow.html" title="">2020-21 Membership</a></li><li class="leaf"><a href="/pistons/tickets/pistons-premium-tickets">Premium Seating</a></li><li class="leaf"><a href="/pistons/groups-page">Groups</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="http://www.pistons.com/rewards" title="">Pistons Rewards</a></li><li class="leaf" title=""><a href="https://oss.ticketmaster.com/aps/Pistons/EN/account/login" title="">My Pistons Account</a></li><li class="leaf" title=""><a href="https://am.ticketmaster.com/pistons/virtual-venue/RVBCRlVMMjA=#/" title="">LCA Virtual Venue</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.313presents.com/" title="">313 Presents</a></li><li class="leaf" title=""><a href="https://www.nba.com/pistons/tickets/hfhs-detroit-pistons-performance-center-private-event-spaces" title="">Event Rentals</a></li><li class="last leaf" title=""><a href="https://www.nba.com/pistons/tickets/ppc-packages-menu" title="">Plum Market Catering</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/pistons/roster/grid" title="">Team</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf"><a href="/pistons/roster">Roster</a></li><li class="leaf"><a href="/pistons/stats/team">Team Stats</a></li><li class="leaf"><a href="/pistons/stats">Player Stats</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/pistons/stats/leaders">Leaders</a></li><li class="leaf" title=""><a href="https://www.nba.com/standings" title="">Standings</a></li><li class="leaf" title=""><a href="https://www.nba.com/gamenotes/pistons.pdf" title="">Game Notes</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="/pistons/archive/transaction" title="">Transactions</a></li><li class="leaf" title=""><a href="https://www.nba.com/dleague/grandrapids/" title="">Grand Rapids Drive</a></li><li class="leaf"><a href="/pistons/news/Media_Guide.html">Media Guide</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/pistons/news/detroit-pistons-open-new-training-facility-and-corporate-headquarters-midtown">Henry Ford Detroit Pistons Performance Center</a></li><li class="last leaf"><a href="/pistons/history/ownership-tom-gores">Ownership - Tom Gores</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/pistons/schedule" title="">Schedule</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="/pistons/schedule" title="">Schedule &amp; Scores</a></li><li class="leaf" title=""><a href="https://www.nba.com/resources/static/team/v2/pistons/files/201920_print_schedule.pdf" title="">Print Schedule</a></li><li class="leaf"><a href="/pistons/detroit-pistons-basketball-fs-detroit-and-fs-plus">Fox Sports Detroit</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/pistons/multimedia/fox-sports-detroit/detroit-pistons">Fox Sports Go</a></li><li class="leaf"><a href="/pistons/radio.html">Radio Affiliates</a></li><li class="last leaf" title=""><a href="https://on.nba.com/2j5zClY" title="">NBA League Pass</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/pistons/video" title="">Video</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-2 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="/pistons/video" title="">Video</a></li><li class="leaf" title=""><a href="/pistons/photos" title="">Photo Galleries</a></li><li class="leaf" title=""><a href="https://www.youtube.com/user/DetPistonsOfficial" title="">YouTube</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="https://instagram.com/detroitpistons" title="">Instagram</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/pistons/" title="">Fan Zone</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/pistons/archive/True Blue Pistons" title="">True Blue Pistons</a></li><li class="leaf" title=""><a href="/pistons/archive/mailbag" title="">Pistons Mailbag</a></li><li class="leaf"><a href="/pistons/pistons-fan-clubs">Fan Clubs</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/pistons/mobile">Mobile App</a></li><li class="leaf"><a href="/pistons/hooper">Hooper</a></li><li class="leaf" title=""><a href="http://pistons.infopop.cc/eve/forums" title="">Message Boards</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="" target="_blank"><a href="/pistons/detroit-pistons-license-plate" title="" target="_blank">Fundraising License Plates</a></li><li class="leaf" title=""><a href="http://www.pistonsgt.com" title="">Pistons Gaming Team</a></li><li class="leaf"><a href="/pistons/wired-pistons-podcast">Wired Podcast</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf"><a href="/pistons/pistons-pavers-program">Pavers Program</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/pistons/" title="">Game Night</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/pistons/hooper" title="">Hooper</a></li><li class="leaf"><a href="/pistons/dance/pistons-entertainment">Entertainment Team</a></li><li class="leaf"><a href="/pistons/tickets/giftcardshtml">Gift Cards</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/pistons/features/what-know-your-visit-little-caesars-arena">Little Caesars Arena</a></li><li class="leaf"><a href="/pistons/celebrate-your-birthday-pistons">Birthday Packages</a></li><li class="leaf" title=""><a href="https://www.parkwhiz.com/little-caesars-arena-parking/?event_name=Pistons&amp;seller_id=977&amp;pwa=pa-126&amp;utm_campaign=Platform_Pistons_EmailParking&amp;utm_source=126&amp;utm_medium=Olympia&amp;utm_content=email&amp;utm_term=link" title="">Parking</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf"><a href="/pistons/pistons-bar-network">Pistons Bar Network</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown"><a href="/pistons/community">Community</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="http://www.pistons.com/basketballforall" title="">Basketball For All</a></li><li class="leaf" title=""><a href="https://pages.palacenet.com/ComeTogetherGameChangerNomination1819.html" title="">Game Changers</a></li><li class="leaf"><a href="/pistons/community/community-tickets">Community Tickets</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/pistons/community/community-requests" title="">Donation Requests</a></li><li class="leaf"><a href="/pistons/community/foundation">Detroit Pistons Foundation</a></li><li class="leaf" title=""><a href="http://www.flintnow.org" title="">FlintNOW Foundation</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://pages.palacenet.com/CSRPistonsintheCommunityInt.html" title="">Pistons in the Community Nomination</a></li><li class="last leaf"><a href="/pistons/community/champions">Community Champions</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/pistons/community/junior-pistons" title="">Jr. Pistons</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-1 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/pistons/fp_newsletter_signup.html" title="">Fan Club</a></li><li class="leaf" title=""><a href="https://www.nba.com/pistons/groups" title="">Group Tickets</a></li><li class="last leaf" title=""><a href="http://pistonsacademy.com/" title="">Pistons Academy</a></li></ul></li></ul></li><li class="last expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.pistonslockerroomstore.com/" title="">Store</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://pistonslockerroomstore.com/about-us" title="">Arena Store</a></li><li class="leaf" title=""><a href="https://www.nba.com/pistons/tickets/gift_cards.html" title="">Gift Cards</a></li><li class="leaf" title=""><a href="https://pistonslockerroomstore.com/womens/" title="">Womens</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://pistonslockerroomstore.com/mens.html" title="">Mens</a></li><li class="leaf" title=""><a href="https://pistonslockerroomstore.com/kids.html" title="">Kids</a></li><li class="leaf" title=""><a href="https://pistonslockerroomstore.com/hats.html" title="">Hats</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://pistonslockerroomstore.com/nike/" title="">Nike</a></li><li class="leaf" title=""><a href="https://pistonslockerroomstore.com/novelties/" title="">Novelties</a></li><li class="last leaf" title=""><a href="https://pistonslockerroomstore.com/giftcertificates.php" title="">Gift Certificates</a></li></ul></li></ul></li></ul>                                <div class="search-box">
                  <p><span class="search-box__pre-text">Search</span> <a tabindex="-1" class="search-box__icon" href="#"><span tabindex="-1" class="element-invisible">Toggle Search Input</span></a>
                  </p>
                  <div class="search-box__form-wrapper">
                    <form>
                      <label for="search-box__input-box" class="element-invisible">Search Box</label>
                      <input tabindex="1" id="search-box__input-box" class="search-box__input-box" alt="search box" type="text" placeholder="Search" />
                      <input tabindex="1" type="submit" class="submit search-box__submit-btn" value="Search" />
                      <div class="search-box__submit-btn-icon"></div>
                    </form>
                  </div>
                </div>
                <!-- Social Bar -->
                <div class="social-bar-wrapper">
                  <!-- <a class="social-bar__mobile-icon visible-xs" href="#"><span class="element-invisible">Social Menu</span></a> -->
                    <div class="region region-header-social">
    <div id="block-etowah-marketing-social-links-header" class="block block-etowah-marketing">

    
  <div class="content">
    <ul class="social-bar first social-bar--header"><li class="social-bar__item "><a href="https://www.facebook.com/detroitpistons" target="_blank" class="" alt="Facebook social link" title="Facebook social link" style="background-color:#3b5998"><i class="fab fa-facebook"></i></a></li><li class="social-bar__item "><a href="https://twitter.com/DetroitPistons" target="_blank" class="" alt="Twitter social link" title="Twitter social link" style="background-color:#1da1f2"><i class="fab fa-twitter"></i></a></li><li class="social-bar__item "><a href="https://www.instagram.com/detroitpistons/" target="_blank" class="" alt="Instagram social link" title="Instagram social link" style="background-color:#c8102e"><i class="fab fa-instagram"></i></a></li></ul>  </div>
</div>
  </div>
                </div>
              </div><!-- End .col-lg-12 -->
            </div><!-- End .row -->
          </div><!-- End .container -->
        </div><!-- End .main-nav-wrapper-inner -->
        </nav><!-- End .main-nav-wrapper -->
      </header>
    
    <div class="container">
      
    </div>
          <div class="page-header-ad">
        <div class="container">
            <div class="region region-header">
    <div id="block-panels-mini-mini-panel-top-banner-ad" class="block block-panels-mini">

    
  <div class="content">
    <div class="panel-display panel-1col clearfix" id="mini-panel-mini_panel_top_banner_ad">
  <div class="panel-panel panel-col">
    <div><div class="panel-pane pane-fieldable-panels-pane pane-uuid-4cc5beb7-d95e-410b-8848-2f63eb0a96bd pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-4cc5beb7-d95e-410b-8848-2f63eb0a96bd" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c39c3-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c39c3-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
</div>
  </div>
</div>
  </div>
</div>
  </div>
        </div>
      </div>
    
     <div tabindex="0" id="content" class="">

    <div id="page-header">
                      </div>
           <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    
<div class="panel-display moscone-flipped clearfix " >

  <div class="moscone-container moscone-header clearfix panel-panel">
    <div id='moscone-header-inner' class="moscone-container-inner moscone-header-inner panel-panel-inner">
      <div class="panel-pane pane-fieldable-panels-pane pane-uuid-89e991a2-ace0-44ec-8d10-fbce2dd3f8da pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		  <div class="visible-lg visible-md"><img class="img-responsive center-block" src="https://i.cdn.turner.com/drp/nba/pistons/sites/default/files/trending-header_1150x75.jpg" /></div>
<div class="visible-sm visible-xs"><img class="img-responsive center-block" src="https://i.cdn.turner.com/drp/nba/pistons/sites/default/files/trending-header_750x75.jpg" /></div>
	</div>
</div>

  
</div>
    </div>
  </div>

  <div class="moscone-flipped-container moscone-flipped-column-content clearfix">
    <div class="moscone-flipped-column-content-region moscone-flipped-content panel-panel">
      <div id='moscone-flipped-content-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-content-inner panel-panel-inner">
        <div class="panel-pane pane-etowah-story-pane-photo" >
  
      
  
  <div class="pane-content">
      <div>
    <h1>The off-season ahead, already uncertain for Pistons, faces an additional layer of mystery</h1>
          <div class="field field-name-field-subheadline field-type-text field-label-hidden">
              </div>
      </div>
  
  <img src="/pistons/sites/pistons/files/rose_800_20119.jpg?w=756&amp;h=425" alt="Derrick Rose" />      <div class="story-photo-caption">
      Derrick Rose is among the handful of players the Pistons have under contract for next season, a season that faces many challenging questions amid an uncertain time.    </div> 
        <div class="story-photo-credit">
      NBAE/Getty Images    </div>
  

  </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-author" >
  
      
  
  <div class="pane-content">
     
<div class="author-block">
  <img class="author-block__icon" src="/pistons/sites/pistons/files/pictures/klanglois_300.jpg?w=100&amp;h=100" alt="" /> 
   
  <div class="author-block__author">by Keith Langlois</div>
      <div class="author-block__author-title">Web Editor</div>
    <div class="author-block__post-date">Posted: May 21, 2020</div>
    <div class="social-bar--author-block__wrapper"><div class='social-bar-wrapper social-bar--author-block' id='social-bar-wrapper-354455ec697eeb6eb0'><div class="item-list"><ul class="social-bar "><li class="social-bar__item first"><a href="https://facebook.com/sharer.php?u=https://www.nba.com/pistons/news/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery&amp;t=The+off-season+ahead%2C+already+uncertain+for+Pistons%2C+faces+an+additional+layer+of+mystery" class="social-facebook-icon facebook-color social-facebook-popup" title="Share on Facebook" target="_blank"><span class='element-invisible'>Facebook</span></a></li>
<li class="social-bar__item last"><a href="https://twitter.com/intent/tweet?url=https://www.nba.com/pistons/news/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery&amp;text=The+off-season+ahead%2C+already+uncertain+for+Pistons%2C+faces+an+additional+layer+of+mystery&amp;via=DetroitPistons" class="social-twitter-icon twitter-color social-twitter-popup" title="Share on Twitter" target="_blank"><span class='element-invisible'>Twitter</span></a></li>
</ul></div></div></div>
  </div><!-- End author-block -->  </div>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="pane-content">
    <div class="field field-name-body field-type-text-with-summary field-label-hidden">
  		  <p>
The world was a very different place in the first days of 2020. We now know the coronavirus was already on the radar of public health and intelligence officials, but it had yet to penetrate mainstream consciousness – or transform the world as we know it.
</p>
<p>
The Pistons were in a different place then, too. The season had taken a hard wrong turn a few months before that when a wave of injuries washed over them, but as an organization they’d not yet made any hard calls on their future.
</p>
<p>
But they knew that day was staring them down.
</p>
<p>
“I think we’re going to have to re-evaluate in the next couple of weeks,” Pistons owner <a href="https://www.nba.com/pistons/history/ownership-tom-gores" alt="Tom Gores">Tom Gores</a> said on Jan. 2 at Staples Center when the Pistons played the Clippers. “We have to, as an organization, take a look at things – what makes sense and what doesn’t and evaluate the injuries and how that’s impacted us. I think we have to evaluate. When you’re not winning, you have to evaluate.”
</p>
<p>
That was a little more than a month ahead of the trade deadline, at which time the Pistons beat the clock by less than 30 minutes before dealing Andre Drummond to Cleveland for a future second-round pick. That pick wasn’t the carrot for the Pistons so much as the opportunity to rebuild enabled by clearing Drummond’s 2020-21 salary of nearly $29 million.
</p>
<p>
But that was before the COVID-19 pandemic shut down the season another month later, throwing into disarray the planning for the future that the Pistons and their peers around the NBA had begun.
</p>
<p>
The salary cap for 2020-21 was projected to be $115 million but no one is certain what it might ultimately be set at. If the NBA can resume the 2019-20 season, it is most likely to be without fans. In any case, a significant amount of revenue that informed the $115 million projection figures to be missing. If there is a negotiated adjustment to the cap, then all the usual unknowns of a typical NBA free agency season will be a degree of magnitude greater.
</p>
<p>
The Pistons were projected to have somewhere around $35 million in cap space, more than all but New York ($48 million) and Atlanta ($38 million). Only five other teams were expected to have cap space above the anticipated mid-level exception amount of $9.7 million, so eight of the league’s 30 teams – 27 percent – would go into free agency with a decided advantage.
</p>
<p>
Now what?
</p>
<p>
If the NBA and its Players Association negotiate a new deal within the collective bargaining agreement to cover the seasons made aberrant by the pandemic, then what are the ripple effects for the Pistons?
</p>
<p>
If the cap is lowered, are salaries commensurately lowered so that the Pistons are still one of the few teams with enough cap room to sign someone to a maximum contract – and would the caps on maximum contracts be similarly affected? If the cap is lowered without a commensurate adjustment to contracts in place, then fewer teams – perhaps no teams – would have tools beyond cap exceptions to offer in free agency.
</p>
<p>
The Pistons resisted the course of bottoming out in an attempt to build a powerhouse contender more quickly – <a href="https://www.nba.com/pistons/features/rebuilding-means-uncertain-path-pistons-made-right-call-altering-course" alt="blog">a course with a spotty track record of success</a> – at various low points over the past decade. The self-evaluation that took place between their January visit to Los Angeles and the trade deadline sent them down another path. Now the coronavirus has strewn that path with obstacles whose challenges remain unfathomable.
</p>
<p>
To be sure, the analytics departments for all 30 teams will go into overdrive studying the ramifications of whatever the NBA and players decide upon if the pandemic means that it won’t be business as usual in the 2020-21 season. The Pistons are as committed to analytics as any organization under Gores’ stewardship – something he brought with him from his business empire, Platinum Equity, built on a devotion to analytics to spot business inefficiencies – and he’s armed them amply in that area. It will serve them well in perhaps the most uncertain days the NBA has ever faced.
</p>
</p>
	</div>
  </div>

  
  </div>
<div class="panel-pane pane-node-links link-wrapper" >
  
      
  
  <div class="pane-content">
      </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-tags" >
  
      
  
  <div class="pane-content">
    <div class="tag__title">Tags</div><div class="tag__link-wrapper"><a href="/pistons/archive/Rose%2C%20Derrick" class="tag__link" aria-label="Link to content tagged with Rose, Derrick">Rose, Derrick</a>, <a href="/pistons/archive/Pistons" class="tag__link" aria-label="Link to content tagged with Pistons">Pistons</a>, <a href="/pistons/archive/Tom%20Gores" class="tag__link" aria-label="Link to content tagged with Tom Gores">Tom Gores</a>, <a href="/pistons/archive/%23Trending" class="tag__link" aria-label="Link to content tagged with #Trending">#Trending</a>, <a href="/pistons/archive/True%20Blue%20Pistons" class="tag__link" aria-label="Link to content tagged with True Blue Pistons">True Blue Pistons</a></div>  </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-comment" >
  
      
  
  <div class="pane-content">
    <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) {return;}
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));</script>
<div class="fb-comments" data-href="https://www.nba.com/pistons/news/season-ahead-already-uncertain-pistons-faces-additional-layer-mystery" data-num-posts="15" data-width="620" data-colorscheme="light"></div>  </div>

  
  </div>
      </div>
    </div>
    <div class="moscone-flipped-column-content-region moscone-flipped-sidebar panel-panel">
      <div id='moscone-flipped-sidebar-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-sidebar-inner panel-panel-inner">
        <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60ce-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60ce-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-etowah-story-pane-rel-stories" >
  
        <h4 class="pane-title" tabindex="0">Related Content</h4>
    
  
  <div class="pane-content">
      <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Rose, Derrick</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/pistons/chatmailbox/pistons-mailbag-may-13-2020"><img class="content-image" src="/pistons/sites/pistons/files/mailbag_800_200513.jpg?cw=210&amp;ch=140&amp;w=249&amp;h=140&amp;x=20&amp;y=0" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/pistons/chatmailbox/pistons-mailbag-may-13-2020" class="node_title related-content__link related-content__link--title">Pistons Mailbag - May 13, 2020</a></div>
                    <div class="post__date">May 13, 2020</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/pistons/features/pistons-ready-adapt-potentially-volatile-season-whenever-it-arrives"><img class="content-image" src="/pistons/sites/pistons/files/rose_800_200423.jpg?cw=210&amp;ch=140&amp;w=249&amp;h=140&amp;x=20&amp;y=0" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/pistons/features/pistons-ready-adapt-potentially-volatile-season-whenever-it-arrives" class="node_title related-content__link related-content__link--title">Pistons ready to adapt to a potentially volatile off-season, whenever it arrives</a></div>
                    <div class="post__date">April 23, 2020</div>
        </li>
          </ul>
  </div>
  <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Pistons</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--videos" href="https://www.nba.com/pistons/video/teams/pistons/2020/05/20/3232682/1590007491220-blake-griffin-pistons-hits-1920x1080-3232682"><img class="content-image" width="210" height="140" alt="Pistons Hits: Blake Griffin" src="https://www.nba.com/images/vod01/teams/pistons/2020/05/20/3232682/1590007491220-Blake-Griffin-Pistons-Hits-1920X1080-3232682-9.1920x1080.jpg"/></a>                    <div class="post__title"><a href="/pistons/video/teams/pistons/2020/05/20/3232682/1590007491220-blake-griffin-pistons-hits-1920x1080-3232682" class="node_title related-content__link related-content__link--title">Pistons Hits: Blake Griffin</a></div>
                    <div class="post__date">May 20, 2020</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/pistons/chatmailbox/pistons-mailbag-may-20-2020"><img class="content-image" src="/pistons/sites/pistons/files/billups_800_200520.jpg?cw=210&amp;ch=140&amp;w=249&amp;h=140&amp;x=20&amp;y=0" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/pistons/chatmailbox/pistons-mailbag-may-20-2020" class="node_title related-content__link related-content__link--title">Pistons Mailbag - May 20, 2020</a></div>
                    <div class="post__date">May 20, 2020</div>
        </li>
          </ul>
  </div>
  <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Tom Gores</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/pistons/features/rebuilding-means-uncertain-path-pistons-made-right-call-altering-course"><img class="content-image" src="/pistons/sites/pistons/files/griffin_800_200511.jpg?cw=210&amp;ch=140&amp;w=249&amp;h=140&amp;x=20&amp;y=0" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/pistons/features/rebuilding-means-uncertain-path-pistons-made-right-call-altering-course" class="node_title related-content__link related-content__link--title">Rebuilding means an uncertain path, but Pistons made the right call in altering course</a></div>
                    <div class="post__date">May 12, 2020</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/pistons/news/detroit-pistons-and-mcdonalds-team-launch-special-motor-city-frontline-meals-program"><img class="content-image" src="/pistons/sites/pistons/files/motor-city-frontline-meals_800x450_v2.jpg?cw=210&amp;ch=140&amp;w=249&amp;h=140&amp;x=12&amp;y=0" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/pistons/news/detroit-pistons-and-mcdonalds-team-launch-special-motor-city-frontline-meals-program" class="node_title related-content__link related-content__link--title">Detroit Pistons and McDonald&#039;s Team Up to Launch Special &quot;Motor City Frontline Meals&quot; Program</a></div>
                    <div class="post__date">May 08, 2020</div>
        </li>
          </ul>
  </div>
  </div>

  
  </div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60d1-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60d1-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
      </div>
    </div>
  </div>

  <div class="moscone-container moscone-footer clearfix panel-panel">
    <div id='moscone-footer-inner' class="moscone-container-inner moscone-footer-inner panel-panel-inner">
      <div class="panel-pane pane-upcoming-games-pane" >
  
      
  
  <div class="pane-content">
    <app-tickets-upcoming-games upcoming_bg="https://www.nba.com/pistons/sites/pistons/files/ticket_widget_bg.jpg" upcoming_button_color="#dc1e35" upcoming_button_text_color="#ffffff" upcoming_button_text="Tickets" upcoming_secondary="0" upcoming_secondary_text="" upcoming_secondary_link="" ></app-tickets-upcoming-games>   </div>

  
  </div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60cf-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60cf-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
    </div>
  </div>

</div><!-- /.moscone-flipped -->
  </div>
</div>
<div class="etowah_ticket_share mfp-hide">
  <app-ticket-share></app-ticket-share>
</div>
  <div class="nextup_wrapper nextup_original">
    <div class="nextup_contain" tabindex="0" aria-label="Next Up">
      <div class="nextup_header">
        <div class="nextup_image">
          <img src="" class="thumb" />
        </div>
        <div class="nextup_details">
          <div class="nextup_timer">NEXT UP: <span></span></div>
          <div class="nextup_title"></div>
          <div class="nextup_desc"></div>
        </div>
      </div>
      <div class="nextup_playback">
        <button class="nextup_replay" title="Replay Video">Replay</button>
        <button class="nextup_playnext" title="Play Next Video">Play Next</button>
      </div>
      <div class="nextup_social">
        <hr />
        <ul>
          <li id="nextup_fb">
            <a href="#" target="_blank" title="Share to Facebook">
              <img src="https://cdn.nba.net/assets/video/icons/social_fb.png" alt="Facebook" />
            </a>
          </li>
          <li id="nextup_tw">
            <a href="#" target="_blank" title="Share to Twitter">
              <img src="https://cdn.nba.net/assets/video/icons/social_tw.png" alt="Twitter" />
            </a>
          </li>
          <li id="nextup_link">
            <a href="#" title="Copy share link">
              <img src="https://cdn.nba.net/assets/video/icons/social_lk.png" alt="Share Link" />
            </a>
            <div id="nextup_link_message">Link copied to clipboard</div>
          </li>
        </ul>
      </div>
    </div>
  </div>  </div>
    </div>
  </div><!-- End .page -->

</main>

  <div class="region region-footer">
    <div id="block-panels-mini-mini-panel-footer" class="block block-panels-mini">

    
  <div class="content">
    
<footer id="footer" role="footer" class="footer panel-display etowah-footer clearfix etowah-footer" id="mini-panel-mini_panel_footer">
  <div class="footer-top">
    <div class="container">
      <div class="row">
        <div class="custom-page-ad_bottom">
          <div class="panel-pane pane-fieldable-panels-pane pane-uuid-5ffe6ffc-6116-4158-bd0f-62b082d7e833 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-5ffe6ffc-6116-4158-bd0f-62b082d7e833" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-291c456b-b19a-423d-a0dc-713c528a1399 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-291c456b-b19a-423d-a0dc-713c528a1399" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
        </div>
      </div>
      <div class="row">
        <ul class="col-xs-12 footer-top-sponsors">
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-menu-tree pane-menu-footer-tickets" >
  
      
  
  <div class="pane-content">
    <div class="menu-block-wrapper menu-block-ctools-menu-footer-tickets-1 menu-name-menu-footer-tickets parent-mlid-menu-footer-tickets:0 menu-level-1">
  <ul class="menu nav nav-tabs nav-stacked"><li class="first leaf menu-mlid-1873"><a href="http://content.palacenet.com/content/pistons/renew/2020/buynow.html" title="">2020-21 Membership</a></li>
<li class="leaf menu-mlid-5737"><a href="https://www.nba.com/pistons/groups-page" title="">Group Tickets</a></li>
<li class="leaf menu-mlid-9010"><a href="https://www.nba.com/pistons/tickets/pistons-premium-tickets" title="">Premium Seating</a></li>
<li class="leaf menu-mlid-1871"><a href="https://www.ticketexchangebyticketmaster.com/nba/resaleorder/detroit-pistons-tickets/event/239?brand=pistons&amp;extcmp=gw500717&amp;wt.mc_id=NBA_TEAM_DET_UNIV_FOOTER&amp;utm_source=NBA.com&amp;utm_medium=client&amp;utm_campaign=NBA_TEAM_DET&amp;utm_content=UNIV_FOOTER" title="">Sell Tickets</a></li>
<li class="leaf menu-mlid-1879"><a href="http://pistons.io-media.com/" title="">LCA Virtual Venue</a></li>
<li class="last leaf menu-mlid-1881"><a href="https://oss.ticketmaster.com/aps/Pistons/EN/account/login" title="">My Pistons Account</a></li>
</ul></div>
  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-menu-tree pane-menu-footer-team" >
  
      
  
  <div class="pane-content">
    <div class="menu-block-wrapper menu-block-ctools-menu-footer-team-1 menu-name-menu-footer-team parent-mlid-menu-footer-team:0 menu-level-1">
  <ul class="menu nav nav-tabs nav-stacked"><li class="first leaf menu-mlid-1911"><a href="/pistons/roster" title="">Roster</a></li>
<li class="leaf menu-mlid-1889"><a href="/pistons/stats/team" title="">Team Stats</a></li>
<li class="leaf menu-mlid-1891"><a href="/pistons/stats" title="">Player Stats</a></li>
<li class="last leaf menu-mlid-1895"><a href="https://grandrapids.dleague.nba.com/" title="">Grand Rapids Drive</a></li>
</ul></div>
  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-menu-tree pane-menu-the-palace" >
  
      
  
  <div class="pane-content">
    <div class="menu-block-wrapper menu-block-ctools-menu-the-palace-1 menu-name-menu-the-palace parent-mlid-menu-the-palace:0 menu-level-1">
  <ul class="menu nav nav-tabs nav-stacked"><li class="first leaf menu-mlid-2025"><a href="/pistons/contact/contactdetroitpistonshtml" title="">Contact Us</a></li>
<li class="leaf menu-mlid-2031"><a href="https://www.teamworkonline.com/basketball-jobs/palacenet/detroit-pistons-jobs- " title="">Employment</a></li>
<li class="leaf menu-mlid-9014"><a href="/pistons/nba-fan-code-conduct" title="">Code of Conduct</a></li>
<li class="last leaf menu-mlid-2023"><a href="/pistons/features/what-know-your-visit-little-caesars-arena" title="">Venue Info</a></li>
</ul></div>
  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-menu-tree pane-menu-video-photos" >
  
      
  
  <div class="pane-content">
    <div class="menu-block-wrapper menu-block-ctools-menu-video-photos-1 menu-name-menu-video-photos parent-mlid-menu-video-photos:0 menu-level-1">
  <ul class="menu nav nav-tabs nav-stacked"><li class="first leaf menu-mlid-2043"><a href="https://www.instagram.com/detroitpistons/" title="">Instagram</a></li>
<li class="leaf menu-mlid-2041"><a href="/pistons/photos" title="">Photo Galleries</a></li>
<li class="leaf menu-mlid-2039"><a href="/pistons/video" title="">Videos</a></li>
<li class="last leaf menu-mlid-2047"><a href="https://www.youtube.com/DetPistonsOfficial" title="">YouTube</a></li>
</ul></div>
  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-pistons-fan-zone" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://www.facebook.com/detroitpistons" title="">Facebook</a></li>
<li class="leaf"><a href="/pistons/mobile" title="">Mobile App</a></li>
<li class="leaf"><a href="https://www.snapchat.com/add/nbapistons" title="">Snapchat</a></li>
<li class="last leaf"><a href="https://www.twitter.com/detroitpistons" title="">Twitter</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-game-entertainment" >
  
      
  
  <div class="pane-content">
      </div>

  
  </div>
          </li>
        </ul>
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-top -->

  <div class="footer-bottom">
    <div class="container">
      <div class="row">
        <div class="footer-left col-xs-12 col-md-6">
          <p class="copyrights">
  Copyright © 2020 NBA Media Ventures, LLC. All rights reserved.
  No portion of NBA.com may be duplicated, redistributed or manipulated in any form.
  This site is operated jointly by NBA and WarnerMedia. To opt out of the sale of your personal information as permitted by the California Consumer 
  Privacy Act, please use the links below to visit each company’s privacy center. If you make a request through the WarnerMedia Privacy Center, 
  it will apply to data controlled jointly by the NBA and WarnerMedia as well as other data controlled by WarnerMedia. If you make a request through 
  the NBA Privacy Center, it will apply to data controlled independently by the NBA.
  <a href="https://www.nba.com/news/privacy_policy.html#California_Privacy_Rights">NBA Privacy Center</a>  |
  <a href="https://www.nba.com/privacycenter">WarnerMedia Privacy Center</a>  |
  <a href="https://www.nba.com/privacycenter">Do Not Sell My Personal Information</a>  |
  <a href="http://www.nba.com/news/termsofuse">Terms of Use</a>  |
  <a href="http://www.nba.com/closed_captioning">Accessibility and Closed Caption</a>  |
  <a id="nba_cnsnt_trst" class="nbaAdChoices" consent="null">
    <script type="text/javascript" src="//consent.truste.com/notice?domain=turner.com&amp;c=nba_cnsnt_trst&amp;text=true&amp;country=us" id="truste_0.7941776050720364"></script>
    <script async="async" type="text/javascript" crossorigin="" src="//consent.truste.com/get?name=notice.js"></script>
  </a>
</p>
        </div><!-- End .footer-right .col-md-6 -->
        <div class="footer-right col-xs-12 col-md-6 pull-left">
          <ul class="footer-nav">
  <li class="footer-nav__menu-item">
    <a href="http://adspecs.nba.com" target="_blank">Advertise on NBA.com</a>    </li>
  <li class="footer-nav__menu-item">
    <a href="http://leaguepasssupport.nba.com" target="_blank">NBA.com Help</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/help/fan_relations_faq.html" target="_blank">Fan Relations FAQ</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/careers/" target="_blank">NBA Career Opportunities</a>  </li>
<ul>
        </div><!-- End .footer-left .col-md-6 -->
      </div><!-- End .row -->
      <div class="row">
        <div class="col-md-12">
          <div class="turner-logo"></div>NBA.com is part of Turner Sports Digital, part of the Turner Sports & Entertainment Digital Network.        </div><!-- End col-md-6 -->
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-bottom -->
</footer> <!-- End .footer -->
  </div>
</div>
  </div>
  <div id="closure" style="visibility:hidden; position:absolute; bottom:0; right:0; max-height :1px; max-width:1px;"><script type="text/javascript">if (document.getElementById("user-login--2")) {document.getElementsByClassName("form-item-pass")[0].getElementsByClassName("description")[0].innerHTML = "Enter the password that accompanies your username.";}</script></div><div id="parsely-root" style="display: none">
                  <span id="parsely-cfg" data-parsely-site="pistons.nba.com"></span>
                </div><script type="text/javascript" src="https://www.nba.com/modules/custom/nba/js/tos/tos.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/runtime.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/polyfills.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/vendor.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/main.js"></script>
<script type="text/javascript" src="https://z.cdn.turner.com/nba/tmpl_asset/static/nba-cms3-base/latest/js/pkgCustomLibs-min.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_ROY4zcHmM4k19meZDVZumyAgHlEizExYwYth1i_9mkw.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_KdQWIKINQBZyGu1LBsBAYG_as7pgvy5uNErmTAOuhbw.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_aiQf68XsPM6zndplRn7gli6laergl9IvwXahO765-90.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/js/js_gRa7DZJT8EWvd9F4TnC5RJpwv6HbCrxWZDlSUN-n5ig.js"></script>
<script type="text/javascript" src="https://www.nba.com/pistons/sites/pistons/files/sitewide_overrides/active/etowah_swo_56620/footer_sitewide_overrides.js?qaopes"></script>
  </body>
</html>