<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xml:lang="en" lang="en" version="XHTML+RDFa 1.0" dir="ltr"
  xmlns:fb="http://ogp.me/ns/fb#"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <script type="text/javascript" src="//cdn.optimizely.com/js/2727400142.js"></script>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="google-site-verification" content="9HHWIRDhKScG8XrLbmN9OD6e-TYklksT8u-dPkA0g80"/><meta property="fb:pages" content="98534743609"/><meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo"/><script type="text/javascript" async="1" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="d0494fd0-8921-497a-8323-e3d29775ce1b" />
</script><link rel="amphtml" href="https://www.nba.com/amp/nuggets/news/robinson-earl-20210715" />
<link rel="shortcut icon" href="https://www.nba.com/nuggets/sites/nuggets/files/dn-pickaxe-favicon_0.ico" type="image/vnd.microsoft.icon" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="timestamp" content="1626537865" />
<meta name="is_https" content="true" />
<meta name="google-site-verification" content="RiF1RlTwjSydydQQ-uEASruEdLceNzOuOKv0gyrbJmo" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"NBA Draft 2021 Profile: Can Jeremiah Robinson-Earl add to Nuggets\u2019 frontcourt depth?","url":"https:\/\/www.nba.com\/nuggets\/news\/robinson-earl-20210715","dateCreated":"2021-07-15T19:47:55Z","articleSection":"none","creator":["alabidou"],"keywords":["Nuggets"],"author":["alabidou"],"datePublished":"2021-07-15T19:47:55Z","image":"https:\/\/www.nba.com\/nuggets\/sites\/nuggets\/files\/jeromeweb.jpg","publisher":{"@type":"Organization","name":"NBA.com\/nuggets","logo":{"@type":"ImageObject","url":"https:\/\/www.nba.com\/.element\/img\/1.0\/teamsites\/logos\/teamlogos_500x500\/DEN.png","width":180,"height":60}},"dateModified":"2021-07-15T19:47:55Z","mainEntityOfPage":"https:\/\/www.nba.com\/nuggets\/news\/robinson-earl-20210715","thumbnailUrl":"https:\/\/www.nba.com\/nuggets\/sites\/nuggets\/files\/jeromeweb.jpg"}</script>
<script type="text/javascript">var turner_metadata = {
        teamPageType        : "custom",
        turnerId            : "aa41822-1193725393-1389694715530-1",
        entity              : "nba:team:nuggets",
        analyticsVersion    : "2.0",
        appName             : "app:nba - desktop",
        registrationState   : "not signed in",
        page                : "nba:team:nuggets:features:NBA Draft 2021 Profile Can Jeremiah RobinsonEarl add to Nuggets frontcourt depth",
        section             : "nba:team:nuggets:features",
        subsection          :  "nuggets:features",
        articleCategory     : "none",
        articleTitle        : "NBA Draft 2021 Profile Can Jeremiah RobinsonEarl add to Nuggets frontcourt depth",
        articleAuthor       : "alabidou",
        articlePublishDate  : "07/15/2021",
        articleTags         : "Nuggets, 2021 Draft Central",
        eventPageView       : "1",
        offsiteSource       : "Team Site"
      };</script>
<meta name="description" content="The Nuggets have one of the deepest frontcourts in the NBA, so it is not a surprise that they haven’t been linked with many big men in this year’s draft. Still, the team has typically picked the best prospect available when it has made selections. Then there is also the pending free agency of Paul Millsap and JaVale McGee and JaMychal Green’s player option this offseason. All" />
<script type="text/javascript" src="https://assets.adobedtm.com/82bf3c13a525/5c242dc5adef/launch-f8e9806a0236.min.js" async></script>
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.nba.com/nuggets/news/robinson-earl-20210715" />
<link rel="shortlink" href="https://www.nba.com/nuggets/node/39594" />
<meta property="og:site_name" content="Denver Nuggets" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.nba.com/nuggets/news/robinson-earl-20210715" />
<meta property="og:title" content="NBA Draft 2021 Profile: Can Jeremiah Robinson-Earl add to Nuggets’ frontcourt depth? | Denver Nuggets" />
<meta property="og:description" content="The Nuggets have one of the deepest frontcourts in the NBA, so it is not a surprise that they haven’t been linked with many big men in this year’s draft. Still, the team has typically picked the best prospect available when it has made selections. Then there is also the pending free agency of Paul Millsap and JaVale McGee and JaMychal Green’s player option this offseason. All of those factors could play a role in potentially selecting a big man in the upcoming draft." />
<meta property="og:image" content="https://www.nba.com/nuggets/sites/nuggets/files/jeromeweb.jpg?cw=700&amp;ch=500&amp;w=700&amp;h=507&amp;x=0&amp;y=4" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Draft Profile: Can Robinson-Earl boost Nuggets’ frontcourt?" />
<meta name="twitter:url" content="https://www.nba.com/nuggets/news/robinson-earl-20210715" />
<meta name="twitter:description" content="The Nuggets have one of the deepest frontcourts in the NBA, so it is not a surprise that they haven’t been linked with many big men in this year’s draft. Still, the team has typically picked the best" />
<meta name="twitter:image" content="https://www.nba.com/nuggets/sites/nuggets/files/jeromeweb.jpg?cw=700&amp;ch=500&amp;w=700&amp;h=507&amp;x=0&amp;y=4" />
  <title>NBA Draft 2021 Profile: Can Jeremiah Robinson-Earl add to Nuggets’ frontcourt depth? | Denver Nuggets</title>
  <link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_WdqLW9bb5jNLXNSKGXJiwH2paPLJNKAb8HiZFZviYzM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_vLfRWPFGbR4eVZ8AMspyOjbxk-vA9d8UZeE_3dRfHZM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_6klLCvmTSl9w4XMlHaw6MYpLQ8D5ls8B1E22Jqr3JVs.css" media="screen" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_4oJdWU0FSyJjr2W5S5EP01IeXRignzpO9CBpfjqHI6w.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_YOAv9gEpZ3UhkgQPocy_kPXKT77DuztAEiE94_CNBj4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://turnip.cdn.turner.com/top/player-ui/2.3.0-1/player-ui.min.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_GPeD9LKKvhG9pOjvKVPj2232IT3LEgYn30xfth4iMCk.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/stylesheets/ie8_fallback.css?qwaxcm" media="all" />
<![endif]-->

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/stylesheets/ie7_fallback.css?qwaxcm" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/stylesheets/bootstrap.css?qwaxcm" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/stylesheets/screen.css?qwaxcm" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_T-TZfTydUwB664EEKJHDcuk7jy4tISCzGTq3m7vhy9Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_BCB628l_h53mXwkvjd6omwC2qvhBUHS4CCLe77RpTzk.css" media="print" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/colorizer/etowah_radix-de5be874.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/css/css_nSz-MNkigHVcc5ZwrqTlunh9kLPTrv-jtOUhGOToB2I.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.nba.com/nuggets/sites/nuggets/files/sitewide_overrides/active/etowah_swo_64096/style_sitewide_overrides.css?qwaxcm" media="all" />
    <script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_sOTmJnDhZ0YaYTQBr9FPewnH0WbS6pH--oA8_JDPY0w.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var jQuery1111 = jQuery.noConflict(); var jQuery111 = jQuery1111;
//--><!]]>
</script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_zS-CmNFGyegtLYJmqFRpxQvvQrfPIFrOMq_3T3C8sZE.js"></script>
<script type="text/javascript" src="//www.nba.com/javascriptGlobalSettings.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_eAtNCuh9Vfx9qN14qMJAChJnBHm5P4auvYGH7pl0im8.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_YG4e5Fz1QoKL7h--sIgmUmh3LnbsnH5A7DkL-OUQG_o.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_lIrYjw88ZYMAOjUr6Bw4pOWhZwMOgtLzjxtc8yN7yLc.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_zykj1GuJRnNxoDrLXuFv6n-3vBWcf_mN56NiBXbkjgk.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_RUl525ZJlhTXbT69JUWad71UhhrjIMfJDJcEGJL1ZuA.js"></script>
<script type="text/javascript" src="https://turnip.cdn.turner.com/top/player/2.3.0-1/player.min.js"></script>
<script type="text/javascript" src="https://turnip.cdn.turner.com/top/auth/2.3.0-1/auth.min.js"></script>
<script type="text/javascript" src="https://i.cdn.turner.com/ads/adfuel/ais/2.1/nba-teams-ais.min.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_16s4a3bPvUxjRQYFHA58_6ovzWEKfa9ukGeXCF2j-fQ.js"></script>
<script type="text/javascript" src="//agility.nba.com/turner/nba-prod/Bootstrap.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/sitewide_overrides/active/etowah_swo_64096/header_sitewide_overrides.js?qwaxcm"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_O-8YMkEHkTJ_L_8yhpg2uFQGunL4rJ_A62ML0Znf6o8.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]>
   <script>
      document.createElement('header');
      document.createElement('nav');
      document.createElement('section');
      document.createElement('article');
      document.createElement('aside');
      document.createElement('footer');
   </script>
   <link id="respond-proxy" rel="respond-proxy" href="http://i.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="http://z.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-proxy" rel="respond-proxy" href="https://s.cdn.turner.com/drp/nba/nba/nba/.element/media/2.0/teamsites/all/respond-proxy.xhtml" />
<link id="respond-redirect" rel="respond-redirect" href="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.gif" />
   <script type="text/javascript" src="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/cross-domain/respond.proxy.min.js" />
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/javascripts/vendor/respondjs/src/respond.min.js" />
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/all/themes/etowah_radix/assets/javascripts/vendor/selectivizr-min.js" />
  <![endif]-->

</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-39594 node-type-story region-content">
  <div id="skip-link">
    <a tabindex="1" href="#content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    
<header class="header" role="header">
  <nav class="global-nav-wrapper">
    <div class="container">
    <!--Top of the page navigation and NBA logo -->
      <div class="row">
        <div class="col-xs-12">
          <div class="utility-logo">
            <a tabindex="1" href = "http://www.nba.com"><span class="element-invisible">NBA</span></a>
          </div>
          <ul class="global-nav">
            <li class="global-nav__menu-item"><a tabindex="1" href="http://www.nba.com/global/" class="teamNavGlobal global-nav__hidden-xs" title="Link to NBA Global">Global</a></li>
            <li class="global-nav__menu-item expanded has-dropdown">
              <a tabindex="1" href="javascript:void(0)" id="global-nav__menu-item__teams-link">Teams</a>
              <ul class="global-nav__menu-item__sub-menu" id="global-nav__menu-item__teams-link-dropdown">
                <li><a class="global-nav__menu-item__sub-menu__sub-item" href="http://www.nba.com/teams/" title="Link to NBA Teams">Teams</a></li>
                <li class="teamHDR">Team Sites</li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hawks/" title="Link to Atlanta Hawks Team Site">Atlanta</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/heat/" title="Link to Miami Heat Team Site">Miami</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/celtics/" title="Link to Boston Celtics Team Site">Boston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bucks/" title="Link to Milwaukee Bucks Team Site">Milwaukee</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nets/" title="Link to Brooklyn Nets Team Site">Brooklyn</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/timberwolves/" title="Link to Minnesota Timberwolves Team Site">Minnesota</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/hornets/" title="Link to Charlotte Hornets Team Site">Charlotte</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pelicans/" title="Link to New Orleans Pelicans Team Site">New Orleans</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/bulls/" title="Link to Chicago Bulls Team Site">Chicago</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/knicks/" title="Link to New York Knicks Team Site">New York</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/cavaliers/" title="Link to Cleveland Cavaliers Team Site">Cleveland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/thunder/" title="Link to Oklahoma City Thunder Team Site">Oklahoma City</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/mavericks/" title="Link to Dallas Mavericks Team Site">Dallas</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/magic/" title="Link to Orlando Magic Team Site">Orlando</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/nuggets/" title="Link to Denver Nuggets Team Site">Denver</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/sixers/" title="Link to Philadelphia 76ers Team Site">Philadelphia</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pistons/" title="Link to Detroit Pistons Team Site">Detroit</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/suns/" title="Link to Phoenix Suns Team Site">Phoenix</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/warriors/" title="Link to Golden State Warriors Team Site">Golden State</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/blazers/" title="Link to Portland Blazers Team Site">Portland</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/rockets/" title="Link to Houston Rockets Team Site">Houston</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/kings/" title="Link to Sacramento Kings Team Site">Sacramento</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/pacers/" title="Link to Indiana Pacers Team Site">Indiana</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/spurs/" title="Link to San Antonio Spurs Team Site">San Antonio</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/clippers/" title="Link to LA Clippers Team Site">LA Clippers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/raptors/" title="Link to Toronto Raptors Team Site">Toronto</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/lakers/" title="Link to LA Lakers Team Site">LA Lakers</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/jazz/" title="Link to Utah Jazz Team Site">Utah</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/grizzlies/" title="Link to Memphis Grizzlies Team Site">Memphis</a></li>
                <li><a tabindex="1" class="global-nav__menu-item__sub-menu__sub-item" href="/wizards/" title="Link to Washington Wizards Team Site">Washington</a></li>
              </ul>
            </li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://gleague.nba.com" title="Link to G League">G League</a></li>
            <li class="global-nav__menu-item global-nav__hidden-xs"><a tabindex="1" href="http://www.wnba.com" title="Link to WNBA" class="teamNavWNBA">WNBA</a></li>
            <li class="global-nav__menu-item"><a tabindex="1" href="https://www.nba.com/store?category=nba_jerseys" class="teamNavStore" title="Link to NBA Store">NBA Store</a></li>
            <li class="global-nav__menu-item"><a href="https://www.nba.com/watch/streaming-subscriptions" class="teamLeaguePass" title="Link to NBA League Pass" tabindex="1">NBA League Pass</a></li>
          </ul>
        </div>
      </div>
    </div>
  </nav>
</header>

<main id="main" class="main">
  <div id="page" class="page">
          <header>
        <nav class="main-nav-wrapper">
          <div class="main-nav-wrapper-inner">
          <div class="container">
            <div class="row">
              <div class="col-md-12">
                <!-- Site Logo -->
                <div class="navbar-brand-wrapper">
                  <a tabindex="1" href="/nuggets/" id="logo" class="navbar-brand" title="Home" rel="home">
                                          <img src="https://www.nba.com/nuggets/sites/nuggets/files/dnuggets-primary-web-150x150.png?" alt="Site Logo" title="Site Logo" />                                        <span class="element-invisible">Denver Nuggets</span>
                  </a>
                </div>
                <!-- Presented by Advertisement -->
                <div class="presented-by presented-by--header">
                    <div class="region region-promo-region">
    <div id="block-bean-presented-by-promo" class="block block-bean">

    <h2>Presented by Western Union</h2>
  
  <div class="content">
      <span class="presented-by__text">Presented by</span>
  <a tabindex="1" href="https://www.westernunion.com/us/en/home.html" target="_blank">
  <img class="block__img" src="/nuggets/sites/nuggets/files/wu_logo_hz_yl_rgb.png?w=233&amp;h=22" alt="Presented by Western Union" title="Presented by Western Union" /></a>
  </div>
</div>
  </div>
                </div>
                <!-- Main Navigation for Users -->
                <div class="mobile-menu-hamburger"><a href="javascript:;"></a></div>

                <ul id="main-menu" class="main-nav left"><li class="visible-xs mobile-menu-top">Menu</li><li class="first expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/nuggets/ticketcentral" title="">Tickets</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title="" target="_blank"><a href="https://www.ticketmaster.com/denver-nuggets-tickets/artist/805935?home_away=home" title="" target="_blank">Single Game Tickets</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/ticketcentral" title="">Promotions</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/ticket-plans" title="">Partial Plans</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="http://elevatenuggets.com/" target="_blank" title="">Full Season Membership</a></li><li class="leaf" target="_blank" title=""><a href="https://ballarenaclublexus.com/" target="_blank" title="">Club Lexus</a></li><li class="leaf" target="_blank" title=""><a href="http://nuggets.io-media.com/web/index.html" target="_blank" title="">Seating Map</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="https://www.nba.com/nuggets/premium-options" title="">Premium Options</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/nuggets/roster" title="">Team</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-1"><li class="dropdown-row"><ul><li class="first leaf"><a href="/nuggets/roster">Roster</a></li><li class="leaf" title=""><a href="http://www.nba.com/nuggets/standings" title="">2020-21 Standings</a></li><li class="leaf" title=""><a href="/nuggets/stats/leaders" title="">Team Leaders</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/nuggets/stats/team">Team Stats</a></li><li class="leaf"><a href="/nuggets/stats">Player Stats</a></li><li class="leaf" target="_blank" title=""><a href="https://kseblobstorage.blob.core.windows.net/sitefiles/nuggets/DN_MediaGuide_2021.pdf" target="_blank" title="">Media Guide</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/nuggets/staff-directory">Staff Directory</a></li></ul></li><li class="dropdown-row block"><ul><li class="last leaf" title=""><div class="menu-attach-block-wrapper orientation-horizontal">
  <div id="block-bean-standings-drop-down" class="block block-bean">

    <h2>Standings</h2>
  
  <div class="content">
    <div class="menu-block">
<a href="https://www.nba.com/nuggets/standings" title="Standings" class="menu-block__link"><img class="block__img" src="/nuggets/sites/nuggets/files/dn-dropdown-buttons-standings-v2.png?" width="100%" alt="Standings" title="Standings" /></a>
<a href="https://www.nba.com/nuggets/standings" title="Standings" class="menu-block__link menu-block__link--title">Standings</a>
</div>  </div>
</div>
</div>
</li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/nuggets/schedule" title="">Schedule</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-1 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="/nuggets/schedule" title="">Full Schedule &amp; Results</a></li><li class="last leaf" title="" target="_blank"><a href="https://www.stanza.co/button/launch?calendar=https%3A%2F%2Fstanza.co%2Fschedules%2Fnba-nuggets&amp;size=large&amp;options=ticker#/" title="" target="_blank">Add to Calendar</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/nuggets/news" title="">News</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-1"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/nuggets/2021-draft-central" title="">2021 Draft Central</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/news/archive" title="">Latest News</a></li><li class="leaf" title=""><a href="/nuggets/podcasts" title="">Nuggets 24K Podcast</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="https://www.nba.com/gamenotes/nuggets.pdf" target="_blank" title="">Game Notes</a></li><li class="leaf" target="_blank" title=""><a href="https://kse.teamkse.com/Nuggets-Email-Sign-Up-Updated.html" target="_blank" title="">Newsletter Sign-Up</a></li></ul></li><li class="dropdown-row block"><ul><li class="last leaf" title=""><div class="menu-attach-block-wrapper orientation-horizontal">
  <div id="block-bean-eac-drop-down" class="block block-bean">

    <h2>Nuggets Mailbag</h2>
  
  <div class="content">
    <div class="menu-block">
<a href="https://www.nba.com/nuggets/news/nuggets-mailbag-vol-1" title="Nuggets Mailbag" class="menu-block__link"><img class="block__img" src="/nuggets/sites/nuggets/files/nuggets-mailbag-240x90-2.png?" width="100%" alt="Nuggets Mailbag" title="Nuggets Mailbag" /></a>
<a href="https://www.nba.com/nuggets/news/nuggets-mailbag-vol-1" title="Nuggets Mailbag" class="menu-block__link menu-block__link--title">Nuggets Mailbag</a>
</div>  </div>
</div>
</div>
</li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/nuggets/video" title="">Multimedia</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/nuggets/video/archive" title="">All Videos</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/video/channel/team_highlights" title="">Highlights</a></li><li class="leaf" title=""><a href="/nuggets/photos" title="">Photo Galleries</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/nuggets/photos/nuggets%20dancers%20" title="">Dancer Galleries</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/video/channel/community" title="">Community</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/video/channel/nuggets_360" title="">Nuggets 360</a></li></ul></li><li class="dropdown-row "><ul><li class="last leaf" title=""><a href="/nuggets/live" title="">Nuggets Live</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown"><a href="/nuggets/game-night">Game Night</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf"><a href="/nuggets/denver-nuggets-dancers">Dancers</a></li><li class="leaf"><a href="/nuggets/game-night/supermascot-rocky">SuperMascot Rocky</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/game-night/skyline-drumline" title="">Skyline Drumline</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/nuggets/game-night/mile-high-city-hype-squad">Mile High City Hype Squad</a></li><li class="leaf"><a href="/nuggets/game-night/in-game-hosts">In-Game Hosts</a></li><li class="leaf"><a href="/nuggets/game-night/pa-announcer">PA Announcer</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title="Austin “Paws The Music” Pawelka. "><a href="https://www.nba.com/nuggets/nuggets-dj" title="Austin “Paws The Music” Pawelka. ">Nuggets DJ</a></li><li class="last leaf"><a href="/nuggets/game-night/faqs">Game Night FAQs</a></li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/nuggets/" title="">Fans</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-4 blocks-1"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/nuggets/2021-draft-central" title="">2021 Draft Central</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/barnetwork" title="">Bar Network</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/denvernuggetsevents" title="">Fan Events</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/nuggets/mobile-app" title="">Mobile App</a></li><li class="leaf"><a href="/nuggets/fans/wallpapers">Wallpapers</a></li><li class="leaf"><a href="/nuggets/fan-zone/infographics">Infographics</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/nuggets/fan-zone/contests/king-soopers-honorary-hero-game/" title="">King Soopers Honorary Hero of the Game</a></li><li class="leaf"><a href="/nuggets/meeting-backgrounds">Video Conference Backgrounds</a></li><li class="leaf"><a href="/nuggets/fan-activities">Fan Activities</a></li></ul></li><li class="dropdown-row block"><ul><li class="last leaf" title=""><div class="menu-attach-block-wrapper orientation-horizontal">
  <div id="block-bean-camps-dropdown" class="block block-bean">

    <h2>Kids Club</h2>
  
  <div class="content">
    <div class="menu-block">
<a href="https://www.nba.com/nuggets/academy/kidsclub" title="Kids Club" class="menu-block__link"><img class="block__img" src="/nuggets/sites/nuggets/files/dn2021_kids_club_240x90.png?" width="100%" alt="Kids Club" title="Kids Club" /></a>
<a href="https://www.nba.com/nuggets/academy/kidsclub" title="Kids Club" class="menu-block__link menu-block__link--title">Kids Club</a>
</div>  </div>
</div>
</div>
</li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="https://www.nba.com/nuggets/academy" title="">Youth</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-1"><li class="dropdown-row"><ul><li class="first leaf" title=""><a href="https://www.nba.com/nuggets/academy" title="">Nuggets Basketball Academy</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/academy/kidsclub" title="">Kids Club</a></li><li class="leaf" target="_blank" title=""><a href="https://www.nba.com/nuggets/academy/skillsclinic" target="_blank" title="">Skills Clinics</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" title=""><a href="https://www.nba.com/nuggets/academy/virtualclinic" title="">Clinics</a></li><li class="leaf" title=""><a href="https://www.nba.com/nuggets/academy/academytv" title="">Nuggets Academy TV</a></li><li class="leaf" target="_blank" title=""><a href="https://kse.formstack.com/forms/nuggets_academy_contact_us" target="_blank" title="">Contact Us</a></li></ul></li><li class="dropdown-row block"><ul><li class="last leaf" title=""><div class="menu-attach-block-wrapper orientation-horizontal">
  <div id="block-bean-camps-dropdown--2" class="block block-bean">

    <h2>Kids Club</h2>
  
  <div class="content">
    <div class="menu-block">
<a href="https://www.nba.com/nuggets/academy/kidsclub" title="Kids Club" class="menu-block__link"><img class="block__img" src="/nuggets/sites/nuggets/files/dn2021_kids_club_240x90.png?" width="100%" alt="Kids Club" title="Kids Club" /></a>
<a href="https://www.nba.com/nuggets/academy/kidsclub" title="Kids Club" class="menu-block__link menu-block__link--title">Kids Club</a>
</div>  </div>
</div>
</div>
</li></ul></li></ul></li><li class="expanded main-nav__menu-item has-dropdown" title=""><a href="/nuggets/community" title="">Community</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-0"><li class="dropdown-row"><ul><li class="first leaf"><a href="/nuggets/news/ninth-annual-givesports-drive">giveSPORTS Drive</a></li><li class="leaf" title=""><a href="/nuggets/community/charity-events" title="">Charity Events</a></li><li class="leaf"><a href="/nuggets/community/donations">Donations</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf"><a href="/nuggets/community/community-ambassadors">Community Ambassadors</a></li><li class="leaf" title=""><a href="/nuggets/community/educational-athletic-programs" title="">Youth Programs</a></li><li class="leaf"><a href="/nuggets/community/license-plate">License Plate</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="https://www.facebook.com/KroenkeSportsCharities" target="_blank" title="">Kroenke Sports Charities Facebook</a></li><li class="leaf" target="_blank" title=""><a href="https://kseblobstorage.blob.core.windows.net/sitefiles/Altitude/KSC_AnnualReport_2019-20_ONLINE.pdf" target="_blank" title="">Community Report</a></li><li class="last leaf" title=""><a href="https://www.nba.com/nuggets/program-sales" title="">Program Sales</a></li></ul></li></ul></li><li class="last expanded main-nav__menu-item has-dropdown" target="_blank" title=""><a href="https://www.altitudeauthentics.com/" target="_blank" title="">Store</a><div class='button-primary__arrow button-primary__arrow--down button-primary__arrow--mobile-nav'></div><ul class="dropdown cols-3 blocks-1"><li class="dropdown-row"><ul><li class="first leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-jerseys" target="_blank" title="">Jerseys</a></li><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-evolve-hats" target="_blank" title="">Hats</a></li><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-evolve-mens" target="_blank" title="">Men&#039;s</a></li></ul></li><li class="dropdown-row "><ul><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-evolve-womens" target="_blank" title="">Women&#039;s</a></li><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-evolve-kids" target="_blank" title="">Kids&#039;</a></li><li class="leaf" target="_blank" title=""><a href="https://www.altitudeauthentics.com/collections/nuggets-evolve-novelties" target="_blank" title="">Novelties</a></li></ul></li><li class="dropdown-row block"><ul><li class="last leaf" title=""><div class="menu-attach-block-wrapper orientation-horizontal">
  <div id="block-bean-shop-drop-down" class="block block-bean">

    <h2>Nuggets Jerseys Shop Now</h2>
  
  <div class="content">
    <div class="menu-block">
<a href="https://www.altitudeauthentics.com/collections/nuggets-evolve-jerseys" title="Nuggets Jerseys Shop Now" class="menu-block__link"><img class="block__img" src="/nuggets/sites/nuggets/files/aa-1819-jerseyordernow-240x90.png?" width="100%" alt="Nuggets Jerseys Shop Now" title="Nuggets Jerseys Shop Now" /></a>
<a href="https://www.altitudeauthentics.com/collections/nuggets-evolve-jerseys" title="Nuggets Jerseys Shop Now" class="menu-block__link menu-block__link--title">Nuggets Jerseys Shop Now</a>
</div>  </div>
</div>
</div>
</li></ul></li></ul></li></ul>                                <div class="search-box">
                  <p><span class="search-box__pre-text">Search</span> <a tabindex="-1" class="search-box__icon" href="#"><span tabindex="-1" class="element-invisible">Toggle Search Input</span></a>
                  </p>
                  <div class="search-box__form-wrapper">
                    <form>
                      <label for="search-box__input-box" class="element-invisible">Search Box</label>
                      <input tabindex="1" id="search-box__input-box" class="search-box__input-box" alt="search box" type="text" placeholder="Search" />
                      <input tabindex="1" type="submit" class="submit search-box__submit-btn" value="Search" />
                      <div class="search-box__submit-btn-icon"></div>
                    </form>
                  </div>
                </div>
                <!-- Social Bar -->
                <div class="social-bar-wrapper">
                  <!-- <a class="social-bar__mobile-icon visible-xs" href="#"><span class="element-invisible">Social Menu</span></a> -->
                    <div class="region region-header-social">
    <div id="block-etowah-marketing-social-links-header" class="block block-etowah-marketing">

    
  <div class="content">
    <ul class="social-bar first social-bar--header"><li class="social-bar__item "><a href="https://www.facebook.com/DenverNuggets" target="_blank" class="" alt="Facebook social link" title="Facebook social link" style="background-color:#0e2240"><i class="fab fa-facebook-f"></i></a></li><li class="social-bar__item "><a href="https://twitter.com/nuggets" target="_blank" class="" alt="Twitter social link" title="Twitter social link" style="background-color:#0e2240"><i class="fab fa-twitter"></i></a></li><li class="social-bar__item "><a href="https://www.instagram.com/nuggets/" target="_blank" class="" alt="Instagram social link" title="Instagram social link" style="background-color:#0e2240"><i class="fab fa-instagram"></i></a></li><li class="social-bar__item "><a href="https://www.youtube.com/DenverNuggets" target="_blank" class="" alt="YouTube social link" title="YouTube social link" style="background-color:#0e2240"><i class="fab fa-youtube"></i></a></li><li class="social-bar__item "><a href="https://kse.teamkse.com/Nuggets-Email-Sign-Up-Updated.html" target="_blank" class="" alt="Email social link" title="Email social link" style="background-color:#0e2240"><i class="far fa-envelope"></i></a></li></ul>  </div>
</div>
  </div>
                </div>
              </div><!-- End .col-lg-12 -->
            </div><!-- End .row -->
          </div><!-- End .container -->
        </div><!-- End .main-nav-wrapper-inner -->
        </nav><!-- End .main-nav-wrapper -->
      </header>
    
    <div class="container">
      
    </div>
          <div class="page-header-ad">
        <div class="container">
            <div class="region region-header">
    <div id="block-panels-mini-mini-panel-top-banner-ad" class="block block-panels-mini">

    
  <div class="content">
    <div class="panel-display panel-1col clearfix" id="mini-panel-mini_panel_top_banner_ad">
  <div class="panel-panel panel-col">
    <div><div class="panel-pane pane-fieldable-panels-pane pane-current-129 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1293-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1292-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1292-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
</div>
  </div>
</div>
  </div>
</div>
  </div>
        </div>
      </div>
    
     <div tabindex="0" id="content" class="">

    <div id="page-header">
                      </div>
           <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    
<div class="panel-display moscone-flipped clearfix " >

  <div class="moscone-container moscone-header clearfix panel-panel">
    <div id='moscone-header-inner' class="moscone-container-inner moscone-header-inner panel-panel-inner">
          </div>
  </div>

  <div class="moscone-flipped-container moscone-flipped-column-content clearfix">
    <div class="moscone-flipped-column-content-region moscone-flipped-content panel-panel">
      <div id='moscone-flipped-content-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-content-inner panel-panel-inner">
        <div class="panel-pane pane-etowah-story-pane-photo" >
  
      
  
  <div class="pane-content">
      
  <img src="/nuggets/sites/nuggets/files/jeromeweb.jpg?w=756&amp;h=547" />    

  <div>
    <h1>NBA Draft 2021 Profile: Can Jeremiah Robinson-Earl add to Nuggets’ frontcourt depth?</h1>
     
      <div class="field field-name-field-subheadline field-type-text field-label-hidden">
              </div>
      </div>
  </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-author" >
  
      
  
  <div class="pane-content">
     
<div class="author-block">
   
   
  <div class="author-block__author">by Alex Labidou</div>
      <div class="author-block__author-title">Nuggets.com Staff Writer <br><a href="http://twitter.com/LabidouA">@LabidouA</a></div>
    <div class="author-block__post-date">Posted: Jul 15, 2021</div>
    <div class="social-bar--author-block__wrapper"><div class='social-bar-wrapper social-bar--author-block' id='social-bar-wrapper-3959460f2ff884f753'><div class="item-list"><ul class="social-bar "><li class="social-bar__item first"><a href="https://facebook.com/sharer.php?u=https://www.nba.com/nuggets/news/robinson-earl-20210715&amp;t=NBA+Draft+2021+Profile%3A+Can+Jeremiah+Robinson-Earl+add+to+Nuggets%E2%80%99+frontcourt+depth%3F" class="social-facebook-icon facebook-color social-facebook-popup" title="Share on Facebook" target="_blank"><span class='element-invisible'>Facebook</span></a></li>
<li class="social-bar__item last"><a href="https://twitter.com/intent/tweet?url=https://www.nba.com/nuggets/news/robinson-earl-20210715&amp;text=NBA+Draft+2021+Profile%3A+Can+Jeremiah+Robinson-Earl+add+to+Nuggets%E2%80%99+frontcourt+depth%3F&amp;via=nuggets" class="social-twitter-icon twitter-color social-twitter-popup" title="Share on Twitter" target="_blank"><span class='element-invisible'>Twitter</span></a></li>
</ul></div></div></div>
  </div><!-- End author-block -->  </div>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="pane-content">
    <div class="field field-name-body field-type-text-with-summary field-label-hidden">
  		  <p>The Nuggets have one of the deepest frontcourts in the NBA, so it is not a surprise that they haven’t been linked with many big men in this year’s draft. Still, the team has typically picked the best prospect available when it has made selections. Then there is also the pending free agency of Paul Millsap and JaVale McGee and JaMychal Green’s player option this offseason. All of those factors could play a role in potentially selecting a big man in the upcoming draft.</p>
<p>One frontcourt standout who has seen his name attached to the Nuggets in mock drafts is Jeremiah Robinson-Earl. The two-year Villanova star is a polished low post scorer and an effective rebounder.</p>
</p>
<p><strong>Here is an in-depth look at Robinson-Earl:</strong></p>
<p>Background info</p>
<p>Age: 20</p>
<p>School: Villanova</p>
<p>Grade: Sophomore</p>
<p>Position: Forward</p>
<p>Height: 6-foot-9</p>
<p>Weight: 230 pounds</p>
<p><strong>2020-21 Stats:</strong></p>
<p>15.7 PPG</p>
<p>8.5 RPG</p>
<p>49.7 FG%</p>
<p>28.0 3P%</p>
<p>34.5 MPG</p>
</p>
<p><strong>Profile</strong></p>
<p>Robinson-Earl is a throwback big man, with strong footwork in the low post and a penchant for doing the dirty work when needed. His high basketball IQ is a big reason why he was named the Big East Co-Player of the Year last season. Still, questions remain on if his skill set can translate into the modern NBA.</p>
<p>Robinson-Earl isn’t the most athletic big in the draft and his three-point percentage dipped from his freshman year (32 percent) to his sophomore campaign (28 percent). In a league that craves frontcourt players who can stretch the floor, Robinson-Earl will need to work on that area of his game if he is going to develop into a rotation player.</p>
<p>However, teams will likely be encouraged by Robinson-Earl’s growth as a scorer in his sophomore season. His scoring went up from 10.5 points per game to 15.7. He also raised his overall shooting percentage from 45.4 to 49.7, despite taking more shots. Robinson-Earl added a deadly mid-range shot to his already impressive low post arsenal and that was the foundation of his spike in production. He is also a decent passer for his position.</p>
<p>Teams will also be impressed with Robinson-Earl’s defensive instincts. He isn’t a natural shot-blocker (averaging 0.6 blocks at Villanova), but he has strong positional awareness. It wasn’t uncommon to see Jay Wright task him with guarding smaller players.</p>
<p>If the Nuggets were to select Robinson-Earl, he could spend his first year with the team learning from some of the team’s uniquely skilled frontcourt players – ranging from Nikola Jokić to Aaron Gordon. With a focus on improving his long-range shot, Robinson-Earl could be an interesting addition to Michael Malone's team. </p>
</p>
<p><strong>What they’re saying:</strong></p>
<p>Solid basketball IQ and is a willing passer. Good court vision and makes the right pass, always knows where his teammates are. Knows where he’s passing before he catches the ball … Good defensive versatility, guards multiple positions. Picks up ball handlers away from the basket, also defends the post.</p>
<p><strong>- <a href="https://www.nbadraft.net/players/jeremiah-robinson-earl/">NBADraft.net</a></strong></p>
</p>
<p>He’s not much of a rim protector but he plays with excellent positioning. It remains to be seen if he can develop as an interior defender. He measured at 6-9 in shoes and he’s not a big wingspan guy with a 6-9 3/4 wingspan.</p>
<p><strong>- <a href="https://nbadraftroom.com/p/jeremiah-robinson-earl/">NBA Draft Room</a></strong></p>
	</div>
  </div>

  
  </div>
<div class="panel-pane pane-node-links link-wrapper" >
  
      
  
  <div class="pane-content">
      </div>

  
  </div>
<div class="panel-pane pane-etowah-story-pane-tags" >
  
      
  
  <div class="pane-content">
    <div class="tag__title">Tags</div><div class="tag__link-wrapper"><a href="/nuggets/archive/Nuggets" class="tag__link" aria-label="Link to content tagged with Nuggets">Nuggets</a>, <a href="/nuggets/archive/2021%20Draft%20Central" class="tag__link" aria-label="Link to content tagged with 2021 Draft Central">2021 Draft Central</a></div>  </div>

  
  </div>
      </div>
    </div>
    <div class="moscone-flipped-column-content-region moscone-flipped-sidebar panel-panel">
      <div id='moscone-flipped-sidebar-inner' class="moscone-flipped-column-content-region-inner moscone-flipped-sidebar-inner panel-panel-inner">
        <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60ce-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60ce-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-etowah-story-pane-rel-stories" >
  
        <h4 class="pane-title" tabindex="0">Related Content</h4>
    
  
  <div class="pane-content">
      <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">Nuggets</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/nuggets/news/nugs-draft-party-20210714"><img class="content-image" src="/nuggets/sites/nuggets/files/dn21_draftparty_1920x1080.png?cw=210&amp;ch=140&amp;w=249&amp;h=140&amp;x=20&amp;y=0" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/news/nugs-draft-party-20210714" class="node_title related-content__link related-content__link--title">Denver Nuggets to host NBA Draft party at Tom’s Watch Bar at McGregor Square</a></div>
                    <div class="post__date">July 14, 2021</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/nuggets/news/christopher-profile-20210713"><img class="content-image" src="/nuggets/sites/nuggets/files/joshchristopher.jpg?cw=210&amp;ch=140&amp;w=210&amp;h=152&amp;x=0&amp;y=6" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/news/christopher-profile-20210713" class="node_title related-content__link related-content__link--title">NBA Draft 2021 Profile: Josh Christopher’s athleticism could be a difference-maker for Nuggets</a></div>
                    <div class="post__date">July 13, 2021</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/nuggets/news/draftworkouts-20210712"><img class="content-image" src="/nuggets/sites/nuggets/files/quintongrimes.jpg?cw=210&amp;ch=140&amp;w=210&amp;h=152&amp;x=0&amp;y=6" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/news/draftworkouts-20210712" class="node_title related-content__link related-content__link--title">Denver Nuggets Draft Workouts: Takeaways from Day 1 and 2</a></div>
                    <div class="post__date">July 12, 2021</div>
        </li>
          </ul>
  </div>
  <div class="related-content col-xs-12 col-tiny-6 col-sm-6 col-md-12">
    <div>
            <h3 class="related-content__tag-name">2021 Draft Central</h3>
          </div>
    <ul class="related-content__row-wrapper">
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/nuggets/news/nuggets-2021-mock-draft-monday-071221"><img class="content-image" src="/nuggets/sites/nuggets/files/mock_draft_mon_july_12_web.png?cw=210&amp;ch=140&amp;w=210&amp;h=152&amp;x=0&amp;y=6" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/news/nuggets-2021-mock-draft-monday-071221" class="node_title related-content__link related-content__link--title">Nuggets 2021 NBA Mock Draft Monday - July 12 </a></div>
                    <div class="post__date">July 12, 2021</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/nuggets/news/nuggets-draft-profile-joshua-primo-070821"><img class="content-image" src="/nuggets/sites/nuggets/files/primo_profile_web.png?cw=210&amp;ch=140&amp;w=210&amp;h=152&amp;x=0&amp;y=6" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/news/nuggets-draft-profile-joshua-primo-070821" class="node_title related-content__link related-content__link--title">NBA Draft 2021 Profile: Joshua Primo’s versatility could boost Nuggets backcourt </a></div>
                    <div class="post__date">July 08, 2021</div>
        </li>
              <li class="related-content__row">
                      <a class="content-image__link-wrapper content-image__link-wrapper--left-thumb hidden-xs icon-overlay icon-overlay--news" href="https://www.nba.com/nuggets/news/nuggets-mock-draft-monday-070521"><img class="content-image" src="/nuggets/sites/nuggets/files/mock_mon_july_5_web.png?cw=210&amp;ch=140&amp;w=210&amp;h=152&amp;x=0&amp;y=6" width="210" height="140" alt="" /></a>                    <div class="post__title"><a href="/nuggets/news/nuggets-mock-draft-monday-070521" class="node_title related-content__link related-content__link--title">Nuggets 2021 NBA Mock Draft Monday – July 5 </a></div>
                    <div class="post__date">July 05, 2021</div>
        </li>
          </ul>
  </div>
  </div>

  
  </div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60d1-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60d1-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
      </div>
    </div>
  </div>

  <div class="moscone-container moscone-footer clearfix panel-panel">
    <div id='moscone-footer-inner' class="moscone-container-inner moscone-footer-inner panel-panel-inner">
      <div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c60cf-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c60cf-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
    </div>
  </div>

</div><!-- /.moscone-flipped -->
  </div>
</div>
<div class="etowah_ticket_share mfp-hide">
  <app-ticket-share></app-ticket-share>
</div>
  <div class="nextup_wrapper nextup_original">
    <div class="nextup_contain" tabindex="0" aria-label="Next Up">
      <div class="nextup_header">
        <div class="nextup_image">
          <img src="" class="thumb" />
        </div>
        <div class="nextup_details">
          <div class="nextup_timer">NEXT UP: <span></span></div>
          <div class="nextup_title"></div>
          <div class="nextup_desc"></div>
        </div>
      </div>
      <div class="nextup_playback">
        <button class="nextup_replay" title="Replay Video">Replay</button>
        <button class="nextup_playnext" title="Play Next Video">Play Next</button>
      </div>
      <div class="nextup_social">
        <hr />
        <ul>
          <li id="nextup_fb">
            <a href="#" target="_blank" title="Share to Facebook">
              <img src="https://cdn.nba.net/assets/video/icons/social_fb.png" alt="Facebook" />
            </a>
          </li>
          <li id="nextup_tw">
            <a href="#" target="_blank" title="Share to Twitter">
              <img src="https://cdn.nba.net/assets/video/icons/social_tw.png" alt="Twitter" />
            </a>
          </li>
          <li id="nextup_link">
            <a href="#" title="Copy share link">
              <img src="https://cdn.nba.net/assets/video/icons/social_lk.png" alt="Share Link" />
            </a>
            <div id="nextup_link_message">Link copied to clipboard</div>
          </li>
        </ul>
      </div>
    </div>
  </div>  </div>
    </div>
  </div><!-- End .page -->

</main>

  <div class="region region-footer">
    <div id="block-panels-mini-mini-panel-footer" class="block block-panels-mini">

    
  <div class="content">
    
<footer id="footer" role="footer" class="footer panel-display etowah-footer clearfix etowah-footer" id="mini-panel-mini_panel_footer">
  <div class="footer-top">
    <div class="container">
      <div class="row">
        <div class="custom-page-ad_bottom">
          <div class="panel-pane pane-fieldable-panels-pane pane-uuid-b244530f-50b5-4b48-abd1-615c8cb48ea4 pane-bundle-etowah-text" >
  
      
  <div class="fieldable-panels-pane">
    <div class="field field-name-field-etowah-text-body field-type-text field-label-hidden">
  		  <img height="1" width="1" style="border-style:none;" alt="" src="https://insight.adsrvr.org/track/evnt/?adv=puaym5k7&ct=0:hu4awgww&fmt=3"/>  	</div>
</div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c1295-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c1295-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
<div class="panel-pane pane-fieldable-panels-pane pane-uuid-846c39a0-c062-11e3-8a33-0800200c9a66 pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
            <div id="div-gpt-ad-846c39a0-c062-11e3-8a33-0800200c9a66" class="gpt_container" data-section="" data-pos-one="" data-pos-two=""></div>
      </div>

  
</div>
        </div>
      </div>
      <div class="row">
        <ul class="col-xs-12 footer-top-sponsors">
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-fieldable-panels-pane pane-vuuid-9ae18ec0-0e65-4a49-859b-163293e591da pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
                        <div class="field field-name-field-etowah-promo-image field-type-file field-label-hidden">
  		  <img src="/nuggets/sites/nuggets/files/promos/mile-high-city-logo-web.png?cw=865&amp;ch=484&amp;w=125&amp;h=125&amp;x=0&amp;y=0" width="865" height="484" alt="" title="mile-high-city-logo-web.png" />	</div>
       
      </div>

  
</div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-navigation" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="/nuggets/tickets/contact-us" title="">Contact Us</a></li>
<li class="leaf"><a href="https://www.ballarena.com/arena-information/job-opportunities/" target="_blank" title="">Employment</a></li>
<li class="leaf"><a href="/nuggets/contact/faqs" title="">FAQs</a></li>
<li class="last leaf"><a href="/nuggets/staff-directory" title="">Staff Directory</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-menu-kse-info" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="https://kse.teamkse.com/Nuggets-Email-Sign-Up-Updated.html" target="_blank" title="">Newsletter Sign-Up</a></li>
<li class="leaf"><a href="http://www.ballarena.com/tours" target="_blank" title="">Ball Arena Tours</a></li>
<li class="leaf"><a href="/nuggets/advertise-with-us" title="">Advertise With Us</a></li>
<li class="last leaf"><a href="/nuggets/nba-fan-code-conduct" title="">NBA Fan Code of Conduct</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-block pane-menu-menu-footer-menu-column-three" >
  
      
  
  <div class="pane-content">
    <ul class="menu nav"><li class="first leaf"><a href="http://www.altitudeauthentics.com/" target="_blank" title="">Altitude Authentics</a></li>
<li class="leaf"><a href="https://www.ticketmaster.com/denver-nuggets-tickets/artist/805935" target="_blank" title="">Ticketmaster</a></li>
<li class="leaf"><a href="https://www.altitudesportsradio.com/" target="_blank" title="">Altitude Sports Radio</a></li>
<li class="leaf"><a href="http://www.ballarena.com/" target="_blank" title="">Ball Arena</a></li>
<li class="last leaf"><a href="https://www.altitudesports.com/" target="_blank" title="">Altitude Sports</a></li>
</ul>  </div>

  
  </div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
            <div class="panel-pane pane-fieldable-panels-pane pane-uuid-923ea1cd-ed0f-4d77-94eb-81c324d26d7d pane-bundle-etowah-promo" >
  
      
  <div class="fieldable-panels-pane">
          <a href="https://www.westernunion.com/us/en/home.html" target="_blank">              <div class="field field-name-field-etowah-promo-image field-type-file field-label-hidden">
  		  <img src="/nuggets/sites/nuggets/files/promos/wu_logo_st_yl_rgb_2.png?cw=865&amp;ch=484&amp;w=250&amp;h=188&amp;x=0&amp;y=0" width="865" height="484" alt="" title="wu_logo_st_yl_rgb_2.png" />	</div>
       
    </a>  </div>

  
</div>
          </li>
          <li class="footer-top-sponsors__sponsor-item col-md-2 col-sm-3 col-xs-12">
                      </li>
        </ul>
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-top -->

  <div class="footer-bottom">
    <div class="container">
      <div class="row">
        <div class="footer-left col-xs-12 col-md-6">
          <p class="copyrights">
  Copyright © 2021 NBA Media Ventures, LLC. All rights reserved.
  No portion of NBA.com may be duplicated, redistributed or manipulated in any form.
  This site is operated jointly by NBA and WarnerMedia. To opt out of the sale of your personal information as permitted by the California Consumer 
  Privacy Act, please use the links below to visit each company’s privacy center. If you make a request through the WarnerMedia Privacy Center, 
  it will apply to data controlled jointly by the NBA and WarnerMedia as well as other data controlled by WarnerMedia. If you make a request through 
  the NBA Privacy Center, it will apply to data controlled independently by the NBA.
  <a href="https://www.nba.com/privacy-policy#Cookies">NBA Privacy Center</a>  |
  <a href="https://www.warnermediaprivacy.com">WarnerMedia Privacy Center</a>  |
  <a href="https://privacy.nba.com">Do Not Sell My Personal Information</a>  |
  <a href="http://www.nba.com/news/termsofuse">Terms of Use</a>  |
  <a href="https://www.nba.com/accessibility">Accessibility and Closed Caption</a>  |
  <a id="nba_cnsnt_trst" class="nbaAdChoices" consent="null">
    <script type="text/javascript" src="//consent.truste.com/notice?domain=turner.com&amp;c=nba_cnsnt_trst&amp;text=true&amp;country=us" id="truste_0.7941776050720364"></script>
    <script async="async" type="text/javascript" crossorigin="" src="//consent.truste.com/get?name=notice.js"></script>
  </a>
  |
  <a class="ot-sdk-show-settings">Manage Preferences</a>
</p>
        </div><!-- End .footer-right .col-md-6 -->
        <div class="footer-right col-xs-12 col-md-6 pull-left">
          <ul class="footer-nav">
  <li class="footer-nav__menu-item">
    <a href="http://adspecs.nba.com" target="_blank">Advertise on NBA.com</a>    </li>
  <li class="footer-nav__menu-item">
    <a href="https://support.watch.nba.com/hc/en-us" target="_blank">NBA.com Help</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="http://www.nba.com/help/fan_relations_faq.html" target="_blank">Fan Relations FAQ</a>  </li>
  <li class="footer-nav__menu-item">
    <a href="https://careers.nba.com/" target="_blank">NBA Career Opportunities</a>  </li>
<ul>
        </div><!-- End .footer-left .col-md-6 -->
      </div><!-- End .row -->
      <div class="row">
        <div class="col-md-12">
          <div class="turner-logo"></div>NBA.com is part of Turner Sports Digital, part of the Turner Sports & Entertainment Digital Network.        </div><!-- End col-md-6 -->
      </div><!-- End .row -->
    </div><!-- End .container -->
  </div><!-- End .footer-bottom -->
</footer> <!-- End .footer -->
  </div>
</div>
  </div>
  <div id="closure" style="visibility:hidden; position:absolute; bottom:0; right:0; max-height :1px; max-width:1px;"><script type="text/javascript">if (document.getElementById("user-login--2")) {document.getElementsByClassName("form-item-pass")[0].getElementsByClassName("description")[0].innerHTML = "Enter the password that accompanies your username.";}</script>

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '276454472733728');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=276454472733728&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Code for Action: NBA Nuggets - Sitewide -->
<!-- Begin Sizmek DSP Conversion Action Tracking Code Version 9 -->
<script type='text/javascript'>
(function() {
	var w = window, d = document;
	var s = d.createElement('script');
	s.setAttribute('async', 'true');
	s.setAttribute('type', 'text/javascript');
	s.setAttribute('src', '//c1.rfihub.net/js/tc.min.js');
	var f = d.getElementsByTagName('script')[0];
	f.parentNode.insertBefore(s, f);
	if (typeof w['_rfi'] !== 'function') {
		w['_rfi']=function() {
			w['_rfi'].commands = w['_rfi'].commands || [];
			w['_rfi'].commands.push(arguments);
		};
	}
	_rfi('setArgs', 'ver', '9');
	_rfi('setArgs', 'rb', '37981');
	_rfi('setArgs', 'ca', '20813499');
	_rfi('setArgs', '_o', '37981');
	_rfi('setArgs', '_t', '20813499');
	_rfi('track');
})();
</script>
<noscript>
  <iframe src='//20813499p.rfihub.com/ca.html?rb=37981&ca=20813499&_o=37981&_t=20813499&ra=REPLACE_ME_WITH_YOUR_CACHE_BUSTING' style='display:none;padding:0;margin:0' width='0' height='0'>
</iframe>
</noscript>
<!-- End Sizmek DSP Conversion Action Tracking Code Version 9 -->

<!-- 
Start of global snippet: Please do not remove
Place this snippet between the <head> and </head> tags on every page of your site.
-->
<!-- Global site tag (gtag.js) - Google Marketing Platform -->
<script async src="https://www.googletagmanager.com/gtag/js?id=DC-6589969"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'DC-6589969');
</script>
<!-- End of global snippet: Please do not remove -->

<!--
Event snippet for Nuggets_Retargeting_Altitude Tickets on https://www.altitudetickets.com/events/category/basketball: Please do not remove.
Place this snippet on pages with events you’re tracking. 
Creation date: 08/23/2019
-->
<script>
  gtag('event', 'conversion', {
    'allow_custom_scripts': true,
    'send_to': 'DC-6589969/retar0/nugge0+standard'
  });
</script>
<noscript>
<img src="https://ad.doubleclick.net/ddm/activity/src=6589969;type=retar0;cat=nugge0;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=;npa=;ord=1?" width="1" height="1" alt=""/>
</noscript>
<!-- End of event snippet: Please do not remove -->

<!-- BEGIN ControlTag for "MSO_NBANuggets" -->
<script class="kxct" data-id="unvkgy2tj" data-timing="async" data-version="3.0" type="text/javascript">
  window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
  (function(){
    var k=document.createElement('script');k.type='text/javascript';k.async=true;
    k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/unvkgy2tj.js';
    var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
  }());
</script>
<!-- END ControlTag -->

<!-- Tegna Pixel-->
<img src="https://jelly.mdhv.io/v1/star.gif?pid=958558285533&src=mh&evt=hi">
<!--End Tegna Pixel-->

<!--
Event snippet for Nuggets_Camps_Retargeting on https://protect-us.mimecast.com/s/cSoKCo2930IrqLLkiOCe6M?domain=nba.com Please do not remove.
Place this snippet on pages with events youíre tracking. 
Creation date: 01/14/2020
-->
<script>
  gtag('event', 'conversion', {
    'allow_custom_scripts': true,
    'send_to': 'DC-6589969/retar0/nugge001+standard'
  });
</script>
<noscript>
<img src="https://protect-us.mimecast.com/s/GHECCqxXgrs80PP9cqj7Jx?domain=ad.doubleclick.net" width="1" height="1" alt=""/>
</noscript>
<!-- End of event snippet: Please do not remove -->

</div><div id="parsely-root" style="display: none">
                  <span id="parsely-cfg" data-parsely-site="nuggets.nba.com"></span>
                </div><script type="text/javascript" src="https://www.nba.com/ngteams/runtime.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/polyfills.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/vendor.js"></script>
<script type="text/javascript" src="https://www.nba.com/ngteams/main.js"></script>
<script type="text/javascript" src="https://z.cdn.turner.com/nba/tmpl_asset/static/nba-cms3-base/latest/js/pkgCustomLibs-min.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_ROY4zcHmM4k19meZDVZumyAgHlEizExYwYth1i_9mkw.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_KdQWIKINQBZyGu1LBsBAYG_as7pgvy5uNErmTAOuhbw.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_aiQf68XsPM6zndplRn7gli6laergl9IvwXahO765-90.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_CpKA_1OC8W0diAfzqJsNEAadBhdt9xR0Fdb4Guu-nJ8.js"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/sitewide_overrides/active/etowah_swo_64096/footer_sitewide_overrides.js?qwaxcm"></script>
<script type="text/javascript" src="https://www.nba.com/nuggets/sites/nuggets/files/js/js_cfR1Maee_G2v3cwxi7NDUeq1dJrHOI_i3C6CdVFjXyQ.js"></script>
  </body>
</html>