
<!DOCTYPE html><html lang="en" dir="ltr"><head><link rel="dns-prefetch" href="//fastlane.rubiconproject.com"><link rel="dns-prefetch" href="//optimized-by.rubiconproject.com"><link rel="dns-prefetch" href="//ads.rubiconproject.com"><link rel="dns-prefetch" href="//aax.amazon-adsystem.com"><link rel="dns-prefetch" href="//c.amazon-adsystem.com"><link rel="dns-prefetch" href="//rtax.criteo.com"><meta charset="utf-8" />
<meta property="title" content="Isaiah Thomas making progress, could join Cleveland Cavaliers earlier | NBA.com" />
<link rel="canonical" href="http://www.nba.com/article/2017/11/07/isaiah-thomas-progress-cavaliers" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="viewport" content="width=device-width" />
<meta content="ie=edge, chrome=1" http-equiv="x-ua-compatible" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1044.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<meta http-equiv="ImageToolbar" content="false" />
<script>
  var cvp_settings = {
      "cdnAkamaiVideoFlashPrefix" : "http://nbavod-f.akamaihd.net/z/nba/big",      "cdnAkamaiVideoHtml5Prefix" : "http://nbavod-f.akamaihd.net/i/nba/big",      "cdnAkamaiVideoFlashSuffix" : "_,416x234_150,416x234_380,640x360_664m,768x432_996,768x432_1404,960x540_2104,1280x720,.mp4.csmil/manifest.f4m",      "cdnAkamaiVideoHtml5Suffix" : "_,416x234_150,416x234_380,640x360_664m,768x432_996,768x432_1404,960x540_2104,1280x720,.mp4.csmil/master.m3u8",      "cvpPlayer" : "nba_prod",      "hpCvpPlayerContext" : "desktop_home",      "hpCvpPlayerName" : "nba_hp_standalone_player",      "cvpJsVersion" : "2.8.8.1/cvp.min.js",      "hostLive" : "www.nba.com",      "jsNamespace" : "_nba",      "jsSettings" : "settings",      "cdnTurnerVideoPrefix" : "http://nba.cdn.turner.com/nba/big",      "cvpContainerVersion" : "3.0.0.0_RC1/cvp_main_container.swf",      "containerSwfRoot" : "cvp1.cdn.turner.com/xslo/cvp/assets/container/",      "cvpProfile" : "30",      "cvpProfileSecure" : "41",      "cvpProfileLive" : "34",      "cvpProfileLiveSecure" : "44"    };
</script>
<meta name="author" content="Tom Withers | The Associated Press" />
<meta name="publishDate" content="2017-11-07T14:04:57" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Isaiah Thomas making progress, could join Cleveland Cavaliers earlier","url":"http:\/\/www.nba.com\/article\/2017\/11\/07\/isaiah-thomas-progress-cavaliers","dateCreated":"2017-11-07T08:54:03Z","datePublished":"2017-11-07T14:04:57","author":{"@type":"Organization","name":"NBA.com"},"publisher":{"@type":"Organization","name":"NBA.com","logo":{"@type":"ImageObject","url":"http:\/\/cdn.nba.net\/assets\/amp\/include\/images\/nba-logo.png","width":180,"height":60}},"image":{"@type":"ImageObject","url":"http:\/\/cdn.nba.net\/themes\/custom\/league\/assets\/images\/video\/nbaVideoGeneric1200x675.png","width":225,"height":127},"thumbnailUrl":"https:\/\/cdn.nba.net\/nba-drupal-prod\/2017-11\/isaiah-thomas-pregame-red.jpg","creator":"Tom Withers | The Associated Press","keywords":["Isaiah Thomas","Cleveland Cavaliers","Top Stories Web &amp; App"]}</script>
<meta property="description" content="INDEPENDENCE, Ohio (AP)&amp;nbsp; -- Day by day, dribble by dribble , Isaiah Thomas looks a little more like an All-Star point guard - like himself.

And just maybe like one who can rescue the reeling " />
<meta property="og:image" content="https://cdn.nba.net/nba-drupal-prod/2017-11/isaiah-thomas-pregame-red.jpg" />
<meta property="og:title" content="Isaiah Thomas making progress, could join Cleveland Cavaliers earlier | NBA.com" />
<meta property="og:description" content="INDEPENDENCE, Ohio (AP)&amp;nbsp; -- Day by day, dribble by dribble , Isaiah Thomas looks a little more like an All-Star point guard - like himself.

And just maybe like one who can rescue the reeling " />
<meta property="og:url" content="http://www.nba.com/article/2017/11/07/isaiah-thomas-progress-cavaliers" />
<meta property="og:type" content="article" />
<meta property="twitter:image" content="https://cdn.nba.net/nba-drupal-prod/2017-11/isaiah-thomas-pregame-red.jpg" />
<meta property="twitter:title" content="Isaiah Thomas making progress, could join Cleveland Cavaliers earlier | NBA.com" />
<meta property="twitter:description" content="INDEPENDENCE, Ohio (AP)&amp;nbsp; -- Day by day, dribble by dribble , Isaiah Thomas looks a little more like an All-Star point guard - like himself.

And just maybe like one who can rescue the reeling " />
<meta property="twitter:url" content="http://www.nba.com/article/2017/11/07/isaiah-thomas-progress-cavaliers" />
<link rel="shortlink" href="/node/186548" />
<link rel="revision" href="/article/2017/11/07/isaiah-thomas-progress-cavaliers" />
<link rel="amphtml" href="https://www.nba.com/amp/league/article/2017/11/07/isaiah-thomas-progress-cavaliers" />
<title>Isaiah Thomas making progress, could join Cleveland Cavaliers earlier | NBA.com</title><link rel="stylesheet" href="/modules/custom/nba_cvp/css/cvp.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/ajax-progress.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/align.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/autocomplete-loading.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/fieldgroup.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/container-inline.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/clearfix.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/details.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/hidden.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/item-list.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/js.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/nowrap.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/position-container.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/progress.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/reset-appearance.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/resize.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/sticky-header.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/tabledrag.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/tablesort.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/core/themes/stable/css/system/components/tree-child.module.css?oyszjk" media="all" />
<link rel="stylesheet" href="/modules/contrib/anchor_link/css/anchor_link.css?oyszjk" media="all" />
<link rel="stylesheet" href="/themes/custom/league/assets/css/style.css?oyszjk" media="all" />
<link rel="stylesheet" href="/themes/custom/membership/css/membership/import/header.css?oyszjk" media="all" />

<!--[if lte IE 8]>
<script src="/core/assets/vendor/html5shiv/html5shiv.min.js?v=3.7.3"></script>
<![endif]-->
<script src="/core/assets/vendor/modernizr/modernizr.min.js?v=3.3.1"></script>
<script src="//nexus.ensighten.com/turner/nba-prod/Bootstrap.js"></script>
<link rel="icon" href="http://cdn.nba.net/assets/icons/favicon16.ico" type="image/x-icon" /><link rel="apple-touch-icon" href="http://cdn.nba.net/assets/icons/apple-touch-icon.png" type="image/png" /><meta property="og:site_name" content="NBA.com" /><meta name="twitter:site" content="@NBAcom"><meta property="twitter:card" content="summary_large_image" /><script>
      //
      (function (namespace,settings,w,d,undefined) {
        if (!w[namespace]) {
          w[namespace] = {};
        }
        if (!w[namespace][settings]) {
          w[namespace][settings] = {};
        }
        w[namespace][settings].geo = {
          countryCode:"US",
          regionCode:"VA",
          postalCodes:"20146-20149",
          networkType:"hosted"
        };

        w[namespace][settings].device = {
          os:"device_os",
          osVersion:"device_os_version"
        };
      }("_client","settings",window,document));
      //</script></head><body class=" path-node node--type-article  geo-US"><script>
      // Webviews
      var is_webview = document.location.search.slice(1).split('&').filter(function(d){ return 'experience=app' === d; }).length;
      if (is_webview) {
        document.querySelector('body').classList.add('webviews-app');
        document.querySelector('html').classList.add('webviews-app-html');
      }
    </script><div><section id="block-notificationsblock" class="block-notificationsblock"><div ></div></section><section id="block-analyticsmetasblock" class="block-analyticsmetasblock"><div ><script>

  ;(function _metadata_init(w) {

    w.turner_metadata = {

      /* ------------------------------------------------------------------- *
       * Basic Information
       * ------------------------------------------------------------------- */
      analyticsVersion : "2.0",
      appName          : "app:nba - desktop",
      entity           : "league:nba",
      turnerId         : "aa41822-1193725393-1389694715530-1",

      /* ------------------------------------------------------------------- *
       * Game - need live game to review this
       * ------------------------------------------------------------------- */
      gameId      : "none",
      gameQuarter : "none",
      gameState   : "none",

      /* ------------------------------------------------------------------- *
       * Entity
       * ------------------------------------------------------------------- */
      playerId : "none",
      teamId   : "none",

      /* ------------------------------------------------------------------- *
       * Branding - awaiting final ads code push
       * ------------------------------------------------------------------- */
      sponsor : "none",

      /* ------------------------------------------------------------------- *
       * Article Information
       * ------------------------------------------------------------------- */
      articleCategory    : "none",
      articleTitle       : "none",
      articleAuthor      : "none",
      articlePublishDate : "none",
      articleTags        : "none",
      offsiteSource      : "Responsive Web"
    }

  }(window));

</script><script async="async" data-client-id="MciousnsysXuwtD" type="text/javascript" src="//d2lv4zbk7v5f93.cloudfront.net/esf.js"></script></div></section></div><a href="#main" class="visually-hidden focusable skip-link">
      Skip to main content
    </a><section class="off-canvas-wrap" data-offcanvas><div class="inner-wrap"><aside class="left-off-canvas-menu"></aside><aside class="right-off-canvas-menu"></aside><div class="headerWrapper"><header class="nba-nav-header"><section class="nba-nav-wrapper"><nav role="navigation" aria-labelledby="block-mainnavigation-menu" id="block-mainnavigation" class="block-mainnavigation"><h2 class="block-title visually-hidden" id="block-mainnavigation-menu">Main navigation</h2><nav class="nba-nav nba-primary-nav"><div class="nba-nav__container nba-nav__container--left"><button class="nba-nav__container--button"></button><a title="Home" class="nba-nav__container--logo" href="/"></a></div><div class="nba-nav__container nba-nav__container--center"><ul class="nba-nav__container--center-menu" data-dropdown-menu><li  class="nba-nav__container--center-menu-item"><a href="/scores" data-drupal-link-system-path="scores">Scores</a></li><li  class="nba-nav__container--center-menu-item"><a href="http://stats.nba.com/schedule">Schedule</a></li><li  class="nba-nav__container--center-menu-item"><a href="/news" data-drupal-link-system-path="node/131240">News</a></li><li  class="nba-nav__container--center-menu-item"><a href="/video" data-drupal-link-system-path="node/131241">Video</a></li><li  class="nba-nav__container--center-menu-item"><a href="/standings" data-drupal-link-system-path="standings">Standings</a></li><li  class="nba-nav__container--center-menu-item"><a href="http://stats.nba.com/">Stats</a></li><li  class="nba-nav__container--center-menu-item"><a href="/players" data-drupal-link-system-path="players">Players</a></li><li  class="nba-nav__container--center-menu-item"><a href="/teams" data-drupal-link-system-path="teams">Teams</a></li></ul></div><div class="nba-nav__container nba-nav__container--right"><ul class="nba-nav__container--right-add-to-secondary"><li class="nba-nav__container--right-item nba-nav__store-item"><a class="nba-nav__store">Shop</a><ul class="nba-nav__submenu"><li><a href="http://global.nba.com/store-link-handler/" class="nba-nav__store-store-link" >Store</a></li><li><a href="http://global.nba.com/store-link-handler/?cat=nba_jerseys">Jerseys</a></li><li><a href="http://global.nba.com/store-link-handler/?cat=nba_mens">Men</a></li><li><a href="http://global.nba.com/store-link-handler/?cat=nba_womens">Women</a></li><li><a href="http://global.nba.com/store-link-handler/?cat=nba_kids">Kids </a></li><li><a href="http://global.nba.com/store-link-handler/?cat=nba_customshop">Custom Shop</a></li><li><a href="http://global.nba.com/store-link-handler/?cat=nba_classics">Hardwood Classics</a></li><li><a href="http://global.nba.com/store-link-handler/?cat=nba_headwear">Hats </a></li><li><a href="http://global.nba.com/store-link-handler/?cat=nba_footwear">Footwear </a></li><li><a href="http://auctions.nba.com/?utm_source=NBA.com%20Web&utm_medium=Site%20Link&utm_campaign=NBA.com%20Web%20Clicks">Auctions </a></li><li><a href="http://nbagameworn.com/?utm_source=NBA.com%20Web&utm_medium=Website%20link&utm_campaign=NBA.com%20Web%20Link">NBA Game Worn</a></li><li><a href="http://nbanyc.fanatics.com/">NYC Store</a></li><li><a href="https://photostore.nba.com/">NBA Photo Store</a></li></ul></li><li class="nba-nav__container--right-item"><a class="nba-nav__tickets" href="//nbatickets.nba.com">Tickets</a></li><li class="nba-nav__container--right-item nba-nav__lp-item "><a class="nba-nav__lp" href="/leaguepass">NBA League Pass</a></li></ul><ul class="nba-nav__container--right-fixed"><li class="nba-nav__account-item nba-nav__container--right-item"><a class="nba-nav__account"></a><ul class="nba-nav__submenu"><li><scoreboard-score-toggle></scoreboard-score-toggle></li></ul></li></ul></div></nav></nav><nav role="navigation" aria-labelledby="block-mainaccordionmenu-menu" id="block-mainaccordionmenu" class="block-mainaccordionmenu"><h2 class="block-title visually-hidden" id="block-mainaccordionmenu-menu">Main Accordion Menu</h2><aside class="nba-secondary-nav__wrapper"><nav class="nba-secondary-nav__container"><section class="nba-secondary-nav__ss--left-slide"><ul class="nba-secondary-nav__list--top"></ul><span class="nba-secondary-nav__list--item-more hide-for-medium">More</span></section><section class="nba-secondary-nav__search-link" ><ul><li><a href="/search" title="Search Site" class="nba-nav__search" ></a></li></ul></section><section class="nba-secondary-nav__ss--right-slide"><ul class="nba-secondary-nav__list--middle" role="menu"><li class="nba-secondary-nav__list--item nba-secondary-nav__list--item-back hide-for-medium"><span>Back</span></li><li class="hide-for-medium" ><a href="/search" title="Search Site" class="nba-nav__search" ></a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="/leaguepass" data-drupal-link-system-path="node/181724">BUY NBA LEAGUE PASS</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="/vr" data-drupal-link-system-path="node/149032">NBA VR</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://www.nba.com/nbatv">NBA TV</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://stats.nba.com/schedule/#!/?rfr=nba">Full Schedule</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="/key-dates" data-drupal-link-system-path="node/146806">Key Dates</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://www.nba.com/freeagents/2017">Free Agent Tracker</a></li><li class="nba-secondary-nav__list--item nba-secondary-nav__list--item--dropdown"><a href="http://www.nba.com">NBA Events</a><ul class="menu"><li><a href="/allstar" data-drupal-link-system-path="node/184767">2018 All-Star Game</a></li><li><a href="/summerleague" data-drupal-link-system-path="node/175023">2017 Summer League</a></li><li><a href="/draft" data-drupal-link-system-path="node/164496">2017 NBA Draft</a></li><li><a href="/NBAawards" data-drupal-link-system-path="node/173672">2017 NBA Awards</a></li><li><a href="http://www.nba.com/playoffs/">2017 NBA Playoffs</a></li></ul></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="/fantasy/collection" data-drupal-link-system-path="node/131454">Fantasy</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://www.nba.com/history">NBA History</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="/inplay" data-drupal-link-system-path="node/157074">NBA InPlay</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://wnba.com/">WNBA</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://www.nba.com/dleague/?ls=iref:nba:gfooter">NBA G League</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://cares.nba.com/">NBA Cares</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://jr.nba.com/">Jr. NBA</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="https://nbaacademy.nba.com/">NBA Academy</a></li><li class="nba-secondary-nav__list--separator nba-secondary-nav__list--item"><a href="http://pr.nba.com/">NBA Communications</a></li><li class="nba-secondary-nav__list--item nba-secondary-nav__list--item--dropdown"><a href="http://official.nba.com/">NBA Official</a><ul class="menu"><li><a href="/news/officiating" data-drupal-link-system-path="node/146807">Officiating News</a></li><li><a href="http://official.nba.com/referee-assignments/">Daily Ref Assignments</a></li><li><a href="http://official.nba.com/replay/">Replay Center</a></li><li><a href="http://videorulebook.nba.com/">Video Rulebook</a></li></ul></li><li class="nba-secondary-nav__list--item nba-secondary-nav__list--item--dropdown"><a href="" data-drupal-link-system-path="&lt;front&gt;">NBA Initiatives</a><ul class="menu"><li><a href="https://thisiswhyweplay.nba.com/" title="This Is Why We Play">This Is Why We Play</a></li><li><a href="http://green.nba.com/">NBA Green</a></li><li><a href="http://fit.nba.com/">NBA Fit</a></li><li><a href="http://hoopsfortroops.nba.com/">Hoops For Troops</a></li><li><a href="http://www.nba.com/enebea/index.html">Ene-be-a</a></li></ul></li><li class="nba-secondary-nav__list--item nba-secondary-nav__list--item--dropdown"><a href="" data-drupal-link-system-path="&lt;front&gt;">NBA Info</a><ul class="menu"><li><a href="/news/about" data-drupal-link-system-path="node/146803">About The NBA</a></li><li><a href="/news/faq" data-drupal-link-system-path="node/146804">NBA FAQs</a></li><li><a href="http://stats.nba.com/transactions/">Transactions</a></li><li><a href="http://careers.nba.com/">Careers</a></li><li><a href="http://contact.nba.com/">Contact Us</a></li><li><a href="http://www.nba.com/history">NBA History</a></li><li><a href="/news/nba-register-and-nba-guide" data-drupal-link-system-path="node/146805">NBA Guide &amp; Register</a></li><li><a href="http://auctions.nba.com/?utm_source=NBA.com%20Responsive&amp;utm_medium=Site%20Link&amp;utm_campaign=NBA.com%20Mobile%20Clicks">Auctions</a></li><li><a href="https://photostore.nba.com/">NBA Photostore</a></li><li><a href="http://nbanyc.fanatics.com/">NYC Store</a></li><li><a href="https://globalstores.nba.com/">Global Stores</a></li></ul></li></ul></section></nav></aside></nav></section></header><div><section id="block-globalheaderadblock" class="block-globalheaderadblock"><div ><div class="nba-ad-container light-gray global-nav"><div class="nba-ad-wrap-has-singleton-left"><div id="ad_bnr_atf_01" class="nba-ad dfp"></div><div class="nba-ad freewheel desktop-only"><span id="desktop_nav" class="_fwph" style="font-size:0px;"><form id="_fw_form_desktop_nav" style="display:none;"><input type="hidden" name="_fw_input_desktop_nav" id="_fw_input_desktop_nav" value="w=728&h=90&envp=g_js&sflg=-nrpl;"></form><span id="_fw_container_desktop_nav_companion" class="_fwac"></span><span id="_fw_container_desktop_nav" class="_fwac"></span></span></div><div class="nba-ad freewheel mobile-only"><span id="mobile_nav" class="_fwph" style="font-size:0px;"><form id="_fw_form_mobile_nav" style="display:none;"><input type="hidden" name="_fw_input_mobile_nav" id="_fw_input_mobile_nav" value="w=320&h=50&envp=g_js&sflg=-nrpl;"></form><span id="_fw_container_mobile_nav_companion" class="_fwac"></span><span id="_fw_container_mobile_nav" class="_fwac"></span></span></div></div><div class="global-banner-ad-200-90"><div id="ad_mod_92f78ded2" class="nba-ad"></div></div></div></div></section></div></div><div class="row"></div><section id="main" class="row expanded nba-display-detail" role="main"><div id="content" role="region" class=""><button class="content__back nba-toggle-sidebar" title="Back To Sidebar">&#10094; Back</button><div><section id="block-league-content" class="block-league-content"><div ><article  role="article" about="/article/2017/11/07/isaiah-thomas-progress-cavaliers" typeof="schema:Article"><div class="article__detail--container"><div class="article__detail--header-wrapper"><div class="large-8 large-offset-2 small-12"><div class="article__detail--header"><h2 class="article__detail--header-text">Isaiah Thomas making progress, could join Cleveland Cavaliers earlier</h2><h3 class="article__detail--subhead"></h3><div class="article__detail--writer-profile"><p>Tom Withers | The Associated Press <span></span></p><p class="article__detail--date"><span>Nov 7, 2017 9:04 AM ET</span></p></div></div></div></div><div class="large-8 large-offset-2 small-12"><div class="main"><div class="field-wrapper field field-node--field-main-image field-name-field-main-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item"><img sizes="(min-width: 85.375em) 44.8125em, (min-width: 64em) 47.75vw, (min-width: 48.063em) 65.10vw, 100vw" src="data:image/gif;base64,R0lGODlhAQABAIABAP///wAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="" class="lazyload responsive" data-srcset="https://cdn.nba.net/nba-drupal-prod/styles/landscape_320w/s3/2017-11/isaiah-thomas-pregame-red.jpg?itok=KwrfQFkb 320w, https://cdn.nba.net/nba-drupal-prod/styles/landscape_640w/s3/2017-11/isaiah-thomas-pregame-red.jpg?itok=N91o9gtJ 640w, https://cdn.nba.net/nba-drupal-prod/styles/landscape_1045w/s3/2017-11/isaiah-thomas-pregame-red.jpg?itok=0URjjHal 1045w, https://cdn.nba.net/nba-drupal-prod/styles/landscape_1280w/s3/2017-11/isaiah-thomas-pregame-red.jpg?itok=pBTy_vqo 1280w, https://cdn.nba.net/nba-drupal-prod/styles/landscape_2090w/s3/2017-11/isaiah-thomas-pregame-red.jpg?itok=YzKohYPN 2090w" data-src="data:image/gif;base64,R0lGODlhAQABAIABAP///wAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-sizes="(min-width: 85.375em) 44.8125em, (min-width: 64em) 47.75vw, (min-width: 48.063em) 65.10vw, 100vw" typeof="foaf:Image" /></div></div></div><p class="article__detail--inline-caption">
            Isaiah Thomas has picked it up in workouts as he continues to rehab from a hip injury.
          </p></div><div class="paragraphs"><div class="field-wrapper field field-node--field-article-body field-name-field-article-body field-type-entity-reference-revisions field-label-hidden"><div class="field-items"><div class="field-item"><div class="paragraph__text"><div class="field-wrapper field field-paragraph--field-text-slice field-name-field-text-slice field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item"><p><strong>INDEPENDENCE, Ohio (AP)</strong>  -- Day by day, dribble by dribble , Isaiah Thomas looks a little more like an All-Star point guard - like himself.</p><p>And just maybe like one who can rescue the reeling Cavaliers.</p><p>Thomas has been increasing the intensity of his workouts and is making strong progress in his recovery from a serious hip injury that ended his 2016 season in Boston and delayed his debut with Cleveland.</p><p>As Cavs coach Tyronn Lue and a member of Cleveland's medical staff kept an eye on him from an adjacent floor at Cleveland Clinic Courts, Thomas broke a healthy sweat during a workout Monday under the guidance of assistant coach Phil Handy, who fired him passes and praise. Thomas worked on his 3-pointer , man-to-man defense, conditioning, ball handling and free throws as he nears a return that may be coming sooner than imagined.</p><p>Although the team has not disclosed any change from its original timetable estimate of the end of December, it's apparent that Thomas is getting closer.</p><p>At 4-6, and lacking a second scorer to complement LeBron James, the Cavs might be tempted to rush Thomas along. But Lue said it's imperative for the team to stick with its plan so as not to harm the 28-year-old.</p><p>"We have to make sure he's 100 percent," Lue said Monday as the Cavs regrouped following an embarrassing loss to the Atlanta Hawks. "We have to worry about him as a player and a person. If he's not right, not healthy, we don't want to rush him back to set him back even more."</p><p>Thomas isn't keeping his status any kind of secret. In the first few weeks of his rehab, he kept a lower profile as he worked out in the team's facility away from reporters and cameras. Lately, he's been front and center, giving everyone a glimpse of the strides he's made in coming back from a torn labrum.</p><p>Lue credited Cleveland's training staff with a slow, steady approach in bringing along Thomas, who came to the Cavs in the blockbuster trade last summer that sent Kyrie Irving to the Boston Celtics.</p><p>Irving and the Celtics have won nine straight and lead the Eastern Conference. Meanwhile, Cleveland has remained patient, although it's clear that Thomas can't wait to get back onto the floor in meaningful games.</p><p>"I just wanna HOOP!!!!!" he tweeted Sunday night.</p><blockquote class="twitter-tweet"><p lang="en" dir="ltr" xml:lang="en">I️ just wanna HOOP!!!!!</p>— Isaiah Thomas (@Isaiah_Thomas) <a href="https://twitter.com/Isaiah_Thomas/status/927386838620409856?ref_src=twsrc%5Etfw">November 6, 2017</a></blockquote><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>The Cavs need him. Without Irving, the Eastern Conference champions lack a proven scorer to take some pressure off James. Thomas won't help Cleveland's suspect defense. In fact, it might be a little worse with him on the court, but its offense would go to another level with Thomas.</p><p>He can drive. He can shoot. He can get to the line.</p><p>"We still have a 30-point scorer, All-Star point guard that's coming soon," James said recently. "So that's exciting."</p><p>Once he returns, Thomas is expected to move into the starting lineup, with Derrick Rose coming off the bench and running the Cavs' second unit. It's been dreadful starts by the Cavs' first five that have been at the heart of their early struggles. Thomas could fix that, but until he's ready, the Cavs have to come out with more energy and a greater sense of urgency.</p><p>Thomas should also help Cleveland's woeful 3-point shooting. The Cavs enter Tuesday night's game against Milwaukee 25th in the league in 3-point accuracy (33 percent) and tied for 16th in 3-pointers made per game. Thomas made a Celtics record 245 3-pointers last season and knocked down at least one in 57 straight games.</p><p>Against the Hawks, the Cavs started 3 of 25 from behind the arc and finished 10 of 36 - thanks mostly to Kyle Korver heating up during a fourth-quarter comeback.</p><p>"We have guys that can shoot the ball," said Kevin Love, who was taken to the hospital Sunday after falling ill. "I don't know what it says on pace, but last year we really pushed the ball with 'Bron and Ky and really opened up the floor. But we're just not shooting the ball well from 3, and that has to change."</p><p>There need to be other changes, and Lue said it's time for his team to begin making them.</p><p>"Just have to keep attacking it," he said. "Have to keep showing film and continue to keep talking about it. I think guys are embarrassed and we should be embarrassed of how we're getting beat. Teams that we're playing, having guys out, key guys out and still not being able to win. We all have to continue to keep searching and continue to keep fighting and continue to play hard."</p><p>And at some point, they might get some help.</p></div></div></div></div></div></div></div></div></div></div></article></div></section></div><div><section id="block-homepagefooter" class="block-homepagefooter"><div ><hr><p>Copyright &copy; <em class="placeholder">2017</em> NBA Media Ventures, LLC. All rights reserved.</p><p><a href="http://www.nba.com/news/privacy_policy.html">Privacy Policy</a> | <a href="http://www.nba.com/closed_captioning">Accessibility and Closed Caption</a> | <a href="http://www.nba.com/news/termsofuse">Terms of Use</a> | <a id="nba_cnsnt_trst" class="nbaAdChoices"></a><p>NBA.com is part of Turner Sports Digital, part of the Turner Sports &amp; Entertainment Digital Network.</p><img alt="Turner Broadcasting System, Inc. A Time Warner Company." data-align="center" data-entity-type="file" src="//i.cdn.turner.com/nba/nba/footer/turner_logo_200x35.png" /></div></section></div></div><aside id="main_sidebar" role="region"><div><section id="block-collectionlistblock" class="block-collectionlistblock"><div ><div class="article__detail--sidebar"><nav class="sectiontabs"><ul><li><p><a href="/news" data-drupal-link-system-path="node/131240">Now</a></p><div class="overlay"><div><ul><li><a href="http://www.nba.com/news">NBA News</a></li><li><a href="/" data-drupal-link-system-path="&lt;front&gt;">Topics</a><ul><li><a href="/blogtable" data-drupal-link-system-path="node/147356">Blogtable</a></li><li><a href="/david-aldridge" data-drupal-link-system-path="node/131456">DA&#039;s Morning Tip</a></li><li><a href="/dunkhq" data-drupal-link-system-path="node/152872">Dunk HQ</a></li><li><a href="/fantasy" data-drupal-link-system-path="node/131453">Fantasy</a></li><li><a href="/around-the-league" data-drupal-link-system-path="node/147355">Around The League</a></li><li><a href="/podcast" data-drupal-link-system-path="node/147464">Podcast</a></li><li><a href="/powerrankings" data-drupal-link-system-path="node/131458">Power Rankings</a></li><li><a href="/fool" data-drupal-link-system-path="node/148429">Shaqtin&#039; A Fool</a></li><li><a href="/mvp-ladder" data-drupal-link-system-path="node/151156">Kia Race to the MVP</a></li><li><a href="/rookie-ladder" data-drupal-link-system-path="node/131459">Kia Rookie Ladder</a></li><li><a href="/top-plays" data-drupal-link-system-path="node/153030">Kia Top Plays Theatre</a></li></ul></li><li><a href="/" data-drupal-link-system-path="&lt;front&gt;">Events</a><ul><li><a href="/allstar" data-drupal-link-system-path="node/184767">2018 All-Star Game</a></li><li><a href="/summerleague" data-drupal-link-system-path="node/175023">2017 Summer League</a></li><li><a href="http://www.nba.com/draft">2017 NBA Draft</a></li><li><a href="/nbaawards/2017/finalists" data-drupal-link-system-path="node/175489">2017 NBA Awards</a></li><li><a href="/playoffs" data-drupal-link-system-path="playoffs">2017 NBA Playoffs</a></li></ul></li><li><a href="/writer/archive" data-drupal-link-system-path="node/148070">Writer Archive</a></li></ul></div></div></li></ul><div id="sectiontabs-cover" class="reveal-overlay"></div></nav><collection-list></collection-list></div></div></section></div></aside></section></div></section><script>
      if (is_webview) {
        document.querySelector('#block-globalheaderadblock').remove();
      }
    </script><script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/186548","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ajaxPageState":{"libraries":"anchor_link\/drupal.anchor_link,core\/html5shiv,core\/picturefill,league\/ensighten-prod,league\/global,league\/lazyload,league\/parse-ly,league\/sourcepoint,nba\/nba_blackout,nba\/nba_headshot,nba_ads\/nba_articles.ad_registry,nba_ads\/nba_pages.global_banner_ad,nba_angular\/nba_angular.game,nba_block_homepagefooter\/nba_block_homepagefooter.truste,nba_collection\/nba_collection.ad_registry,nba_collection\/nba_collection.tile_selector,nba_notifications\/notificationDisplay,system\/base,zurb_foundation\/global","theme":"league","theme_token":null},"ajaxTrustedUrl":[],"displayed_entity_uuid":[],"collection_uuid":"47b76848-028b-4536-9c9c-37379d209639","CAPI_URL":"https:\/\/api.nba.net\/0","ENV":"prod","NUGGET_API":"\/\/subscriber11.turner.com:4711","site_url":"http:\/\/www.nba.com","secure_url":"https:\/\/secure.nba.com","storefront_url":"https:\/\/account.nba.com\/","membership_api":"https:\/\/audience.nba.com","sdata_url":"https:\/\/data.nba.net","sdata_url_path":"prod","sdata_path":"prod","free_preview":"none","GEO_URL":"\/\/geo.nba.com\/api\/geo","user":{"uid":0,"permissionsHash":"282b49902c7f9b837aa5dc5e99c2a248ffdc2225d4c77b5afa94b960b1d31686"}}</script>
<script src="/core/assets/vendor/domready/ready.min.js?v=1.0.8"></script>
<script src="/core/assets/vendor/jquery/jquery.min.js?v=2.2.3"></script>
<script src="/core/assets/vendor/jquery-once/jquery.once.min.js?v=2.1.1"></script>
<script src="/core/misc/drupalSettingsLoader.js?v=8.2.7"></script>
<script src="/core/misc/drupal.js?v=8.2.7"></script>
<script src="/core/assets/vendor/picturefill/picturefill.min.js?v=3.0.1"></script>
<script src="/modules/custom/nba/js/blackout.js?oyszjk"></script>
<script src="/modules/custom/nba/js/headshot.js?oyszjk"></script>
<script src="/core/assets/vendor/jquery.cookie/jquery.cookie.min.js?v=1.4.1"></script>
<script src="/modules/custom/nba_p13n/js/nba_p13n.js?v=1.x"></script>
<script src="/js/foundation/foundation.min.js?oyszjk"></script>
<script src="/themes/custom/league/assets/js/nav.js?oyszjk"></script>
<script src="/themes/custom/league/assets/js/toggleSidebar.js?oyszjk"></script>
<script src="/themes/custom/league/assets/js/player-stats.js?oyszjk"></script>
<script src="/themes/custom/league/assets/js/scoreboard.js?oyszjk"></script>
<script src="/themes/custom/league/assets/js/sectiontabs-overlay.js?oyszjk"></script>
<script src="/modules/custom/nba/js/namespaceTools.js?oyszjk"></script>
<script src="/modules/custom/nba/js/polyfill.js?oyszjk"></script>
<script src="/modules/custom/nba/js/tos/tos.js?oyszjk"></script>
<script src="//ssl.cdn.turner.com/ads/adfuel/ais/nba2-ais.js"></script>
<script src="//ssl.cdn.turner.com/ads/adfuel/adfuel-1.2.4.min.js"></script>
<script src="/modules/custom/nba_ads/js/adfuel-tagging.js?oyszjk"></script>
<script src="/themes/custom/league/assets/js/lazyload-config.js?oyszjk"></script>
<script src="/libraries/lazy/lazysizes.min.js?oyszjk"></script>
<script src="/libraries/lazy/plugins/unveilhooks/ls.unveilhooks.min.js?oyszjk"></script>
<script src="/themes/custom/league/assets/js/sourcepoint/config.js?oyszjk"></script>
<script src="/themes/custom/league/assets/js/parse_ly.js?oyszjk"></script>
<script src="/modules/custom/nba_ads/js/sidebar-ads.js?oyszjk"></script>
<script src="/modules/custom/nba_collection/js/adInit.js?oyszjk"></script>
<script src="/modules/custom/nba_collection/js/tileSelector.js?oyszjk"></script>
<script src="/core/misc/progress.js?v=8.2.7"></script>
<script src="/core/modules/responsive_image/js/responsive_image.ajax.js?v=8.2.7"></script>
<script src="/core/misc/ajax.js?v=8.2.7"></script>
<script src="/core/assets/vendor/jquery-form/jquery.form.min.js?v=3.51"></script>
<script src="/modules/custom/nba_cvp/js/lib/namespaceTools.js?oyszjk"></script>
<script src="/modules/custom/nba_cvp/js/lib/polyfill.js?oyszjk"></script>
<script src="/modules/custom/nba_cvp/js/lib/logger.js?oyszjk"></script>
<script src="/modules/custom/nba_cvp/js/lib/pubsub.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/membership-settings.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/namespaceTools.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/cookie.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/polyfill/dataset.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/querystring.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/storage.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/logger.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/pubsub.js?oyszjk"></script>
<script src="/themes/custom/membership/js/settings/membership.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/errorHandler.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/format.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/authcode.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/authsignature.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/cookie.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/follow.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/redirect.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/sso.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/test.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/import/display.js?oyszjk"></script>
<script src="/themes/custom/membership/js/membership/import/link.js?oyszjk"></script>
<script src="/themes/custom/membership/js/lib/jquery/parsley.js?oyszjk"></script>
<script src="/modules/custom/nba_membership/js/dalton.js?oyszjk"></script>
<script src="//www.nba.com/ng/game/inline.bundle.js"></script>
<script src="//www.nba.com/ng/game/polyfills.bundle.js"></script>
<script src="//www.nba.com/ng/game/vendor.bundle.js"></script>
<script src="//www.nba.com/ng/game/main.bundle.js"></script>
<script src="//consent.truste.com/notice?domain=turner.com&amp;c=nba_cnsnt_trst&amp;text=true&amp;country=us"></script>
<script src="/core/assets/vendor/matchMedia/matchMedia.min.js?v=0.2.0"></script>
<script src="//ssl.cdn.turner.com/ads/nba2/nba_articles.js"></script>
<script src="/modules/custom/nba_ads/js/global-banner-ad.js?oyszjk"></script>
<script src="/modules/custom/nba_notifications/js/notificationDisplay.js?v=1.x"></script>
<script>
      (function ($) {
        $(document).foundation();

        function getQueryParameters(str) {
          return (str || document.location.search).replace(/(^\?)/,'').split("&").map(function(n){return n = n.split("="),this[n[0]] = n[1],this}.bind({}))[0];
        }

        if (getQueryParameters()['hideLinks']==='true') {
          if (typeof(getQueryParameters()['parent'])==='undefined') {
            $('a').contents().unwrap();
          } else {
            $(decodeURIComponent(getQueryParameters()['parent'])+' a').contents().unwrap();
          }
        }
      })(jQuery);
    </script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"cd6a814e06","applicationID":"26034795","transactionName":"ZwYBMkcCX0tWVxdeXF5MIgVBCl5WGEAMXFZePBMUUDxDXVlQBkVsVgoGClE8RVdcUQ0=","queueTime":0,"applicationTime":748,"atts":"S0ECRA8YTEU=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>